开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 267|回复: 10
收起左侧

[完成] 帮我看看哪里错了?

 关闭 [复制链接]
结帖率:88% (45/51)
发表于 2024-4-17 17:55:24 | 显示全部楼层 |阅读模式   广东省清远市
5精币
屏幕截图 2024-04-17 175222.png

  
子程序名返回值类型公开备 注
测试  
变量名类 型静态数组备 注
num整数型7
i整数型 
ret文本型 
数据数组文本型8
count整数型10
数据数组 = { “”, “3”, “6”, “6”, “6”, “5”, “6”, “9” }
变量循环首 (0, 7, 1, i)
num [i]到整数 (数据数组 [i + 1])
count [num [i] + 1] = count [num [i] + 1] + 1
变量循环尾 ()
数组排序 (num, )
变量循环首 (1, 6, 1, i)
如果真 (i > 0 num [i] - num [i - 1] = 2 count [num [i]] = 0)
ret = ret + 到文本 (num [i] - 1)“, ”

变量循环尾 ()
调试输出 (ret)


i支持库列表   支持库注释   
spec特殊功能支持库


我都懵了,越来绕进去了

最佳答案

查看完整内容

num [0] 肯定是没有的,从1开始 补充内容 (2024-4-17 18:00): num = 到整数 (数据数组 ) 就你这里,右边的你知道 i + 1 直接变量循环从1开始呗

签到天数: 22 天

发表于 2024-4-17 17:55:25 | 显示全部楼层   浙江省杭州市
num [0] 肯定是没有的,从1开始

补充内容 (2024-4-17 18:00):
num = 到整数 (数据数组 [i + 1])  
就你这里,右边的你知道 i + 1
直接变量循环从1开始呗

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

回复

使用道具 举报

结帖率:100% (1/1)

签到天数: 17 天

发表于 2024-4-17 18:00:35 | 显示全部楼层   河南省郑州市
变量循环首 (0, 7

从0到7
一共是8个  溢出了
回复

使用道具 举报

结帖率:85% (22/26)

签到天数: 16 天

发表于 2024-4-17 18:01:30 | 显示全部楼层   广东省广州市
易语言的循环从1开始,不是0
回复

使用道具 举报

结帖率:88% (45/51)

签到天数: 7 天

 楼主| 发表于 2024-4-17 18:05:58 | 显示全部楼层   广东省清远市
black0216 发表于 2024-4-17 17:59
num [0] 肯定是没有的,从1开始

补充内容 (2024-4-17 18:00):

但得出来的结果为什么会是空的?
回复

使用道具 举报

签到天数: 22 天

发表于 2024-4-17 18:07:35 | 显示全部楼层   浙江省杭州市
ato 发表于 2024-4-17 18:05
但得出来的结果为什么会是空的?

额,具体情况具体改,不是直接照搬,你想达到什么效果我也不清楚

补充内容 (2024-4-17 18:09):
看着你这像是别的语言硬翻译过来的代码,不然你上原代码好得多
回复

使用道具 举报

结帖率:88% (45/51)

签到天数: 7 天

 楼主| 发表于 2024-4-17 18:09:00 | 显示全部楼层   广东省清远市
afu45 发表于 2024-4-17 18:00
变量循环首 (0, 7

从0到7

我头脑都蒙了能帮我改改吗?
回复

使用道具 举报

结帖率:75% (3/4)

签到天数: 20 天

发表于 2024-4-17 18:12:58 | 显示全部楼层   江西省南昌市
你没错 错的是整个世界
回复

使用道具 举报

结帖率:88% (45/51)

签到天数: 7 天

 楼主| 发表于 2024-4-17 18:13:14 | 显示全部楼层   广东省清远市
black0216 发表于 2024-4-17 18:07
额,具体情况具体改,不是直接照搬,你想达到什么效果我也不清楚

补充内容 (2024-4-17 18:09):

搞定了,谢谢你哈!!感谢



.版本 2
.支持库 spec

.子程序 测试
.局部变量 num, 整数型, , "7"
.局部变量 i, 整数型
.局部变量 ret, 文本型
.局部变量 数据数组, 文本型, , "8"
.局部变量 count, 整数型, , "10"

数据数组 = { “”, “3”, “6”, “6”, “6”, “5”, “6”, “9” }

.变量循环首 (0, 7, 1, i)
    num <i> = 到整数 (数据数组 [i + 1])
    count [num <i> + 1] = count [num <i> + 1] + 1
.变量循环尾 ()

数组排序 (num, 真)

.变量循环首 (1, 6, 1, i)
    .如果真 (i > 0 且 num <i> - num [i - 1] = 2 且 count [num <i>] = 0)
        ret = ret + 到文本 (num <i> - 1) + “, ”
    .如果真结束

.变量循环尾 ()

调试输出 (ret)

补充内容 (2024-4-17 18:14):
.版本 2
.支持库 spec

.子程序 测试
.局部变量 num, 整数型, , "7"
.局部变量 i, 整数型
.局部变量 ret, 文本型
.局部变量 数据数组, 文本型, , "8"
.局部变量 c...
回复

使用道具 举报

结帖率:100% (1/1)

签到天数: 17 天

发表于 2024-4-17 18:14:29 | 显示全部楼层   河南省郑州市
你的说清楚 你这代码是想实现什么
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表