开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 163|回复: 4
收起左侧

[已解决] JSON

 关闭 [复制链接]
结帖率:91% (162/179)
发表于 2024-4-17 17:20:50 | 显示全部楼层 |阅读模式   海南省儋州市
9精币
图片.png
{"Image":"图片地址","PayeeName":"姓名"}
Image和PayeeName不固定,例如{"ImA":"图片地址","PayeeB":"姓名","Payeeaq1":"姓名"}


怎么判断有多少个属性名,然后解析,点击修改的时候,对应修改内容

最佳答案

查看完整内容

E2EE你值得拥有

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 页面申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:80% (4/5)

签到天数: 11 天

发表于 2024-4-17 17:20:51 | 显示全部楼层   河北省唐山市
QQ截图20240417173130.png


E2EE你值得拥有

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

回复

使用道具 举报

结帖率:91% (119/131)

签到天数: 22 天

发表于 2024-4-17 17:24:17 | 显示全部楼层   福建省泉州市
你要不就弄成data数组
回复

使用道具 举报

结帖率:98% (93/95)

签到天数: 21 天

发表于 2024-4-17 17:24:45 | 显示全部楼层   浙江省温州市
.版本 2
.支持库 spec

.子程序 例子
.局部变量 json_读, 类_json
.局部变量 json_写, 类_json

' ====================读===================
json_读.解析 (#常量1)
' 谷
调试输出 (json_读.取通用属性 (“['Name']”))
' 6791
调试输出 (json_读.取通用属性 (“['Main']”))
' 铜
调试输出 (json_读.取通用属性 (“['OreName']”))
' 银
调试输出 (json_读.取通用属性 (“['HerbalName']”))
' 0
调试输出 (json_读.取通用属性 (“['Home']['Hearthstone']”))
' D
调试输出 (json_读.取通用属性 (“['Home']['Repair']”))
' A
调试输出 (json_读.取通用属性 (“['Home']['Sell']”))
' B
调试输出 (json_读.取通用属性 (“['Home']['Buy']”))
' E
调试输出 (json_读.取通用属性 (“['Home']['Mail']”))
' F
调试输出 (json_读.取通用属性 (“['Home']['Other']”))
' ====================写===================
json_写.置属性 (“Name”, “谷”)
json_写.置属性 (“Main”, “6791”)
json_写.置属性 (“OreName”, “铜”)
json_写.置属性 (“HerbalName”, “银”)
json_写.置属性 (“Home”, “{}”, 真)
json_写.置属性 (“['Home']['Hearthstone']”, “0”, 真)
json_写.置属性 (“['Home']['Repair']”, “D”)
json_写.置属性 (“['Home']['Sell']”, “A”)
json_写.置属性 (“['Home']['Buy']”, “B”)
json_写.置属性 (“['Home']['Mail']”, “E”)
json_写.置属性 (“['Home']['Other']”, “F”)
调试输出 (json_写.取数据文本 ())
回复

使用道具 举报

结帖率:91% (162/179)

签到天数: 20 天

 楼主| 发表于 2024-4-17 17:27:07 | 显示全部楼层   海南省儋州市
q456 发表于 2024-4-17 17:24
你要不就弄成data数组

这个是网页获取的JSON,不是自己生成的
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表