开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 249|回复: 10
收起左侧

[已解决] 这种字节怎么寻找?

 关闭 [复制链接]
结帖率:86% (83/96)
发表于 2024-4-3 10:10:08 | 显示全部楼层 |阅读模式   湖南省邵阳市
30精币
“6A3C68????????E8????????33??”
这种怎么寻找
  
子程序名返回值类型公开备 注
寻字节集通配整数型 
参数名类 型参考可空数组备 注
被搜寻的字节集字节集
欲寻找的字节集字节集
起始搜寻位置整数型
置入代码 ({ 131, 228, 240, 131, 236, 40, 139, 69, 8, 15, 87, 192, 86, 87, 139, 125, 16, 139, 8, 79, 139, 69, 12, 102, 15, 214, 68, 36, 33, 199, 68, 36, 41, 0, 0, 0, 0, 139, 81, 4, 131, 193, 8, 139, 0, 137, 84, 36, 24, 137, 76, 36, 16, 102, 199, 68, 36, 45, 0, 0, 139, 112, 4, 131, 192, 8, 137, 68, 36, 20, 198, 68, 36, 47, 0, 138, 0, 136, 68, 36, 32, 59, 250, 125, 119, 15, 40, 68, 36, 32, 15, 31, 0, 186, 16, 0, 0, 0, 184, 1, 0, 0, 0, 102, 15, 58, 97, 4, 15, 12, 59, 202, 116, 75, 139, 84, 36, 16, 3, 207, 51, 192, 137, 76, 36, 28, 3, 209, 139, 76, 36, 20, 138, 12, 8, 56, 12, 2, 116, 5, 128, 249, 63, 117, 18, 64, 59, 198, 117, 234, 139, 68, 36, 28, 64, 95, 94, 139, 229, 93, 194, 16, 0, 139, 76, 36, 16, 71, 186, 16, 0, 0, 0, 184, 1, 0, 0, 0, 102, 15, 58, 97, 4, 15, 12, 59, 202, 117, 181, 131, 199, 16, 59, 124, 36, 24, 125, 6, 139, 76, 36, 16, 235, 145, 95, 131, 200, 255, 94, 139, 229, 93, 194, 16, 0 })
返回 (0)


我的这种寻找在部分系统上无法搜索的到。求解决。

最佳答案

查看完整内容

楼下的兄弟你们理解错他的意思了,他是用这个‘寻字节集通配’子程序(论坛兄弟开源的,我用过)搜索这个特征码“6A3C68????????E8????????33??”,这个寻字节集通配功能有时候搜索特征码可以搜索得到,但是在某些情况下是搜索不到的。 上面这个是跟你的一样论坛兄弟开源的,可以看一下我里面的备注。 你也可以使用下面图片的搜索特征码办法,这个办法应该是通用一点,我看了几款辅助的自动更新jz软件源码,基本都是用这个特征码搜 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 页面申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 14 天

发表于 2024-4-3 10:10:09 | 显示全部楼层   广西壮族自治区贵港市
楼下的兄弟你们理解错他的意思了,他是用这个‘寻字节集通配’子程序(论坛兄弟开源的,我用过)搜索这个特征码“6A3C68????????E8????????33??”,这个寻字节集通配功能有时候搜索特征码可以搜索得到,但是在某些情况下是搜索不到的。
QQ截图20240403105202.png
上面这个是跟你的一样论坛兄弟开源的,可以看一下我里面的备注。
你也可以使用下面图片的搜索特征码办法,这个办法应该是通用一点,我看了几款辅助的自动更新jz软件源码,基本都是用这个特征码搜索的,只要用对是没啥大问题的。
QQ截图20240403105021.png ,这个论坛搜索一下特征码就有这个源码了
回复

使用道具 举报

结帖率:94% (34/36)

签到天数: 12 天

发表于 2024-4-3 10:16:27 | 显示全部楼层   广西壮族自治区梧州市
这个编码是怎么意思的,WG ? 打补丁?     
回复

使用道具 举报

结帖率:100% (1/1)

签到天数: 11 天

发表于 2024-4-3 10:34:01 | 显示全部楼层   北京市北京市
回复

使用道具 举报

结帖率:100% (5/5)

签到天数: 17 天

发表于 2024-4-3 10:42:27 | 显示全部楼层   河南省平顶山市
问号 是什么意思?
回复

使用道具 举报

结帖率:94% (34/36)

签到天数: 12 天

发表于 2024-4-3 12:29:52 | 显示全部楼层   广西壮族自治区梧州市
想想不能,用正则表达式麽??呵呵
回复

使用道具 举报

结帖率:86% (83/96)

签到天数: 13 天

 楼主| 发表于 2024-4-3 12:36:54 | 显示全部楼层   湖南省邵阳市
背靠背拥抱 发表于 2024-4-3 10:58
楼下的兄弟你们理解错他的意思了,他是用这个‘寻字节集通配’子程序(论坛兄弟开源的,我用过)搜索这个特征 ...

你这个源码可以提供下吗。我论坛没搜到哦
回复

使用道具 举报

结帖率:86% (83/96)

签到天数: 13 天

 楼主| 发表于 2024-4-3 22:51:27 | 显示全部楼层   湖南省邵阳市
背靠背拥抱 发表于 2024-4-3 10:58
楼下的兄弟你们理解错他的意思了,他是用这个‘寻字节集通配’子程序(论坛兄弟开源的,我用过)搜索这个特征 ...

老铁麻烦帮忙给个源码,论坛没找到哈
回复

使用道具 举报

签到天数: 14 天

发表于 2024-4-3 23:09:17 | 显示全部楼层   广西壮族自治区贵港市
kuangshen1 发表于 2024-4-3 22:51
老铁麻烦帮忙给个源码,论坛没找到哈

.版本 2

.子程序 寻找字节集_通配符, 整数型
.参数 被搜寻的字节集, 字节集
.参数 欲寻找的字节集, 文本型, , 不能[??]和[00 ??]当作开头
.参数 起始搜寻位置, 整数型, 可空, 可以被省略。1为首位置,2为第2个位置,如此类推,如果被省略,则“寻找字节集”命令默认从首部开始,“倒找字节集”命令默认从尾部开始
.局部变量 临_数据地址, 整数型
.局部变量 临_数据大小, 整数型
.局部变量 临_搜索地址, 整数型
.局部变量 临_寻找的字节集, 字节集
.局部变量 临_匹配内容, 文本型
.局部变量 临_文本, 文本型
.局部变量 临_位置, 整数型

.如果真 (是否为空 (起始搜寻位置))
    起始搜寻位置 = 1
.如果真结束
临_数据地址 = 取字节集指针 (被搜寻的字节集) + 起始搜寻位置 - 1
临_数据大小 = 取字节集长度 (被搜寻的字节集) - 起始搜寻位置 + 1
临_搜索地址 = 1
临_匹配内容 = 删全部空 (欲寻找的字节集)
.如果真 (取文本长度 (临_匹配内容) % 2 ≠ 0)  ' 搜索的字节集错误
    返回 (-1)
.如果真结束
.如果真 (取文本长度 (临_匹配内容) ÷ 2 > 临_数据大小)  ' 搜索内容大于被搜索的内容,没的找。
    返回 (-1)
.如果真结束
.如果真 (取文本长度 (临_匹配内容) ÷ 2 > 255)  ' 搜索内容大于255,自个升级吧。
    返回 (-1)
.如果真结束
临_位置 = -1
.判断循环首 (临_匹配内容 ≠ “”)
    临_文本 = 取文本左边 (临_匹配内容, 2)
    .如果真 (取反 (临_文本 = “**” 或 临_文本 = “??” 或 临_文本 = “4?” 或 临_文本 = “7?”))
        临_寻找的字节集 = 临_寻找的字节集 + 到字节集 (到字节 (临_位置)) + 到字节集 (到字节 (进制_十六到十 (临_文本)))
    .如果真结束
    临_位置 = 临_位置 + 1
    临_匹配内容 = 文本替换 (临_匹配内容, 1, 2, )
.判断循环尾 ()

临_搜索地址 = 取字节集指针 (临_寻找的字节集)
置入代码 ({ 139, 125, 252, 139, 77, 248, 139, 117, 244, 139, 86, 252, 51, 192, 138, 70, 1, 242, 174, 117, 28, 187, 2, 0, 0, 0, 51, 192, 138, 4, 30, 138, 4, 7, 58, 68, 30, 1, 117, 228, 131, 195, 2, 59, 218, 115, 13, 235, 233, 184, 255, 255, 255, 255, 139, 229, 93, 194, 10, 0, 43, 125, 252, 137, 125, 252 })
返回 (临_数据地址 + 起始搜寻位置 - 2)

.版本 2

.子程序 取字节集指针, 整数型
.参数 字节集, 字节集

置入代码 ({ 139, 69, 8, 139, 0, 131, 192, 8, 201, 194, 4, 0 })
' mov eax, dword ptr [ebp+08]
' mov eax, dword ptr [eax]
' add eax, 00000008
' leave
' ret 0004
返回 (0)

回复

使用道具 举报

签到天数: 14 天

发表于 2024-4-3 23:12:59 | 显示全部楼层   广西壮族自治区贵港市
想问一下,怎么发你这种代码格式呀。 QQ截图20240403231041.png
直接就是易语言格式了,好像没看见有易语言格式代码。 QQ截图20240403231234.png
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表