开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 261|回复: 8
收起左侧

[完成] joson解析

 关闭 [复制链接]
结帖率:50% (1/2)
发表于 2024-4-3 01:01:59 | 显示全部楼层 |阅读模式   河北省秦皇岛市
5精币
一个JSON,能解析,却怎么样都获取不到委买和委卖,code等没有问题,请教各位大佬了,没办法了。多谢

hh.txt

35.57 KB, 下载次数: 9, 下载积分: 精币 -1 枚

Json文件

最佳答案

查看完整内容

[e=0].版本 2 .支持库 spec .子程序 __启动窗口_创建完毕 .局部变量 JSON, 类_json .局部变量 loopInt, 整数型 .局部变量 i, 整数型 .局部变量 value, 文本型 .局部变量 最新涨跌幅, 文本型 .局部变量 委买, 文本型 .局部变量 委卖, 文本型 调试输出 (JSON.解析 (取剪辑板文本 (), , )) loopInt = 到整数 (JSON.取通用属性 (“['answer']['components'][0]['data']['datas']['length']”, )) .计次循环首 (loopInt, i) i = ...
结帖率:100% (4/4)

签到天数: 13 天

发表于 2024-4-3 01:02:00 | 显示全部楼层   广东省东莞市
  
子程序名返回值类型公开备 注
__启动窗口_创建完毕  
变量名类 型静态数组备 注
JSON类_json 
loopInt整数型 
i整数型 
value文本型 
最新涨跌幅文本型 
委买文本型 
委卖文本型 
调试输出 (JSON.解析 (取剪辑板文本 (), , ))
loopInt = 到整数 (JSON.取通用属性 (“['answer']['components'][0]['data']['datas']['length']”, ))
计次循环首 (loopInt, i)
i = i - 1
最新涨跌幅 = JSON.取通用属性 (“['answer']['components'][0]['data']['datas'][”到文本 (i)“]['最新涨跌幅']”, )
委买 = JSON.取通用属性 (“['answer']['components'][0]['data']['datas'][”到文本 (i)“]['委买[20240403]']”, )
委卖 = JSON.取通用属性 (“['answer']['components'][0]['data']['datas'][”到文本 (i)“]['委卖[20240403]']”, )
调试输出 (最新涨跌幅, 委买, 委卖)
计次循环尾 ()


i支持库列表   支持库注释   
spec特殊功能支持库


易箱可以生成循环代码,下载地址:易箱 - 性能提升,JSON百万字符秒加载,支持Unicode
S8J6MTUCNYPHYFIYE.png




回复

使用道具 举报

结帖率:100% (38/38)

签到天数: 15 天

发表于 2024-4-3 01:35:16 | 显示全部楼层   北京市北京市
  
json.解析 ( #常量1, , )
json.取所有属性名 (文本数组, “['answer']['components'][0]['data']['datas'][0]”)
计次循环首 (取数组成员数 (文本数组), i)
如果真 (寻找文本 (文本数组 [i], “委买”, , ) > 0)
调试输出 (json.取通用属性 (“['answer']['components'][0]['data']['datas'][0]['” + 文本数组 [i]“']”, ))

计次循环尾 ()


i支持库列表   支持库注释   
spec特殊功能支持库

回复

使用道具 举报

结帖率:100% (38/38)

签到天数: 15 天

发表于 2024-4-3 01:38:57 | 显示全部楼层   北京市北京市
小白子 发表于 2024-4-3 01:35
[e=0].版本 2
.支持库 spec

我咋没有生成循环代码呢
回复

使用道具 举报

结帖率:100% (4/4)

签到天数: 13 天

发表于 2024-4-3 01:46:01 | 显示全部楼层   广东省东莞市
ltais 发表于 2024-4-3 01:38
我咋没有生成循环代码呢

最新版1.5.0中,要在数组上,且数组里是对象,右键菜单就会出现
回复

使用道具 举报

结帖率:50% (1/2)
 楼主| 发表于 2024-4-3 11:39:32 | 显示全部楼层   河北省秦皇岛市
小白子 发表于 2024-4-3 01:35
[e=0].版本 2
.支持库 spec

是能看,易箱、乐玩啥的都行,就是取不到数值。
回复

使用道具 举报

结帖率:50% (1/2)
 楼主| 发表于 2024-4-3 11:41:00 | 显示全部楼层   河北省秦皇岛市
ltais 发表于 2024-4-3 01:35
[e=0].版本 2
.支持库 spec

我觉得精易里的Json问题多。我试试精易的,谢谢!
回复

使用道具 举报

结帖率:100% (4/4)

签到天数: 13 天

发表于 2024-4-3 11:51:33 | 显示全部楼层   广东省东莞市
八八就发 发表于 2024-4-3 11:41
我觉得精易里的Json问题多。我试试精易的,谢谢!

建议使用zyjson,E2EE和yyjson。你没说用哪个我就生成了精易的了
回复

使用道具 举报

结帖率:50% (1/2)
 楼主| 发表于 2024-4-3 11:53:06 | 显示全部楼层   河北省秦皇岛市
ltais 发表于 2024-4-3 01:35
[e=0].版本 2
.支持库 spec

你们都用精易的,我试试,原来一直用zyJson
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 793400750,邮箱:wp@125.la
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表