开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 4683|回复: 93
收起左侧

[易语言纯源码] 春碗魔术解密(约瑟夫问题) 含易语言操作步骤

[复制链接]
结帖率:100% (1/1)
发表于 2024-2-11 19:17:49 | 显示全部楼层 |阅读模式   山东省青岛市
分享源码
界面截图:
是否带模块: -
备注说明: -
今年春晚刘谦魔术火了,其实仔细分析就是数学问题,抽时间写了个易语言分析的程序,源码 奉上。




' ’‘揭秘:
' 重要的步骤前 我加了* 表示
' 第一个*号, 就是从顶部拿3张牌 插入中间,结果会怎样,不管原来几张牌如何排列,经过本步骤后一定会出现首张与尾张相同的情况,如果没做到,可以和小尼一桌。
' 这里延伸一下, 如果魔术开始是5张牌,这里就要拿4张牌, 依次类推。。。


' 第二个*号,很神奇,必须的步骤,使底牌排在了准确的位置,具体来说就是:
' 如果 手余 5 张牌,循环一轮后底牌在第 3 位置,如果手余 6 张牌,循环一轮后底牌在 第 5 位置,本操作很重要,使其正好符合 约瑟夫序列

' 第三个*号,约瑟夫问题的实施。过程不能错

' 至于为何是下翻7张,其实也不是巧合,有兴趣去了解下约瑟夫问题, 下面我们来分析 约瑟夫问题的解法,递归法。

' 本程序只从程序算法角度解决问题,还有更好的数学解法,从略。


最后加上 约瑟夫问题的解法 ,完美了


.版本 2

.子程序 子程序报数问题
.局部变量 n, 整数型
.局部变量 m, 整数型
.局部变量 people, , , "0"
.局部变量 i, 整数型
.局部变量 j, 整数型
.局部变量 count, 整数型

' 设有n个人(编号从1到n)围成一圈,从第一个人开始报数,数到m的人出列,然后从出列的下一个人开始重新报数,直到所有人依次出列。问,最后一个出列的人的编号是多少?
n = 到整数 (编辑框3.内容)  ' 总人数)
m = 到整数 (编辑框4.内容)  ' 报数到m的人出列
重定义数组 (people, 假, n)
.计次循环首 (n, i)
    people = 1  ' '初始化每个人的状态为在圈内
.计次循环尾 ()
count = 0  ' 计数器,记录报数到m的人
i = 1  ' 从第1个人开始报数
j = 0  ' 记录出圈的人数
.判断循环首 (j < n - 1)  ' 当出圈人数小于总人数时循环
    .如果 (people = 1)
        count = count + 1  ' 报数加1
        .如果 (count = m)  ' 如果报数到m了
            count = 0  ' 重新开始报数
            people = 0  ' 将这个人标记为出圈
            j = j + 1  ' 出圈人数加1
            输出调试文本 (数组_hebing_整数 (people, “,”))
        .否则

        .如果结束


    .否则

    .如果结束
    i = i + 1  ' 继续报数
    .如果真 (i > n)
        i = 1  ' 如果到了最后一个人,则从第一个人继续报数
    .如果真结束
。。。

源码 下载:
用到了精易模块,请自行下载

扑克解密.e (966.06 KB, 下载次数: 56, 售价: 1 枚 精币)

点评

B站先出的py版本,我看了,所以才写了易版本的。py版本应该是先加UP吧   山东省青岛市  发表于 2024-2-19 21:13
@云长爱读春秋 隔壁是哪个隔壁推给我   河南省洛阳市  发表于 2024-2-18 09:41
好家伙,下午在隔壁看到PY版本的,现在易的版本也来了   江苏省淮安市  发表于 2024-2-11 19:38

评分

参与人数 23好评 +7 精币 +25 收起 理由
易语言资源网 + 1 + 3 开源精神必须支持~
zhaoxinli2715 + 1 感谢分享,很给力!~
keyi5566 + 1 感谢分享,很给力!~
3266167 + 1 感谢分享,很给力!~
YzZA + 1 感谢分享,很给力!~
songue + 1 + 2 YYDS~!
无尘666 + 1 感谢分享,很给力!~
t176 + 1 感谢分享,很给力!~
望尘莫及 + 1 感谢分享,很给力!~
龍貓 + 1 新技能已get√
1828902364 + 1 感谢分享,很给力!~
风雨3137 + 1 感谢分享,很给力!~
※逍遥游※ + 1 感谢分享,很给力!~
XXGL2005 + 1 感谢分享,很给力!~
Zźh926 + 1 感谢分享,很给力!~
ican8 + 1 感谢分享,很给力!~
聿聿 + 1 感谢分享,很给力!~
abpyu + 1 + 2 开源精神必须支持~
番茄吧 + 1 牛,赞
財財 + 1 感谢分享,很给力!~
光影魔术 + 1 + 1 新技能已get√
传奇 + 1 YYDS~!
dych1688 + 1 + 1 支持开源~!感谢分享

查看全部评分


签到天数: 1 天

发表于 2024-5-16 13:23:35 高大上手机用户 | 显示全部楼层   河南省新乡市
123
回复 支持 反对

使用道具 举报

签到天数: 1 天

发表于 2024-3-1 22:33:47 | 显示全部楼层   广西壮族自治区柳州市
永无烦恼,好运常留!
回复 支持 反对

使用道具 举报

结帖率:0% (0/1)

签到天数: 6 天

发表于 2024-2-22 19:14:25 | 显示全部楼层   广东省汕头市
感谢大神分享~!
回复 支持 反对

使用道具 举报

结帖率:100% (1/1)

签到天数: 13 天

发表于 2024-2-20 03:17:10 | 显示全部楼层   广东省深圳市
学习一下
回复 支持 反对

使用道具 举报

结帖率:100% (9/9)
发表于 2024-2-19 15:24:04 | 显示全部楼层   广东省江门市
楼主好犀利,这么快就解开了春晚的魔术小把戏
回复 支持 反对

使用道具 举报

结帖率:63% (22/35)

签到天数: 9 天

发表于 2024-2-18 13:36:45 | 显示全部楼层   广东省汕尾市
6666666666666666666
回复 支持 反对

使用道具 举报

签到天数: 1 天

发表于 2024-2-18 10:12:13 | 显示全部楼层   吉林省长春市
感谢分享
回复 支持 反对

使用道具 举报

签到天数: 1 天

发表于 2024-2-18 00:20:45 | 显示全部楼层   广东省肇庆市
666666666666666666
回复 支持 反对

使用道具 举报

结帖率:50% (2/4)

签到天数: 4 天

发表于 2024-2-17 21:43:31 | 显示全部楼层   广东省江门市
网上人才多,分分钟就扒光了
回复 支持 1 反对 0

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 793400750,邮箱:wp@125.la
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表