开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 479|回复: 8
收起左侧

[已解决] 萌新请教数组反转例子

 关闭 [复制链接]
结帖率:100% (1/1)
发表于 2024-2-8 17:41:07 | 显示全部楼层 |阅读模式   广西壮族自治区南宁市
8精币
.版本 2
.支持库 ncdx98

.子程序 转换
.局部变量 文本1, 文本型
.局部变量 反转, 文本型

文本1 = 十到十六_ (66666, )  '文本1=“1046A”' /////用精易模块的数组_反转()让反转等于0A4610如何操作。


麻烦大佬



补充内容 (2024-2-8 17:47):
上面错了,

文本1 = 十到十六_ (66666, )  '文本1=“1046A”' /////用精易模块的数组_反转()让反转等于6a0401如何操作。

最佳答案

查看完整内容

[e=1].版本 2 .支持库 spec .子程序 转换 .局部变量 文本, 文本型 .局部变量 数组, 文本型, , "0" .局部变量 反转, 文本型 .局部变量 i, 整数型 文本 = 进制_十到十六 (66666) ' 文本1=“1046A” .如果真 (文本_逐字分割 (文本, 数组) % 2 = 1) 插入成员 (数组, 1, “0”) .如果真结束 数组_反转 (数组) .计次循环首 (取数组成员数 (数组), i) 反转 = 反转 + 数组 [选择 (i % 2 = 0, i - 1, i + 1)] .计次循环 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 页面申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 18 天

发表于 2024-2-8 17:41:08 | 显示全部楼层   河北省张家口市
  
子程序名返回值类型公开备 注
转换  
变量名类 型静态数组备 注
文本文本型 
数组文本型0
反转文本型 
i整数型 
文本 = 进制_十到十六 (66666)  ' 文本1=“1046A”
如果真 (文本_逐字分割 (文本, 数组) % 2 = 1)
插入成员 (数组, 1, “0”)
数组_反转 (数组)
计次循环首 (取数组成员数 (数组), i)
反转 = 反转 + 数组 [选择 (i % 2 = 0, i - 1, i + 1)]
计次循环尾 ()
调试输出 (到小写 (反转))


i支持库列表   支持库注释   
spec特殊功能支持库


必须用数组_反转的话只能这样了

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

回复

使用道具 举报

签到天数: 9 天

发表于 2024-2-8 17:50:32 | 显示全部楼层   云南省曲靖市
首先你的这个值不是一个数组类型,用不了数组_反转来操作,其次,你这个更改前后没啥规律也不是直接倒过来,就算是数组类型的用这个命令也是没办法等于0A4610
回复

使用道具 举报

结帖率:100% (9/9)

签到天数: 22 天

发表于 2024-2-8 17:52:47 | 显示全部楼层   广西壮族自治区百色市
到字节集 然后用字节集_反转
回复

使用道具 举报

结帖率:100% (78/78)

签到天数: 21 天

发表于 2024-2-8 17:53:53 | 显示全部楼层   河南省洛阳市
  
变量名类 型静态数组备 注
str文本型 
strText文本型 
i整数型 
str = “AE3”
如果真 (取文本长度 (str) % 2 ≠ 0)
str = “0” + str
变量循环首 (取文本长度 (str), 1, -2, i)
strText = strText + 取文本中间 (str, i - 1, 2)
变量循环尾 ()
调试输出 (strText)

回复

使用道具 举报

结帖率:100% (9/9)

签到天数: 22 天

发表于 2024-2-8 17:55:39 | 显示全部楼层   广西壮族自治区百色市
  
变量名类 型静态数组备 注
data字节集 
data = 到字节集 (进制_十到十六 (66666, ))
调试输出 (到文本 (data))
调试输出 (到文本 (字节集_反转 (data)))


i支持库列表   支持库注释   
spec特殊功能支持库

回复

使用道具 举报

结帖率:100% (20/20)

签到天数: 22 天

发表于 2024-2-8 18:54:27 | 显示全部楼层   浙江省杭州市
66666先到字节集  删除末尾的0
然后字节集到16进制就是了
回复

使用道具 举报

结帖率:100% (1/1)
 楼主| 发表于 2024-2-8 20:43:41 | 显示全部楼层   广西壮族自治区南宁市
zz1318 发表于 2024-2-8 17:52
到字节集 然后用字节集_反转

这个不对,并不是全反哦
回复

使用道具 举报

结帖率:100% (1/1)
 楼主| 发表于 2024-2-8 20:46:58 | 显示全部楼层   广西壮族自治区南宁市
zz1318 发表于 2024-2-8 17:55
[e=0].版本 2
.支持库 spec

这样不对哦。66666的十六进制0001046A。目标是6a0401

按照你的方法变成这样。* A6401000
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表