开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到 - 下载易语言


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 113|回复: 4
收起左侧

[易语言] 怎么把如下的两个sql语句合并成一个达到同样的效果

[复制链接]
结帖率:96% (134/139)
发表于 前天 16:37 | 显示全部楼层 |阅读模式   江苏省苏州市
5精币
如下图,因为之前excel导入到sql server 效率太慢,目前处理的方式是,先将excel导入到sql server,因为excel导入到sql是生成新表,只能再将数据复制到另一个指定表中,多了一个步骤,还多了已和表,请问怎么修改成一句达到相同效果;符原语句:1:“SELECT * INTO ” + 数据表名称 + “ FROM OPENROWSET('Microsoft.ACE.OLEDB.12.0','Excel 12.0; Database=” + 通用对话框1.文件名 + “', [期末库存cha询$])”;2:“INSERT INTO [dbo].[t_ck_qimokc] SELECT * FROM ” + 数据表名称
搜狗截图20230919163137.png


补充内容 (2023-9-19 16:39):
没检查,错别字太多请多包涵(还多了一张数据表)(附原语句)


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 页面申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:98% (124/127)

签到天数: 19 天

发表于 前天 17:15 | 显示全部楼层   重庆市重庆市
excel导入到sqlserver 我感觉直接用数据库工具处理,可能更快。好多工具都支持直接导入,只要表和数据库结构一样,也很快很方便。
回复

使用道具 举报

结帖率:76% (16/21)

签到天数: 4 天

发表于 前天 23:39 | 显示全部楼层   浙江省嘉兴市
能用两句解决已经很不错了,功能有了先干为敬
回复

使用道具 举报

结帖率:96% (134/139)

签到天数: 13 天

 楼主| 发表于 昨天 08:22 | 显示全部楼层   江苏省苏州市
53770zhang 发表于 2023-9-19 17:15
excel导入到sqlserver 我感觉直接用数据库工具处理,可能更快。好多工具都支持直接导入,只要表和数据库结 ...

主要是操作人员啥也不会,恨不得你一键全部ok
回复

使用道具 举报

结帖率:98% (124/127)

签到天数: 19 天

发表于 昨天 08:42 | 显示全部楼层   重庆市重庆市
.版本 2
.支持库 e2ee

.如果真 (取反 (xlBookLoadA (句柄, 取文本指针 (上传目录)) = 1))  ' 打开工作簿
       xlBookReleaseA (句柄)  ' 释放
    返回 ()
.如果真结束

表_句柄 = xlBookGetSheetA (句柄, 读取表格)  ' 取表格内容
行数 = xlSheetLastRowA (表_句柄)  ' 取得行数

.变量循环首 (3, 行数 - 1, 1, 行)  ' 读工作表数据
    姓名 = 指针到文本 (xlSheetReadStrA (表_句柄, 行, 1, 0))  ' 读单元格文本
    电话 = 指针到文本 (xlSheetReadStrA (表_句柄, 行, 3, 0))
    预约日期 = 指针到文本 (xlSheetReadStrA (表_句柄, 行, 5, 0))
    预约日期 = 时间_格式化EX (增减时间 (到时间 (“1900年1月1日”), 5, 到数值 (预约日期) - 2), , , 2)
    预约时间 = 指针到文本 (xlSheetReadStrA (表_句柄, 行, 6, 0))
    单位 = 指针到文本 (xlSheetReadStrA (表_句柄, 行, 7, 0))
    value = value + “('” + 姓名 + “','” + 单位 + “','” + 预约日期 + “','” + 预约时间 + “','” + 电话 + “','” + 登记时间 + “','” + 备注 + “','1'),”
.变量循环尾 ()
value = 取文本左边 (value, 取文本长度 (value) - 1)
SQL = “insert into yuyue (name,company,date,time,tel,record,remarks,stat) values ” + value
连接池.取连接 (连接)
连接.执行 (SQL, , )
xlBookReleaseA (句柄)  ' 释放

可以读取表的内容,然后直接写入表。我以前写过一个类似的。用了libxl

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表