开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

查看: 826|回复: 8
收起左侧

[精币悬赏] 求助汇编高手帮忙修改翻转字节集汇编代码

[复制链接]
结帖率:40% (2/5)
发表于 2023-9-18 20:56:10 | 显示全部楼层 |阅读模式   重庆市重庆市
5精币
感谢易友zainex的优秀汇编代码翻转字节集, 求助当传入字节集长度为1字节或0字节时, 我在子程序入口加了判断代码后无效程序会崩溃,求加判断的汇编代码。谢谢!原作者看过来@zainex

  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
倒序字节集字节集 
参数名类 型参考可空数组备 注
对象字节集
如果真 (取字节集长度 (Bytes) < 2) ‘ 我加了判断代码无效还是会崩溃
返回 ({  })
置入代码 ({ 93, 100, 139, 21, 48, 0, 0, 0, 139, 82, 12, 139, 82, 28, 139, 66, 8, 139, 74, 32, 139, 18, 128, 121, 12, 51, 117, 242, 137, 193, 3, 72, 60, 139, 81, 120, 1, 194, 139, 74, 32, 1, 193, 49, 219, 139, 60, 153, 1, 199, 67, 129, 127, 4, 108, 65, 108, 108, 117, 241, 139, 74, 36, 1, 193, 102, 139, 28, 89, 139, 74, 28, 1, 193, 139, 76, 153, 252, 1, 193, 139, 92, 36, 4, 139, 27, 139, 115, 4, 141, 86, 8, 82, 104, 0, 0, 0, 0, 255, 209, 198, 0, 1, 137, 112, 4, 131, 195, 8, 49, 255, 235, 10, 138, 84, 51, 255, 136, 84, 56, 8, 71, 78, 133, 246, 117, 242, 194, 4, 0 })
' pop ebp
' mov edx, dword [fs:0x00000030]
' mov edx, dword [edx+0x0C]
' mov edx, dword [edx+0x1C]
' Label1:
' mov eax, dword [edx+0x08]
' mov ecx, dword [edx+0x20]
' mov edx, dword [edx]
' cmp byte [ecx+0x0C], 0x33
' jne Label1
' mov ecx, eax
' add ecx, dword [eax+0x3C]
' mov edx, dword [ecx+0x78]
' add edx, eax
' mov ecx, dword [edx+0x20]
' add ecx, eax
' xor ebx, ebx
' Label2:
' mov edi, dword [ecx+ebx*4]
' add edi, eax
' inc ebx
' cmp dword [edi+0x04], 0x6C6C416C
' jne Label2
' mov ecx, dword [edx+0x24]
' add ecx, eax
' mov bx, word [ecx+ebx*2]
' mov ecx, dword [edx+0x1C]
' add ecx, eax
' mov ecx, dword [ecx+ebx*4-0x04]
' add ecx, eax
' mov ebx, dword [esp+0x04]
' mov ebx, dword [ebx]
' mov esi, dword [ebx+0x04]
' lea edx, dword [esi+0x08]
' push edx
' push 0x00000000
' call ecx
' mov byte [eax], 0x01
' mov dword [eax+0x04], esi
' add ebx, 0x08
' xor edi, edi
' jmp Label3
' Label4:
' mov dl, byte [ebx+esi-0x01]
' mov byte [eax+edi+0x08], dl
' inc edi
' dec esi
' Label3:
' test esi, esi
' jne Label4
' retn 0x0004
返回 ({  })
子程序名返回值类型公开备 注
__启动窗口_创建完毕  
变量名类 型静态数组备 注
对象字节集 
结果字节集 
对象 = { 6 }
计次循环首 (1, )
结果 = 倒序字节集 (对象)
计次循环尾 ()
调试输出 (对象, 结果)


i支持库列表   支持库注释   
spec特殊功能支持库


结帖率:96% (55/57)
发表于 2023-9-18 21:00:09 | 显示全部楼层   河南省洛阳市
那就在外部做判断呀
回复

使用道具 举报

签到天数: 17 天

发表于 2023-9-18 21:55:45 | 显示全部楼层   广东省广州市
1695045306047.png

这波骚操作看得我一脸懵逼!这Bytes是从哪里冒出来的,这能跑起来!???
回复

使用道具 举报

结帖率:25% (5/20)

签到天数: 16 天

发表于 2023-9-19 01:26:58 | 显示全部楼层   江西省九江市
.版本 2

.子程序 字节集_翻转, 字节集, , 倒序字节集 asm
.参数 arg_bin, 字节集
.局部变量 len, 整数型
.局部变量 p, 整数型
.局部变量 pp, 整数型
.局部变量 bin_new, 字节集

len = 取字节集长度 (arg_bin)
p = 取字节集指针_asm (arg_bin)
pp = 0
bin_new = 取空白字节集 (len)
pp = 取字节集指针_asm (bin_new)
置入代码 ({ 139, 77, 252, 139, 117, 248, 139, 125, 244, 1, 207, 79, 138, 6, 134, 7, 70, 79, 226, 248 })
返回 (bin_new)
回复

使用道具 举报

结帖率:40% (2/5)

签到天数: 1 天

 楼主| 发表于 2023-9-19 09:53:24 | 显示全部楼层   重庆市重庆市
shituo 发表于 2023-9-19 01:26
.版本 2

.子程序 字节集_翻转, 字节集, , 倒序字节集 asm

感谢解答,不过我对比了一下你的asm版本还是没有易友@zainex的版本速度快(字节集越长约明显),我对比了很多个版本就他的最快。有兴趣可以研究一下。

作者原贴地址:https://bbs.125.la/forum.php?mod=viewthread&tid=14761368
我发贴求助作者修改直接返回字节集的版本:https://bbs.125.la/forum.php?mod=viewthread&tid=14792521
回复

使用道具 举报

结帖率:40% (2/5)

签到天数: 1 天

 楼主| 发表于 2023-9-19 09:55:58 | 显示全部楼层   重庆市重庆市
大司命 发表于 2023-9-18 21:55
这波骚操作看得我一脸懵逼!这Bytes是从哪里冒出来的,这能跑起来!???
...

这个是我复制原代码到帖子后面手动加的,哈哈,等我发布了才发现写错了无法修改了。
回复

使用道具 举报

结帖率:40% (2/5)

签到天数: 1 天

 楼主| 发表于 2023-9-19 09:58:38 | 显示全部楼层   重庆市重庆市
Tenacitys 发表于 2023-9-18 21:00
那就在外部做判断呀

刚开始有想过,不过已经应用到很多地方去了,现在只有在子程序中处理比较好了。
回复

使用道具 举报

结帖率:40% (2/5)

签到天数: 1 天

 楼主| 发表于 2023-9-19 10:02:53 | 显示全部楼层   重庆市重庆市
Tenacitys 发表于 2023-9-18 21:00
那就在外部做判断呀

在之后的应用中也会大概率会忘记做判断而在一些特殊场景带来不稳定因素。排查起来会比较麻烦。
回复

使用道具 举报

结帖率:29% (6/21)

签到天数: 8 天

发表于 2023-11-23 14:17:20 | 显示全部楼层   湖南省邵阳市
.版本 2
.支持库 spec

.局部变量 对象, 字节集
.局部变量 结果, 字节集

对象 = { 6, 7, 8, 9, 1 }
.计次循环首 (5, )
    结果 = 倒序字节集 (对象)
.计次循环尾 ()
调试输出 (对象, 结果)


.子程序 倒序字节集, 字节集
.参数 对象, 字节集

置入代码 ({ 93, 100, 139, 21, 48, 0, 0, 0, 139, 82, 12, 139, 82, 28, 139, 66, 8, 139, 74, 32, 139, 18, 128, 121, 12, 51, 117, 242, 137, 193, 3, 72, 60, 139, 81, 120, 1, 194, 139, 74, 32, 1, 193, 49, 219, 139, 60, 153, 1, 199, 67, 129, 127, 4, 108, 65, 108, 108, 117, 241, 139, 74, 36, 1, 193, 102, 139, 28, 89, 139, 74, 28, 1, 193, 139, 76, 153, 252, 1, 193, 139, 92, 36, 4, 139, 27, 139, 115, 4, 141, 86, 8, 82, 104, 0, 0, 0, 0, 255, 209, 198, 0, 1, 137, 112, 4, 131, 195, 8, 49, 255, 235, 10, 138, 84, 51, 255, 136, 84, 56, 8, 71, 78, 133, 246, 117, 242, 194, 4, 0 })
返回 ({  })
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 易语言模块| 手机版| 广告投放| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 793400750,邮箱:wp@125.la
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表