开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到 - 下载易语言


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129长期大量收网站访客量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129长期大量收网站访客量+飞机@bbs129长期大量收网站访客量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129高价寻百du下载站流量+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收国内国外协议群发粉+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收国内国外协议群发粉+飞机@bbs129收国内国外协议群发粉+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收海内外app上架流量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收海内外app上架流量+飞机@bbs129收海内外app上架流量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收百du搜gou广告资源+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收百du搜gou广告资源+飞机@bbs129收百du搜gou广告资源+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收飞机协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收飞机协yi群fa+飞机@bbs129收飞机协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收国内国外广告资源+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收国内国外广告资源+飞机@bbs129收国内国外广告资源+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129大量收海外各种流量粉+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129大量收海外各种流量粉+飞机@bbs129大量收海外各种流量粉+飞机@bbs129
没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129
没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129广告招租
查看: 306|回复: 9
收起左侧

[易求助] 关于取进程目录问题。。

[复制链接]
结帖率:95% (182/192)
发表于 2023-1-25 11:17:26 | 显示全部楼层 |阅读模式   黑龙江省哈尔滨市
10精币
进程_取路径 (进程_名取ID (“测试.exe”, ))


但是。。怎么在打开他的路径?





补充内容 (2023-1-25 11:17):
然后再删掉  测试.exe  这个程序。。


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:50% (1/2)

签到天数: 5 天

发表于 2023-1-25 11:19:39 | 显示全部楼层   辽宁省沈阳市
执行(,取到的路径)   可以打开该文件夹,   删掉程序的话需要 进程_结束(进程_名取ID (“测试.exe”, ))  然后再 删除文件( 所在目录+“测试.exe")
回复

使用道具 举报

结帖率:95% (182/192)

签到天数: 4 天

 楼主| 发表于 2023-1-25 11:22:17 | 显示全部楼层   黑龙江省哈尔滨市
帅与俊的结合 发表于 2023-1-25 11:19
执行(,取到的路径)   可以打开该文件夹,   删掉程序的话需要 进程_结束(进程_名取ID (“测试.exe”, ))   ...

删除文件 (进程_取路径 (进程_名取ID (“测试.exe”, )) + “测试.exe”)
回复

使用道具 举报

结帖率:95% (182/192)

签到天数: 4 天

 楼主| 发表于 2023-1-25 11:29:40 | 显示全部楼层   黑龙江省哈尔滨市
帅与俊的结合 发表于 2023-1-25 11:19
执行(,取到的路径)   可以打开该文件夹,   删掉程序的话需要 进程_结束(进程_名取ID (“测试.exe”, ))   ...

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 路径, 文本型

.子程序 _按钮1_被单击

路径 = 进程_取路径 (进程_名取ID (“WeChatAppEx.exe”, ))
删除文件 (路径)


删不掉- -
回复

使用道具 举报

结帖率:50% (1/2)

签到天数: 5 天

发表于 2023-1-25 11:30:25 | 显示全部楼层   辽宁省沈阳市
一生放荡mo 发表于 2023-1-25 11:29
.版本 2

.程序集 窗口程序集_启动窗口

必须先结束进程才能删掉吧,

补充内容 (2023-1-25 11:30):
你的 测试.exe 露馅了,变成了 WeChatAppEx.exe”  哇哈哈哈哈
回复

使用道具 举报

结帖率:95% (182/192)

签到天数: 4 天

 楼主| 发表于 2023-1-25 11:32:42 | 显示全部楼层   黑龙江省哈尔滨市
帅与俊的结合 发表于 2023-1-25 11:30
必须先结束进程才能删掉吧,

补充内容 (2023-1-25 11:30):

无所谓啊。。我结束掉了。。不行
回复

使用道具 举报

结帖率:95% (182/192)

签到天数: 4 天

 楼主| 发表于 2023-1-25 11:34:39 | 显示全部楼层   黑龙江省哈尔滨市
帅与俊的结合 发表于 2023-1-25 11:30
必须先结束进程才能删掉吧,

补充内容 (2023-1-25 11:30):

我取到的直接是

"C:\Users\Administrator\AppData\Roaming\Tencent\WeChat\XPlugin\Plugins\WMPFRuntime\4676\extracted\runtime\WeChatAppEx.exe"  路径是对的。。就是删除不掉
回复

使用道具 举报

结帖率:50% (1/2)

签到天数: 5 天

发表于 2023-1-25 11:35:37 | 显示全部楼层   辽宁省沈阳市
一生放荡mo 发表于 2023-1-25 11:34
我取到的直接是

"C:%users\Administrator\AppData\Roaming\Tencent\WeChat\XPlugin\Plugins\WMPFRuntime ...
  
窗口程序集名保 留  保 留备 注
窗口程序集1   
变量名类 型数组备 注
路径文本型  

子程序名返回值类型公开备 注
_按钮1_被单击  
变量名类 型静态数组备 注
ID整数型0
i整数型 
路径 = 进程_取路径 (进程_名取ID (“WeChatAppEx.exe”, ))
进程_取同名ID (“WeChatAppEx.exe”, ID)
计次循环首 (取数组成员数 (ID), i)
进程_结束 (ID [i])
计次循环尾 ()
删除文件 (路径)



这样试试呢
回复

使用道具 举报

结帖率:95% (182/192)

签到天数: 4 天

 楼主| 发表于 2023-1-25 11:44:34 | 显示全部楼层   黑龙江省哈尔滨市
帅与俊的结合 发表于 2023-1-25 11:35
[e=1].版本 2

.程序集 窗口程序集1

结束进程是正确的。  就是之后不删除。。
回复

使用道具 举报

结帖率:50% (1/2)

签到天数: 5 天

发表于 2023-1-25 12:15:24 | 显示全部楼层   辽宁省沈阳市
一生放荡mo 发表于 2023-1-25 11:44
结束进程是正确的。  就是之后不删除。。

那应该是它又被启动了的问题。。那你直接把 删除文件 改成 文件更名 试试~~
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表