开启辅助访问 切换到宽版

精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到 - 下载易语言


求职/招聘- 论坛接单- 开发者大厅

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129长期大量收网站访客量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129长期大量收网站访客量+飞机@bbs129长期大量收网站访客量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129高价寻百du下载站流量+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129寻实力国内外短xin群fa+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收国内国外协议群发粉+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收国内国外协议群发粉+飞机@bbs129收国内国外协议群发粉+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收海内外app上架流量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收海内外app上架流量+飞机@bbs129收海内外app上架流量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收百du搜gou广告资源+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收百du搜gou广告资源+飞机@bbs129收百du搜gou广告资源+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129收海外谷gFB大搜流量+飞机@bbs129
收神马搜gou广告资源+飞机@bbs129收海外谷ge代运营流量+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129高价寻百du下载站流量+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129收越南zalo协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129收巴西土耳其协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129收泰国line协yi群fa代发+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129收WhatsApp协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收飞机协yi群fa+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收飞机协yi群fa+飞机@bbs129收飞机协yi群fa+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129收印尼协yi群fa代发+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129收国内国外广告资源+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129收国内国外广告资源+飞机@bbs129收国内国外广告资源+飞机@bbs129
寻稳定短xin群fa+飞机@bbs129寻稳定短xin群fa+飞机@bbs129大量收海外各种流量粉+飞机@bbs129高价收谷ge大搜流量+飞机@bbs129大量收海外各种流量粉+飞机@bbs129大量收海外各种流量粉+飞机@bbs129
没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129
没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129没有飞机的加备用+飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129
谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129谨防被骗唯一飞机@bbs129广告招租
查看: 1526|回复: 61
收起左侧

[已解决] 请教各位大佬,超过20位的长整数怎么右移?

 关闭 [复制链接]
结帖率:67% (2/3)
发表于 2023-1-22 23:16:04 高大上手机用户 | 显示全部楼层 |阅读模式   福建省泉州市
13精币

各位大佬帮帮忙,今天凌晨折腾到现在百度了好久,各种go / js/py 都看了一大堆还是没搞明白该咋计算

原文:
分片是按照guild进行哈希的,哈希规则如下:
shard=(guild_id >> 22) % 2

设: guild_id=16827111275793860813
那么shard最终正确值应该是1

但我的易语言写法
调试输出 (右移长整数 (到长整数 (“16827111275793860813”), 22) % 2)
却报错为0

最佳答案

查看完整内容

易语言中有一个数据类型叫“大数” 实测256位长度的数字都可以正常加减 补充内容 (2023-1-22 23:39): .版本 2 .支持库 eCalc .支持库 spec .子程序 _按钮1_被单击 .局部变量 Num1, 大数 Num1.导入文本 (“666666666666666666666666666666666666666666666666666666666666666666666666...

评分

参与人数 8精币 +8 收起 理由
悟桐的深思 + 1 感谢分享,很给力!~
冰棍好烫啊 + 1 为什么都在评分
无尘666 + 1 感谢分享,很给力!~
微风已过 + 1 感谢分享,很给力!~
Arui + 1 感谢分享,很给力!~
mumulu + 1 感谢分享,很给力!~
qiyuer + 1 感谢分享,很给力!~
※逍遥游※ + 1 感谢分享,很给力!~

查看全部评分


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换荣誉会员、终身vip用户组。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:75% (3/4)

签到天数: 7 天

发表于 2023-1-22 23:16:05 | 显示全部楼层   广西壮族自治区南宁市
易语言中有一个数据类型叫“大数”
实测256位长度的数字都可以正常加减

补充内容 (2023-1-22 23:39):
.版本 2
.支持库 eCalc
.支持库 spec

.子程序 _按钮1_被单击
.局部变量 Num1, 大数


Num1.导入文本 (“666666666666666666666666666666666666666666666666666666666666666666666666...

点评

话说没找到 到大数() 这个东东 我该怎么把20位数的字符串传入右移里?   福建省泉州市  发表于 2023-1-22 23:27
我想到的是 字符串右移 但是百du了一下好像只看到go语言的 没找到易语言如何字符串位或/左移/右移   福建省泉州市  发表于 2023-1-22 23:22

评分

参与人数 1荣誉 +1 收起 理由
项目部004 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

回复

使用道具 举报

结帖率:98% (53/54)

签到天数: 7 天

发表于 2023-1-22 23:23:56 | 显示全部楼层   福建省宁德市
毫无疑问你这个数已经超出易语言长整数的范围了
回复

使用道具 举报

结帖率:67% (2/3)

签到天数: 2 天

 楼主| 发表于 2023-1-22 23:32:15 高大上手机用户 | 显示全部楼层   福建省泉州市
右移()好像只支持整数

点评

汇编试试,最近有开源   广东省东莞市  发表于 2023-1-28 15:57
回复

使用道具 举报

结帖率:75% (3/4)

签到天数: 7 天

发表于 2023-1-22 23:39:27 | 显示全部楼层   广西壮族自治区南宁市
星星之夜 发表于 2023-1-22 23:19
易语言中有一个数据类型叫“大数”
实测256位长度的数字都可以正常加减

.版本 2
.支持库 eCalc
.支持库 spec

.子程序 _按钮1_被单击
.局部变量 Num1, 大数


Num1.导入文本 (“66666666666666666666666666666666666666666666666666666666666666666666666666666666”)


调试输出 (Num1.导出文本 ())

回复

使用道具 举报

结帖率:67% (2/3)

签到天数: 2 天

 楼主| 发表于 2023-1-22 23:48:27 | 显示全部楼层   广东省广州市
星星之夜 发表于 2023-1-22 23:39
.版本 2
.支持库 eCalc
.支持库 spec

导入了 但是 没有Num1.右移() 我该怎么计算?系统自带的 右移只能传入整数
回复

使用道具 举报

结帖率:93% (14/15)

签到天数: 5 天

发表于 2023-1-22 23:59:58 | 显示全部楼层   北京市北京市
没有到大数()这个方法,如果想转为大数的话,定义一个大数变量,然后 变量.导入文本()
回复

使用道具 举报

结帖率:67% (2/3)

签到天数: 2 天

 楼主| 发表于 2023-1-23 00:03:31 | 显示全部楼层   福建省泉州市
iock 发表于 2023-1-22 23:59
没有到大数()这个方法,如果想转为大数的话,定义一个大数变量,然后 变量.导入文本() ...

好的,谢谢了!那导入之后该如何右移呢?
回复

使用道具 举报

结帖率:98% (53/54)

签到天数: 7 天

发表于 2023-1-23 00:06:29 | 显示全部楼层   福建省宁德市
千狐 发表于 2023-1-23 00:03
好的,谢谢了!那导入之后该如何右移呢?

我算了一下  你这个结果就是为0
回复

使用道具 举报

结帖率:93% (14/15)

签到天数: 5 天

发表于 2023-1-23 00:08:14 | 显示全部楼层   北京市北京市
千狐 发表于 2023-1-23 00:03
好的,谢谢了!那导入之后该如何右移呢?

这个就不太懂了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
论坛帖子内容仅用于技术交流学习和研究的目的,严禁用于非法目的,否则造成一切后果自负!如帖子内容侵害到你的权益,请联系我们!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.4 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125 增值电信业务经营许可证 粤B2-20192173

快速回复 返回顶部 返回列表