精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱┃ 服务器出租E3单路E5双路E5 ┃ 长期 包养全网交友粉大户实力公司大量收粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
2019年好项目,每月多挣好多钱┃ 模拟器虚拟机多开! 单进程 ┃长期 包养全网交友粉大户交友粉 婚恋粉 各种活粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█长期大量收购各种活粉█长期 包养全网交友粉大户另收土豆社交APP活粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█ 长期收购各种引流软件 █长期 包养全网交友粉大户无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群无限收各种引流资源寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群无限收精准网赚资源寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群免费帮对接担保交易实力收精准粉大量稳定加Q525253各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群欢迎买卖方进群合作实力收精准粉大量稳定加Q525253┏┏ 全网大量收交友粉 ┓┓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群免费帮对接渠道资源实力收精准粉大量稳定加Q525253〓 各种APP交友粉 〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█     高 收 益 项 目   █实力收精准粉大量稳定加Q525253〓  抖音 快手 火山  〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█      耗资巨大     █实力收精准粉大量稳定加Q525253〓   附 近 人    〓收男女粉+q53779879日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█      市场最牛     █★★★出售抖音网赚精准粉 Q317738〓 各论坛美拍部落 〓收男女粉+q53779879日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█   支 持     日 结   █★★★出售抖音网赚精准粉 Q317738〓各种活人粉实力对接〓收收收大量宝妈粉QQ289259高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█   咨询QQ   880194   █【实力公司无限收各种思路引流活粉】〓大小量通吃欢迎来撩〓收收收.微信扫码进群.加QQ9703796高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█↑↑↑↑↑↑↑↑↑加QQ:575199999〓 稳定全年365天收 〓█★█长期收购网赚精准粉█★█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作███ 实力公司 长期有效 ██〓 无限 收交友粉 〓█★█长期收购网赚精准粉█★█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作███ 收收收收 引流软件 ██┗┗ 全网最高单价收粉 ┛┛高价收qq渠道,交友粉+q7042641高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作███ 收收收收 引流脚本 ██◆大量收婚恋宝妈快手火山◆高价收qq渠道,交友粉+q7042641高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作███ 收收收收 引流思路 ██◇稳定收交友粉,找我换钱◇鼎信社群高价收WZ各类热门资源高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 群fa软件 ██◆收快手火山虎牙找我换钱◆鼎信社万人对接基地高效出粉收粉高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 精准wz粉 ██◇长期收交友粉大小量通吃◇███ 鼎信社群 行业顶尖 ███高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 精准zy粉 ██◆ 婚恋/抖音/空间/快手 ◆鼎信社群欢迎各类 商人对接入驻高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 引流人才 ██◇ 优质有量的找我换钱 ◇鼎信社欢迎各类粉商精英对接交流高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 引流方式 ██◆ 实力大型公司收媒体量 ◆█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
全网最高单价收粉QQ420073██收收收收 易语言高手██◇ 大量资金 ,来一收代理 ◇█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
实力收购各种粉加QQ420073██ 收收收收 软件定制 ██◆ 无限收交友粉交友粉 ◆█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购精准兼职粉加QQ420073██ 加qq群:839661627 ██◇ 各种活人粉实力对接 ◇█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购精准网赚粉加QQ420073██进群找管理 备注引流██全网大量收各种APP交友粉,日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购软件渠道思路QQ420073██进群找管理 备注引流██包养全网交友粉大户日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
████收购微信收租量QQ55698545大量收微信进群粉联系q584121900全网大量收各种APP交友粉,日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
████收购微信收租量QQ55698545出微信qq交友粉网赚粉精准粉兼职包养全网交友粉大户日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
长期出QQ群QQ号微信精准粉网挣粉大量出各类精准用户粉,全行业私信全网大量收各种APP交友粉,日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
出QQ群微信QQ号交友粉网赚粉兼职粉限时限量出售高精准网赚粉包养全网交友粉大户★工作室长期出抖音WZ粉Q159907高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
大量出QQ网赚粉微信粉Q群精准活粉高价收网吧终端量联系Q1908886662全网大量收各种APP交友粉,█网站统计█I引流系统█I高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
Q群粉及交友一手资源Q:4925442249██████出精准网赚粉兼职粉包养全网交友粉大户高价收微信进群活跃男粉Q858529686高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
公司高价收购流量服务器出租E3-E5-单进程全网大量收各种APP交友粉,软件开发商实力出QQ网赚粉兼职粉高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
出游戏粉 游戏粉加Q245014016出Q群微信直播粉联系Q2604720501包养全网交友粉大户出兼职粉有实力的来高价收购【全部行业精准粉】进群!我要租广告位
查看: 202|回复: 7
收起左侧

[易求助] 多线程启动 经常总奔溃软件,请高手看看问题出在什么地方!!!

[复制链接]

签到天数:1 天

结帖率:0% (0/1)
发表于 6 天前 | 显示全部楼层 |阅读模式
5精币



回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 6 天前 | 显示全部楼层
.版本 2
.支持库 EThread
.支持库 iext
.支持库 spec

.子程序 _按钮开始_被单击

按钮开始.禁止 = 真
zc启动线程 ()

.子程序 zc启动线程
.局部变量 i, 整数型
.局部变量 zc个数, 整数型
.局部变量 代理IP位置, 整数型
.局部变量 代理端口, 文本型
.局部变量 返回文本, 文本型

' ===============================================配置线程使用许可证
写出数据许可证 = 创建进入许可证 ()
插入列表数据许可证 = 创建进入许可证 ()
线程许可证 = 创建进入许可证 ()
累加计次成功_许可证 = 创建进入许可证 ()
累加计次失败_许可证 = 创建进入许可证 ()

.计次循环首 (到整数 (超级列表框1.取表项数 ()), i)

    ' ============================================================这里控制线程数
    线程数 = 线程数 + 1
    .判断循环首 (线程数 > 到整数 (编辑框线程数.内容))
        程序_延时 (100)
    .判断循环尾 ()

    CloseHandle (线程_启动 (&执行任务, 存放行数))  ' 启动线程
    立刻拨号 (编辑框宽带账号.内容, 编辑框宽带密码.内容, 到文本 (组合框_宽带配置.现行选中项), 编辑框次数换IP.内容)
    存放行数 = 存放行数 + 1
    .判断循环首 (暂停任务)
        程序_延时 (3000)
    .判断循环尾 ()
.计次循环尾 ()
.判断循环首 (线程数 > 0)
    程序_延时 (100)
.判断循环尾 ()

超级列表框1.保证显示 (0)
' 信息框 (“zc执行计划完成!!!”, 0, , )

.子程序 执行任务
.参数 索引, 整数型
.局部变量 n, 整数型
.局部变量 返回的文本, 文本型
.局部变量 ID, 文本型
.局部变量 对应ID, 整数型
.局部变量 反馈状态, 整数型
.局部变量 宽带账号, 文本型
.局部变量 宽带密码, 文本型
.局部变量 宽度电话簿编号, 文本型
.局部变量 准备拨号次数, 文本型

置随机数种子 ()
CoInitialize (0)
ID = 超级列表框1.取标题 (索引, 5)
返回的文本 = 网页_访问S (“https://www.xxxxx.com” + ID, 0, , “”, , )
调试输出 (返回的文本)
进入许可区 (插入列表数据许可证)
.如果 (寻找文本 (返回的文本, “Redire”, , 真) ≠ -1)
    超级列表框1.置标题 (索引, 6, “成功”)
    zc成功 = zc成功 + 1
    写出数据到文本 (“成功”, 超级列表框1.取标题 (索引, 1) + “---” + 超级列表框1.取标题 (索引, 2) + “---” + 超级列表框1.取标题 (索引, 3) + “---” + 超级列表框1.取标题 (索引, 4) + “---” + 超级列表框1.取标题 (索引, 5))
    编辑框zc成功.内容 = 到文本 (zc成功)
.否则
    超级列表框1.置标题 (索引, 6, “验证”)
.如果结束
退出许可区 (插入列表数据许可证)
进入许可区 (线程许可证)
线程数 = 线程数 - 1
CoUninitialize ()
退出许可区 (线程许可证)
返回 ()

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 4 天

发表于 6 天前 | 显示全部楼层
明显的 多线程直接操作窗口组件导致的

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 6 天前 | 显示全部楼层
荖貢 发表于 2019-6-12 21:34
明显的 多线程直接操作窗口组件导致的

窗口组件 能详细一些吗  感谢

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 14 天

结帖率:100% (137/137)
发表于 6 天前 | 显示全部楼层
有个思路,可以试试一块一块的把代码砍掉,当砍到某一时刻发现,哎,好了,就知道问题了。。。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 5 天前 | 显示全部楼层
万里禅天 发表于 2019-6-12 23:43
有个思路,可以试试一块一块的把代码砍掉,当砍到某一时刻发现,哎,好了,就知道问题了。。。

可是有时候不奔溃 有时候奔溃 好烦

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 4 天

发表于 5 天前 | 显示全部楼层
有点意思啊 中国语言编程 支持

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 5 天前 | 显示全部楼层
还是找不到问题。哎。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表