精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量★ 收各大平台交友来实力团队 ★高价收购各种交友粉◇█ 实力集团 长期有效 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量★ 实力工作室行业领跑者 ★高价收购各种WZ.JZ粉◆█ 实力集团 长期有效 █◆高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 加QQ群:892509555 ◆高价收购各种游戏WZ粉◇█ 收收收VX 40人小群 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 长期收抖音快手火山交友粉 ◆高价收购各种空间WZ粉◆█ 收收收VX 40人小群 █◆高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◇ 长期大量收社交平台交友粉 ◇高价收购各种朋友圈WZ粉◇█ 收收收VX 40人小群 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 欢迎各大实力工作室来对接 ◆寻有实力的短信群fa通道加Q525253◇█ 收收收VX 40人小群 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◇ 信誉第一,长久共赢 ◇寻有实力的短信群fa通道加Q525253◇█ 收收收VX 40人小群 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 全网寻求求包养粉商 ◆寻有实力的短信群fa通道加Q525253◇█加QQ群:773473674 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 加QQ群:892509555 ◆寻有实力的短信群fa通道加Q525253◆█ 收收收VX 40人小群 █◆高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 长期收抖音快手火山交友粉 ◆寻有实力的短信群fa通道加Q525253◇█ 收各种精准粉引到群 █◇高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◇ 长期大量收社交平台交友粉 ◇实力收精准粉大量稳定加Q525253 ◆█ 收各种精准粉引到群 █◇◆出各类精准流量,来实力团队◆
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 欢迎各大实力工作室来对接 ◆实力收精准粉大量稳定加Q525253◇█ 加QQ群:773473674 █◇◆出各类精准流量,来实力团队◆
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◇ 信誉第一,长久共赢 ◇实力收精准粉大量稳定加Q525253◆█ 收各种精准粉WZ 粉 █◇◆出各类精准流量,来实力团队◆
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 全网寻求求包养粉商 ◆实力收精准粉大量稳定加Q525253◆█ 收各种精准粉WZ 粉 █◇◆出各类精准流量,来实力团队◆
█ 公司 高价 收 引流 软件 渠道 █收各种质量交友粉 有质量就有大量◆ 加QQ群:892509555 ◆实力收精准粉大量稳定加Q525253◇█ 收各种精准粉WZ 粉 █◇◆出各类精准流量,来实力团队◆
【-->收群fa软件 Q86573011<--】〓出精准粉 可直推平台Q317738〓◆ 长期收抖音快手火山交友粉 ◆重金招SEO合作加QQ:525253◇█ 收各种精准粉WZ 粉 █◆◆出各类精准流量,来实力团队◆
星盟社群无限收精准网赚资源〓出精准粉 可直推平台Q317738〓◇ 长期大量收社交平台交友粉 ◇重金招SEO合作加QQ:525253◇█ 收各种精准粉WZ 粉 █◇◆出各类精准流量,来实力团队◆
星盟社群免费帮对接担保交易√√稳定出精准WZ粉 QQ7668827◆ 欢迎各大实力工作室来对接 ◆重金招SEO合作加QQ:525253◆█ 加QQ群:773473674 █◆◆出各类精准流量,来实力团队◆
星盟社群欢迎买卖方进群合作√√稳定出精准WZ粉 QQ7668827◇ 信誉第一,长久共赢 ◇重金招SEO合作加QQ:525253◇█ 收各种精准粉引到WX █◇◆出各类精准流量,来实力团队◆
星盟社群免费帮对接渠道资源█出网赚粉-量大真实-没实力勿扰█◆ 全网寻求求包养粉商 ◆重金招SEO合作加QQ:525253◆█ 收各种精准粉引到W █◆◆出各类精准流量,来实力团队◆
寻有实力的|邮件代发 朋友圈通道█出网赚粉-量大真实-没实力勿扰█◆ 加QQ群:892509555 ◆高价收引流思路加QQ:525253◇█ 收实力短信群FA通道 █◇◆出各类精准流量,来实力团队◆
寻有实力 微bo私信发送 短信通道█出网赚粉-量大真实-没实力勿扰█◆ 长期收抖音快手火山交友粉 ◆高价收引流思路加QQ:525253◆█ 收实力短信群FA通道 █◆◆出各类精准流量,来实力团队◆
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◇ 长期大量收社交平台交友粉 ◇高价收引流方式加QQ:525253◇█ 收各类精准资源到Q █◇◆出各类精准流量,来实力团队◆
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◆ 欢迎各大实力工作室来对接 ◆高价收引流方式加QQ:525253◆█加QQ群:773473674 █◆◆出各类精准流量,来实力团队◆
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◇ 信誉第一,长久共赢 ◇高价收引流方式加QQ:525253◇█ 高价收群FA 空间软件 █◇◆出各类精准流量,来实力团队◆
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◆ 全网寻求求包养粉商 ◆重金招易语言高手合作加QQ:525253◆█ 收收收VX 40人小群 █◆★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◆ 加QQ群:892509555 ◆重金招易语言高手合作加QQ:525253◇█ 收收收VX 40人小群 █◇★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◆ 长期收抖音快手火山交友粉 ◆重金招易语言高手合作加QQ:525253◆█ 收收收VX 40人小群 █◆★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价█出网赚粉-量大真实-没实力勿扰█◇ 长期大量收社交平台交友粉 ◇重金招易语言高手合作加QQ:525253◇█ 有大量粉的工作室来 █◇★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价★★★收活粉及引流软件技术★★◆ 欢迎各大实力工作室来对接 ◆重金招易语言高手合作加QQ:525253◆█ 有大量粉的工作室来 █◆★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价★★★收活粉及引流软件技术★★◇ 信誉第一,长久共赢 ◇高价收单项好友加QQ:525253◇█ 有大量粉的工作室来 █◇★★★★长期高价收任何流量★★★★
公司大量收活粉上QQ群 有量有价高价收购宝妈、女性粉:1513888885◆ 全网寻求求包养粉商 ◆高价收单项好友加QQ:525253◆█ 加QQ群:773473674 █◆收活粉导入公众号QQ群无限收
公司大量收活粉上QQ群 有量有价高价收购宝妈、女性粉:1513888885◆ 加QQ群:892509555 ◆高价收单项好友加QQ:525253◇█ 收收收VX 40人小群 █◇收活粉导入公众号QQ群无限收
→★长期收23+男粉 Q9585226 ★←团队大量收宝妈粉/兼职粉◆ 长期收抖音快手火山交友粉 ◆高价收单项好友加QQ:525253◆█ 收收收VX 40人小群 █◆收活粉导入公众号QQ群无限收
●长期收各渠道男粉 Q97588788 ●初次支持测试的来,骗子绕道◇ 长期大量收社交平台交友粉 ◇高价收单项好友加QQ:525253◇█ 稳定长期大量收精准粉 █◇收活粉导入公众号QQ群无限收
大量收软件小群粉大量出交友粉,各类精准用户粉◆ 欢迎各大实力工作室来对接 ◆出Q群粉及交友资源Q:492544249◆█ 加QQ群:773473674█◆收活粉导入公众号QQ群无限收
高价收群fa、空间软件能测试的来█网站统计█引流系统█◇ 信誉第一,长久共赢 ◇出交友粉网赚粉兼职粉精准粉◇█ 进群找管理 认准管理 █◇全网实力收各种活跃粉+Q727271543
出交友粉网赚粉JZ粉精准QQ验证粉短信群fa,Q:177685057 全行业◆ 全网寻求求包养粉商 ◆出网赚交友量上QQ微信QQ群◆█ 进群找管理 认准管理 █◆██████六年邮件█自助群fa█
█八闽社群限时入群资源担保对接█★★★收粉收粉直接加Q34662★★★ 收各大平台交友来实力团队 ★稳定短信卡fa,三网通,高到达率◇█ 实力公司 长期有效 █◇大量出交友男女粉 少量出兼职网赚
收粉出粉进群:788300023高转化收益产品直招一级代理★ 实力工作室行业领跑者 ★
【稳定长期出粉价低质量好】
◆█ 实力公司 长期有效 █◆我要租广告位
查看: 284|回复: 6
收起左侧

[易求助] 多线程启动 经常总奔溃软件,请高手看看问题出在什么地方!!!

[复制链接]

签到天数:1 天

结帖率:0% (0/1)
发表于 2019-6-12 18:34:27 | 显示全部楼层 |阅读模式
5精币



回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 2019-6-12 18:45:38 | 显示全部楼层
.版本 2
.支持库 EThread
.支持库 iext
.支持库 spec

.子程序 _按钮开始_被单击

按钮开始.禁止 = 真
zc启动线程 ()

.子程序 zc启动线程
.局部变量 i, 整数型
.局部变量 zc个数, 整数型
.局部变量 代理IP位置, 整数型
.局部变量 代理端口, 文本型
.局部变量 返回文本, 文本型

' ===============================================配置线程使用许可证
写出数据许可证 = 创建进入许可证 ()
插入列表数据许可证 = 创建进入许可证 ()
线程许可证 = 创建进入许可证 ()
累加计次成功_许可证 = 创建进入许可证 ()
累加计次失败_许可证 = 创建进入许可证 ()

.计次循环首 (到整数 (超级列表框1.取表项数 ()), i)

    ' ============================================================这里控制线程数
    线程数 = 线程数 + 1
    .判断循环首 (线程数 > 到整数 (编辑框线程数.内容))
        程序_延时 (100)
    .判断循环尾 ()

    CloseHandle (线程_启动 (&执行任务, 存放行数))  ' 启动线程
    立刻拨号 (编辑框宽带账号.内容, 编辑框宽带密码.内容, 到文本 (组合框_宽带配置.现行选中项), 编辑框次数换IP.内容)
    存放行数 = 存放行数 + 1
    .判断循环首 (暂停任务)
        程序_延时 (3000)
    .判断循环尾 ()
.计次循环尾 ()
.判断循环首 (线程数 > 0)
    程序_延时 (100)
.判断循环尾 ()

超级列表框1.保证显示 (0)
' 信息框 (“zc执行计划完成!!!”, 0, , )

.子程序 执行任务
.参数 索引, 整数型
.局部变量 n, 整数型
.局部变量 返回的文本, 文本型
.局部变量 ID, 文本型
.局部变量 对应ID, 整数型
.局部变量 反馈状态, 整数型
.局部变量 宽带账号, 文本型
.局部变量 宽带密码, 文本型
.局部变量 宽度电话簿编号, 文本型
.局部变量 准备拨号次数, 文本型

置随机数种子 ()
CoInitialize (0)
ID = 超级列表框1.取标题 (索引, 5)
返回的文本 = 网页_访问S (“https://www.xxxxx.com” + ID, 0, , “”, , )
调试输出 (返回的文本)
进入许可区 (插入列表数据许可证)
.如果 (寻找文本 (返回的文本, “Redire”, , 真) ≠ -1)
    超级列表框1.置标题 (索引, 6, “成功”)
    zc成功 = zc成功 + 1
    写出数据到文本 (“成功”, 超级列表框1.取标题 (索引, 1) + “---” + 超级列表框1.取标题 (索引, 2) + “---” + 超级列表框1.取标题 (索引, 3) + “---” + 超级列表框1.取标题 (索引, 4) + “---” + 超级列表框1.取标题 (索引, 5))
    编辑框zc成功.内容 = 到文本 (zc成功)
.否则
    超级列表框1.置标题 (索引, 6, “验证”)
.如果结束
退出许可区 (插入列表数据许可证)
进入许可区 (线程许可证)
线程数 = 线程数 - 1
CoUninitialize ()
退出许可区 (线程许可证)
返回 ()

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 9 天

发表于 2019-6-12 21:34:04 | 显示全部楼层
明显的 多线程直接操作窗口组件导致的

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 2019-6-12 23:00:20 | 显示全部楼层
荖貢 发表于 2019-6-12 21:34
明显的 多线程直接操作窗口组件导致的

窗口组件 能详细一些吗  感谢

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:100% (139/139)
发表于 2019-6-12 23:43:06 | 显示全部楼层
有个思路,可以试试一块一块的把代码砍掉,当砍到某一时刻发现,哎,好了,就知道问题了。。。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 2019-6-13 10:22:50 | 显示全部楼层
万里禅天 发表于 2019-6-12 23:43
有个思路,可以试试一块一块的把代码砍掉,当砍到某一时刻发现,哎,好了,就知道问题了。。。

可是有时候不奔溃 有时候奔溃 好烦

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:0% (0/1)
 楼主| 发表于 2019-6-13 12:39:29 | 显示全部楼层
还是找不到问题。哎。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表 按钮

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表