精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到 - 下载易语言


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◆█ 加QQ群:913248956 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989收106短信通道加Q96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989收106短信通道加Q96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◆█ 收运营商量 能测试来 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◇█ 收运营商量 能测试来 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收wz流量jz流量高价收购【全部行业精准粉】进群!
◆█ 收运营商量 能测试来 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收wz流量jz流量高价收购【全部行业精准粉】进群!
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类大平台小平台寻实力邮箱通道加QQ96086
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类大平台小平台寻实力邮箱通道加QQ96086
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站寻实力邮箱通道加QQ96086
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站寻实力邮箱通道加QQ96086
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站收邮箱粉 男活粉 QQ1011081819
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086收群fa软件 空间软件收验证粉 网游粉 QQ1011081819
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086收 wz粉 空间粉 群fa粉 jz粉大公司《无限量》收加Q:727999912
◆█ 长期包量收量 有量来谈 █◆◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◇█ 长期包量收量 有量来谈 █◇◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◆█ 长期包量收量 有量来谈 █◆◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█确实想稳定长期做的才来
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█重复量多的不结算
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086↓寻实力代收付合作↓死粉充量的不结算
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086→支持测试的加Q5770045←微商垃圾粉A开头多的不结算
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086 ↑寻有实力短信群fa通道↑收粉收粉收粉收各种粉加Q478649
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086
↑寻推广工作室合作◇收精准粉↑
收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086↑收各种引流软件推广渠道流量↑收粉收粉收粉收各种粉加Q478649
◆█寻QQ群F,QF软件定制高手█◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086████ 出W_群fa软件 ████收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086║支持语音/链接/图片/视频║收粉收粉收粉收各种粉加Q478649
◆█寻QQ群F,QF软件定制高手█◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086║ 实时独立统计 上粉流量 ║收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「SEO搜索引擎优化全包」
◆█寻QQ群F,QF软件定制高手█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「各大搜索引擎快速排名首页」
◇█寻QQ群F,QF软件定制高手█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「单词/整站提权/优化指导」
◆█进群找管理 明镜 认准明镜█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「专业团队/技术过硬」
◇█进群找管理 明镜 认准明镜█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「您的推广专家」
◆█进群找管理 明镜 认准明镜█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086出交友粉网赚粉JZ粉精准验证粉精准客户引流广告推送
◇█  实力公司 长期有效  █◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086大量收微信进群活跃男粉█出各类vx 寻业务合作q2212398
◆█  实力公司 长期有效  █◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989支持测试的加QQ96086实力一手群fa 日发大量Q313952847寻找技术大牛
◇█  实力公司 长期有效  █◇◇█收推广工作室合作绝对满意█◇全天-进群打赏-招代理Q2591111757支持测试的加QQ96086██████六年邮件█自助群fa█收 交友粉长期合作 +Q 2422310943
◆█  实力公司 长期有效  █◆◇█收推广工作室合作绝对满意█◇全天-进群打赏-招代理Q2591111757支持测试的加QQ96086代加指定QQ好友_日加大量_先货后款我要租广告位
查看: 436|回复: 4
收起左侧

[已解决] 进制换位转换。蒙圈求助

 关闭 [复制链接]
结帖率:100% (5/5)
发表于 2019-5-16 01:59:29 | 显示全部楼层 |阅读模式
5精币
看出他10进制转换16进制的换位了。不知道怎么写了。

哪位高手写段学习下!感谢

十进制转换十六进制 换位.e

32.91 KB, 下载次数: 1

微信截图_20190516015206.png

最佳答案

查看完整内容

你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接 .版本 2 进制_十到十六 () 即可

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:58% (7/12)
发表于 2019-5-16 01:59:30 | 显示全部楼层
你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接  .版本 2

进制_十到十六 ()

即可

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 10:17:23 | 显示全部楼层
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 卡号, 文本型
.局部变量 固定文本, 文本型
.局部变量 十六进制, 文本型
.局部变量 i, 整数型
.局部变量 临时文本, 文本型

固定文本 = “0000000002202020202020fc70”
卡号 = 编辑框1.内容
临时文本 = 进制_十到十六 (到长整数 (卡号))

.计次循环首 (2 - 取文本长度 (进制_十到十六 (到长整数 (卡号))), )
    临时文本 = “0” + 临时文本 + 固定文本

.计次循环尾 ()

编辑框2.内容 = “00c3” + 临时文本
调试输出 (临时文本)


.子程序 进制_十到十六, 文本型
.参数 十进制数, 长整数型
.局部变量 余数数组, 文本型, , "0"
.局部变量 tempint, 长整数型
.局部变量 str, 文本型
.局部变量 余, 整数型

余数数组 = { “0”, “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “A”, “B”, “C”, “D”, “E”, “F” }
tempint = 十进制数
.判断循环首 (tempint ≥ 0)  ' 除16取余,结果倒序
    余 = tempint % 16
    str = 余数数组 [余 + 1] + str
    tempint = (tempint - 余) ÷ 16  ' zc()
    .如果真 (tempint ≤ 0)  ' 如果为0,则跳出循环。
        跳出循环 ()
    .如果真结束

.判断循环尾 ()
返回 (str)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 12:43:21 | 显示全部楼层
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
变量名类 型静态数组备 注
卡号文本型 
固定文本1文本型 
十六进制文本型 
i整数型 
临时文本文本型 
四位右文本型 
四位左文本型 
固定文本2文本型 
固定文本1 = “0000000002202020202020fc70”
固定文本2 = “00000002202020202020fc70”
卡号 = 编辑框1.内容
临时文本 = 进制_十到十六 (到长整数 (卡号))
如果真 (取文本长度 (临时文本) = 1 取文本长度 (临时文本) = 2)
编辑框2.内容 = “00c3”取文本右边 (“0” + 临时文本, 2) + 固定文本1
如果真 (取文本长度 (临时文本) = 3 取文本长度 (临时文本) = 4)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = “00c3” + 四位右 + 四位左 + 固定文本2
如果真 (取文本长度 (临时文本) = 5)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = 取文本左边 (临时文本, 1)“0c3” + 四位右 + 四位左 + 固定文本2
如果真 (取文本长度 (临时文本) = 6)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = 取文本中间 (临时文本, 2, 1)取文本左边 (临时文本, 1)“c3” + 四位右 + 四位左 + 固定文本2

子程序名返回值类型公开备 注
进制_十到十六文本型 
参数名类 型参考可空数组备 注
十进制数长整数型
变量名类 型静态数组备 注
余数数组文本型0
tempint长整数型 
str文本型 
整数型 
余数数组 = { “0”, “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “A”, “B”, “C”, “D”, “E”, “F” }
tempint = 十进制数
判断循环首 (tempint ≥ 0)  ' 除16取余,结果倒序
余 = tempint % 16
str = 余数数组 [余 + 1] + str
tempint (tempint - 余) ÷ 16  ' zc()
如果真 (tempint ≤ 0)  ' 如果为0,则跳出循环。
跳出循环 ()

判断循环尾 ()
返回 (str)



自己捣鼓出来了。不知道正确不!

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 12:44:51 | 显示全部楼层
longhenji 发表于 2019-5-16 08:52
你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接  .版本 2

进制_十到十六 () ...

哈,谢了 。怎么不提示下 取文本左边右边中间呢。就这里卡住了!

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /2 下一条

发布主题 收藏帖子 返回列表 按钮 关注QQ

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表