精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱┃ 服务器出租E3单路E5双路E5 ┃ 长期 包养全网交友粉大户高价收购QQ单项双向好友寻有实力的短信群fa通道加Q525253高价收购【全部行业精准粉】进群!
2019年好项目,每月多挣好多钱┃ 模拟器虚拟机多开! 单进程 ┃长期 包养全网交友粉大户高价包养交友粉寻有实力的短信群fa通道加Q525253高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█长期大量收购各种活粉█长期 包养全网交友粉大户高价包养交友粉寻有实力的短信群fa通道加Q525253高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█ 长期收购各种引流软件 █长期 包养全网交友粉大户高价包养交友粉寻有实力的短信群fa通道加Q525253高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服①高价包养交友粉寻有实力的短信群fa通道加Q525253高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服①实力公司大量收粉实力收精准粉大量稳定加Q525253高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服①交友粉 婚恋粉 各种活粉实力收精准粉大量稳定加Q525253高价收购【全部行业精准粉】进群!
【-->收群fa软件 Q86573011<--】日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服②另收土豆社交APP活粉实力收精准粉大量稳定加Q525253高价收购【全部行业精准粉】进群!
星盟社群无限收精准网赚资源日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830实力收精准粉大量稳定加Q525253高价收购【全部行业精准粉】进群!
星盟社群免费帮对接担保交易日吃8000+收一手零转化微信小群粉各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830实力收精准粉大量稳定加Q525253高价收购【全部行业精准粉】进群!
星盟社群欢迎买卖方进群合作日吃8000+收一手零转化微信小群粉┏┏ 全网大量收交友粉 ┓┓无限收交友粉 引流软件 qq7305830██   实力公司  长期有效 ██高价收购【全部行业精准粉】进群!
星盟社群免费帮对接渠道资源日吃8000+收一手零转化微信小群粉〓 各种APP交友粉 〓无限收交友粉 引流软件 qq7305830██   收收收收  引流软件 ██高价收购【全部行业精准粉】进群!
█     高 收 益 项 目   █日吃8000+收一手零转化微信小群粉〓  抖音 快手 火山  〓收男女粉+q6563057██   收收收收  引流脚本 ██高价收购【全部行业精准粉】进群!
█      耗资巨大     █日吃8000+收一手零转化微信小群粉〓   附 近 人    〓收男女粉+q6563057██  收收收收  引流思路 ██高价收购【全部行业精准粉】进群!
█      市场最牛     █日吃8000+收一手零转化微信小群粉〓 各论坛美拍部落 〓高价收qq渠道,交友粉+q6563057██   收收收收  群fa软件 ██高价收购【全部行业精准粉】进群!
█   支 持     日 结   █日吃8000+收一手零转化微信小群粉〓各种活人粉实力对接〓高价收qq渠道,交友粉+q6563057██   收收收收 精准wz粉 ██高价收购【全部行业精准粉】进群!
█   咨询QQ   880194   █日吃8000+收一手零转化微信小群粉〓大小量通吃欢迎来撩〓收收收大量宝妈粉QQ289259██  收收收收  精准zy粉 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉〓 稳定全年365天收 〓收收收.微信扫码进群.加QQ9703796██  收收收收  引流人才 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉〓 无限 收交友粉 〓█★█长期收购网赚精准粉█★███   收收收收 引流方式 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█ ★出WZ粉 出引流软件Q317738★┗┗ 全网最高单价收粉 ┛┛█★█大量收临过期企业Q粉█★███ 收收收收 易语言高手 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█ ★出WZ粉 出引流软件Q317738★◆大量收婚恋宝妈快手火山◆鼎信社群高价收WZ各类热门资源██   收收收收  软件定制 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█████收购微信收租量QQ55698545◇稳定收交友粉,找我换钱◇鼎信社万人对接基地高效出粉收粉██收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █████收购微信收租量QQ55698545◆收快手火山虎牙找我换钱◆███ 鼎信社群 行业顶尖 █████收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █我司《包养+包养+包养》◇长期收交友粉大小量通吃◇鼎信社群欢迎各类 商人对接入驻██收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █**各种网赚兼职粉大户**◆ 婚恋/抖音/空间/快手 ◆鼎信社欢迎各类粉商精英对接交流██  加qq群:839661627 ██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █**各种网赚兼职粉大户**◇ 优质有量的找我换钱 ◇█收交友粉 价格美丽 只走担保███  加qq群:839661627 ██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █支持测试的才加我◆ 实力大型公司收媒体量 ◆█收交友粉 价格美丽 只走担保███收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
全网最高单价收粉QQ420073工资车的不要来恶心◇ 大量资金 ,来一收代理 ◇█收交友粉 价格美丽 只走担保███收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
实力收购各种粉加QQ420073全网大量收各种APP交友粉,◆ 无限收交友粉交友粉 ◆█收交友粉 价格美丽 只走担保███收实力的短信群fa通道██高价收购【全部行业精准粉】进群!
收购精准兼职粉加QQ420073全网大量收各种APP交友粉,◇ 各种活人粉实力对接 ◇日引1000+精准粉求包养QQ10917██ 进群找管理 备注引流 ██高价收购【全部行业精准粉】进群!
收购精准网赚粉加QQ420073全网大量收各种APP交友粉,全网大量收各种APP交友粉,日引1000+精准粉求包养QQ10917██ 进群找管理 备注引流 ██高价收购【全部行业精准粉】进群!
收购软件渠道思路QQ420073包养全网交友粉大户包养全网交友粉大户日引1000+精准粉求包养QQ10917██ 进群找管理 备注引流 ██高价收购【全部行业精准粉】进群!
大量收微信进群粉联系q584121900包养全网交友粉大户全网大量收各种APP交友粉,日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
出微信qq交友粉网赚粉精准粉兼职长期出QQ群QQ号微信精准粉网挣粉包养全网交友粉大户日引1000+精准粉求包养QQ10917高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
大量出各类精准用户粉,全行业私信出QQ群微信QQ号交友粉网赚粉兼职粉全网大量收各种APP交友粉,出全行业各类粉,种类全刷新快高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
★工作室长期出抖音WZ粉Q159907大量出QQ网赚粉微信粉Q群精准活粉包养全网交友粉大户高价收网吧终端量联系Q1908886662高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█网站统计█I引流系统█I出Q群粉及交友资源Q:492544249全网大量收各种APP交友粉,★出售网赚 各种精准粉全行业可上高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
高价收微信进群活跃男粉公司高价收购流量包养全网交友粉大户服务器出租E3-E5-单进程高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
软件开发商实力出QQ网赚粉兼职粉出游戏粉 游戏粉加Q245014016全网大量收各种APP交友粉,出Q群微信直播粉联系Q2604720501高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
出兼职粉有实力的来高价大量收 大龄  空间量 网赚粉包养全网交友粉大户高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!我要租广告位
查看: 285|回复: 4
收起左侧

[已解决] 进制换位转换。蒙圈求助

 关闭 [复制链接]

签到天数:3 天

结帖率:100% (5/5)
发表于 2019-5-16 01:59:29 | 显示全部楼层 |阅读模式
5精币
看出他10进制转换16进制的换位了。不知道怎么写了。

哪位高手写段学习下!感谢

十进制转换十六进制 换位.e

32.91 KB, 下载次数: 1

微信截图_20190516015206.png

最佳答案

查看完整内容

你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接 .版本 2 进制_十到十六 () 即可

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 9 天

结帖率:58% (7/12)
发表于 2019-5-16 01:59:30 | 显示全部楼层
你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接  .版本 2

进制_十到十六 ()

即可

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 10:17:23 | 显示全部楼层
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 卡号, 文本型
.局部变量 固定文本, 文本型
.局部变量 十六进制, 文本型
.局部变量 i, 整数型
.局部变量 临时文本, 文本型

固定文本 = “0000000002202020202020fc70”
卡号 = 编辑框1.内容
临时文本 = 进制_十到十六 (到长整数 (卡号))

.计次循环首 (2 - 取文本长度 (进制_十到十六 (到长整数 (卡号))), )
    临时文本 = “0” + 临时文本 + 固定文本

.计次循环尾 ()

编辑框2.内容 = “00c3” + 临时文本
调试输出 (临时文本)


.子程序 进制_十到十六, 文本型
.参数 十进制数, 长整数型
.局部变量 余数数组, 文本型, , "0"
.局部变量 tempint, 长整数型
.局部变量 str, 文本型
.局部变量 余, 整数型

余数数组 = { “0”, “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “A”, “B”, “C”, “D”, “E”, “F” }
tempint = 十进制数
.判断循环首 (tempint ≥ 0)  ' 除16取余,结果倒序
    余 = tempint % 16
    str = 余数数组 [余 + 1] + str
    tempint = (tempint - 余) ÷ 16  ' zc()
    .如果真 (tempint ≤ 0)  ' 如果为0,则跳出循环。
        跳出循环 ()
    .如果真结束

.判断循环尾 ()
返回 (str)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 12:43:21 | 显示全部楼层
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
变量名类 型静态数组备 注
卡号文本型  
固定文本1文本型  
十六进制文本型  
i整数型  
临时文本文本型  
四位右文本型  
四位左文本型  
固定文本2文本型  
固定文本1 = “0000000002202020202020fc70”
固定文本2 = “00000002202020202020fc70”
卡号 = 编辑框1.内容
临时文本 = 进制_十到十六 (到长整数 (卡号))
如果真 (取文本长度 (临时文本) = 1 取文本长度 (临时文本) = 2)
编辑框2.内容 = “00c3”取文本右边 (“0” + 临时文本, 2) + 固定文本1
如果真 (取文本长度 (临时文本) = 3 取文本长度 (临时文本) = 4)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = “00c3” + 四位右 + 四位左 + 固定文本2
如果真 (取文本长度 (临时文本) = 5)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = 取文本左边 (临时文本, 1)“0c3” + 四位右 + 四位左 + 固定文本2
如果真 (取文本长度 (临时文本) = 6)
四位右 = 取文本右边 (取文本右边 (“0” + 临时文本, 4), 2)
四位左 = 取文本左边 (取文本右边 (“0” + 临时文本, 4), 2)
编辑框2.内容 = 取文本中间 (临时文本, 2, 1)取文本左边 (临时文本, 1)“c3” + 四位右 + 四位左 + 固定文本2

子程序名返回值类型公开备 注
进制_十到十六文本型 
参数名类 型参考可空数组备 注
十进制数长整数型   
变量名类 型静态数组备 注
余数数组文本型 0
tempint长整数型  
str文本型  
整数型  
余数数组 = { “0”, “1”, “2”, “3”, “4”, “5”, “6”, “7”, “8”, “9”, “A”, “B”, “C”, “D”, “E”, “F” }
tempint = 十进制数
判断循环首 (tempint ≥ 0)  ' 除16取余,结果倒序
余 = tempint % 16
str = 余数数组 [余 + 1] + str
tempint (tempint - 余) ÷ 16  ' zc()
如果真 (tempint ≤ 0)  ' 如果为0,则跳出循环。
跳出循环 ()

判断循环尾 ()
返回 (str)



自己捣鼓出来了。不知道正确不!

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:100% (5/5)
 楼主| 发表于 2019-5-16 12:44:51 | 显示全部楼层
longhenji 发表于 2019-5-16 08:52
你想自己写底层代码实现,还是说只是想实现这个功能, 如果实现功能的话直接  .版本 2

进制_十到十六 () ...

哈,谢了 。怎么不提示下 取文本左边右边中间呢。就这里卡住了!

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表