精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

█     高 收 益 项 目   █日吃8000+收一手零转化微信小群粉★ 收各大平台交友来实力团队 ★高价收购各种交友粉██ 实力公司 长期有效 ██高价收购【全部行业精准粉】进群!
█      耗资巨大     █日吃8000+收一手零转化微信小群粉★ 实力工作室行业领跑者 ★高价收购各种WZ.JZ粉██ 收收收收 引流软件 ██高价收购【全部行业精准粉】进群!
█      市场最牛     █日吃8000+收一手零转化微信小群粉◆ 加QQ群:892509555 ◆高价收购各种游戏WZ粉██ 收收收收 引流脚本 ██高价收购【全部行业精准粉】进群!
█   支 持     日 结   █日吃8000+收一手零转化微信小群粉◆ 长期收抖音快手火山交友粉 ◆高价收购各种空间WZ粉██ 收收收收 引流思路 ██高价收购【全部行业精准粉】进群!
█   咨询QQ   880194   █日吃8000+收一手零转化微信小群粉◇ 长期大量收社交平台交友粉 ◇高价收购各种朋友圈WZ粉██ 收收收收 群fa软件 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉◆ 欢迎各大实力工作室来对接 ◆寻有实力的短信群fa通道加Q525253██ 收收收收 精准wz粉 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉◇ 信誉第一,长久共赢 ◇寻有实力的短信群fa通道加Q525253██ 收收收收 精准zy粉 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉◆ 全网寻求求包养粉商 ◆寻有实力的短信群fa通道加Q525253██ 收收收收 引流人才 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉◆ 加QQ群:892509555 ◆寻有实力的短信群fa通道加Q525253██ 收收收收 引流方式 ██高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█日吃8000+收一手零转化微信小群粉◆ 长期收抖音快手火山交友粉 ◆寻有实力的短信群fa通道加Q525253██ 收收收收 易语言高手██高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █日吃8000+收一手零转化微信小群粉◇ 长期大量收社交平台交友粉 ◇实力收精准粉大量稳定加Q525253██ 收收收收 软件定制 ██承接:App Xp插件 爬虫 Js Pc应用
█ 公司 高价 收 引流 软件 渠道 █日吃8000+收一手零转化微信小群粉◆ 欢迎各大实力工作室来对接 ◆实力收精准粉大量稳定加Q525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
█ 公司 高价 收 引流 软件 渠道 █日吃8000+收一手零转化微信小群粉◇ 信誉第一,长久共赢 ◇实力收精准粉大量稳定加Q525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
█ 公司 高价 收 引流 软件 渠道 █日吃8000+收一手零转化微信小群粉◆ 全网寻求求包养粉商 ◆实力收精准粉大量稳定加Q525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
█ 公司 高价 收 引流 软件 渠道 █日吃8000+收一手零转化微信小群粉◆ 加QQ群:892509555 ◆实力收精准粉大量稳定加Q525253██ 加qq群:773473674 ██承接:App Xp插件 爬虫 Js Pc应用
【-->收群fa软件 Q86573011<--】〓出精准粉 可直推平台Q317738〓◆ 长期收抖音快手火山交友粉 ◆重金招SEO合作加QQ:525253██ 加qq群:773473674 ██承接:App Xp插件 爬虫 Js Pc应用
星盟社群无限收精准网赚资源〓出精准粉 可直推平台Q317738〓◇ 长期大量收社交平台交友粉 ◇重金招SEO合作加QQ:525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
星盟社群免费帮对接担保交易》朋友圈广告商,支持拉群截图的来◆ 欢迎各大实力工作室来对接 ◆重金招SEO合作加QQ:525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
星盟社群欢迎买卖方进群合作》朋友圈广告商,支持拉群截图的来◇ 信誉第一,长久共赢 ◇重金招SEO合作加QQ:525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
星盟社群免费帮对接渠道资源》朋友圈广告商,支持拉群截图的来◆ 全网寻求求包养粉商 ◆重金招SEO合作加QQ:525253██收实力的短信群fa通道██承接:App Xp插件 爬虫 Js Pc应用
█收交友粉 王者荣耀粉 价格好█》朋友圈广告商,支持拉群截图的来◆ 加QQ群:892509555 ◆高价收引流思路加QQ:525253██ 收空间 说说软件 ██◆出各类精准流量,来实力团队◆
█收交友粉 王者荣耀粉 价格好█》加QQ:5840875◆ 长期收抖音快手火山交友粉 ◆高价收引流思路加QQ:525253██ 收空间 说说软件 ██◆出各类精准流量,来实力团队◆
█收交友粉 王者荣耀粉 价格好█》能做vx群发好友的团队加我◇ 长期大量收社交平台交友粉 ◇高价收引流方式加QQ:525253██ 收空间 说说软件 ██◆出各类精准流量,来实力团队◆
█收交友粉 王者荣耀粉 价格好█》能做vx群发好友的团队加我◆ 欢迎各大实力工作室来对接 ◆高价收引流方式加QQ:525253██ 收空间 说说软件 ██◆出各类精准流量,来实力团队◆
███收精准粉和引流软件███》能做vx群发好友的团队加我◇ 信誉第一,长久共赢 ◇高价收引流方式加QQ:525253██ 收空间 说说软件 ██◆出各类精准流量,来实力团队◆
███收精准粉和引流软件███》微商团队的能群fa、发圈的加我◆ 全网寻求求包养粉商 ◆重金招易语言高手合作加QQ:525253██ 收空间 相册软件 ██◆出各类精准流量,来实力团队◆
寻有实力的|邮件代发 朋友圈通道》微商团队的能群fa、发圈的加我◆ 加QQ群:892509555 ◆重金招易语言高手合作加QQ:525253██ 收空间 相册软件 ██◆出各类精准流量,来实力团队◆
寻有实力 微bo私信发送 短信通道█ 长期收购各种引流软件 █◆ 长期收抖音快手火山交友粉 ◆重金招易语言高手合作加QQ:525253██ 收空间 相册软件 ██◆出各类精准流量,来实力团队◆
大量出售网赚粉,保证真实,量大█ 长期大量收购各种活粉 █◇ 长期大量收社交平台交友粉 ◇重金招易语言高手合作加QQ:525253██ 收空间 相册软件 ██◆出各类精准流量,来实力团队◆
大量出售网赚粉,保证真实,量大▲全网重金寻引流高手商务合作▲◆ 欢迎各大实力工作室来对接 ◆重金招易语言高手合作加QQ:525253██ 收空间 相册软件 ██◆出各类精准流量,来实力团队◆
大量出售网赚粉,保证真实,量大▲全网重金寻网站高手商务合作▲◇ 信誉第一,长久共赢 ◇高价收单项好友加QQ:525253██ 进群找管理 备注引流 ██◆出各类精准流量,来实力团队◆
大量出售网赚粉,保证真实,量大▲全网重金寻直播流量商务合作▲◆ 全网寻求求包养粉商 ◆高价收单项好友加QQ:525253██ 进群找管理 备注引流 ██◆出各类精准流量,来实力团队◆
大量出售网赚粉,保证真实,量大▲全网重金寻精准流量商务合作▲◆ 加QQ群:892509555 ◆高价收单项好友加QQ:525253██ 进群找管理 备注引流 ██◆出各类精准流量,来实力团队◆
大量收微信进群粉联系q584121900▲▲▲▲▲QQ831397▲▲▲▲▲◆ 长期收抖音快手火山交友粉 ◆高价收单项好友加QQ:525253██ 进群找管理 备注引流 ██◆出各类精准流量,来实力团队◆
大量出各类精准用户粉,全行业私信█收网赚精准粉★★各引流软件█◇ 长期大量收社交平台交友粉 ◇高价收单项好友加QQ:525253██ 进群找管理 备注引流 ██◆出各类精准流量,来实力团队◆
出交友粉网赚粉兼职粉精准粉出Q群粉及交友资源Q:492544249◆ 欢迎各大实力工作室来对接 ◆高价收群fa、空间软件能测试的来██ 进群找管理 备注引流 ███网站统计█I引流系统█I
高价收微信进群活跃男粉★█出高质量男粉,时速2000+█★◇ 信誉第一,长久共赢 ◇实力短信群fa 接各种单 +Q1890702██ 进群找管理 备注引流 ██急急急.大量收宝妈粉+Q481689999
全网实力收各种活跃粉+Q727271543出售高质量网赚粉 QQ5661205◆ 全网寻求求包养粉商 ◆出交友粉网赚粉JZ粉精准QQ验证粉██ 进群找管理 备注引流 ██短信群fa,Q:177685057 全行业
出网赚交友量上QQ微信QQ群★★★★长期高价收任何流量★★★★★ 收各大平台交友来实力团队 ★出精准兼职粉联系Q:350604342██ 进群找管理 备注引流 ██高转化收益产品直招一级代理
收游戏点卡与海外引流技术粉丝出高质量精准粉★加Q7668827★★ 实力工作室行业领跑者 ★
██████六年邮件█明文代发█
██ 进群找管理 备注引流 ██我要租广告位
查看: 5404|回复: 89
收起左侧

[易语言纯源码] [分享源码] EClass 易语言类操作 模块开源

    [复制链接]

签到天数:17 天

结帖率:100% (1/1)
发表于 2019-5-5 14:44:26 | 显示全部楼层 |阅读模式
分享源码
界面截图: -
是否带模块: 纯源码
备注说明: -
本帖最后由 LeyBc 于 2019-5-5 16:08 编辑

EClass 易语言类操作 本模块主要是为了弥补易语言类的不足
易语言的类:
1、成员无法公开,无法对成员直接赋值
2、未公开的方法,无法直接调用[貌似是废话]

封装了 英文方法和中文方法
  1. .版本 2

  2. .子程序 bindMember, , ,
  3. .参数 MemberNameArr, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 CallFun, 整数型, , 调用方法 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  5. .参数 pFunc, 整数型, ,
  6. .参数 buf, 整数型, 可空 ,
  7. .参数 arg1, 整数型, 可空 ,
  8. .参数 arg2, 整数型, 可空 ,
  9. .参数 arg3, 整数型, 可空 ,
  10. .参数 arg4, 整数型, 可空 ,
  11. .参数 arg5, 整数型, 可空 ,

  12. .子程序 getClassFunCount, 整数型, , 取方法数 先调用 getClassFunPoint

  13. .子程序 getClassFunPoint, 整数型, , 取类方法指针 先调用 getClassPoint

  14. .子程序 getClassPoint, 整数型, , 取类指针
  15. .参数 Class, 通用型, 参考 ,

  16. .子程序 getFunPoint, 整数型, , 取方法指针 先调用  getClassFunCount 取出指针后 可以直接 对方法调用 不论方法是否公开
  17. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  18. .子程序 getMemberCount, 整数型, , 取成员数 先调用 getClassPoint

  19. .子程序 getMemberPoint, 整数型, ,  取成员指针 先调用  getMemberCount  取出指针后 可以直接 对 数据进行读写
  20. .参数 Id, 整数型, ,

  21. .子程序 getVarAddress, 整数型, , 取地址 如果写入数据是非整数型,调用这个
  22. .参数 Var, 通用型, 参考 ,

  23. .子程序 setMemberValueById, 逻辑型, , 置成员值 先调用  getMemberCount
  24. .参数 ID, 整数型, ,
  25. .参数 Value, 整数型, , 非整数型 请调用 取地址

  26. .子程序 setMemberValueByName, 逻辑型, , 先调用  getMemberCount  和 bindMember
  27. .参数 MemberName, 文本型, ,
  28. .参数 Value, 整数型, , 非整数型 请调用 取地址


复制代码



2019-05-05_143240.png




  1. .版本 2

  2. .子程序 绑定成员, , ,
  3. .参数 成员名, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 取成员数, 整数型, , 先调用 取类指针

  5. .子程序 取成员指针, 整数型, , 先调用  取成员数  取出指针后 可以直接 对 数据进行读写
  6. .参数 第几个成员, 整数型, ,

  7. .子程序 取地址, 整数型, , 如果写入数据是非整数型,调用这个
  8. .参数 参数, 通用型, 参考 ,

  9. .子程序 取方法数, 整数型, , 先调用 取类方法指针

  10. .子程序 取方法指针, 整数型, , 先调用  取方法数 取出指针后 可以直接 对方法调用 不论方法是否公开
  11. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  12. .子程序 取类方法指针, 整数型, , 先调用 取类指针

  13. .子程序 取类指针, 整数型, ,
  14. .参数 类, 通用型, 参考 ,

  15. .子程序 调用方法, 整数型, , 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  16. .参数 子程序指针, 整数型, ,
  17. .参数 缓存区, 整数型, 可空 ,
  18. .参数 参数1, 整数型, 可空 ,
  19. .参数 参数2, 整数型, 可空 ,
  20. .参数 参数3, 整数型, 可空 ,
  21. .参数 参数4, 整数型, 可空 ,
  22. .参数 参数5, 整数型, 可空 ,

  23. .子程序 置成员值_ID, 逻辑型, , 先调用  取成员数
  24. .参数 第几个成员, 整数型, ,
  25. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址

  26. .子程序 置成员值_名称, 逻辑型, , 先调用  取成员数 和 绑定成员
  27. .参数 参数名, 文本型, ,
  28. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址</font>


复制代码




2.png


调用代码截图


3.png


类截图


4.png


运行效果演示




ys.gif
调试结果 截图
5.png
此模块中不含任何的广告,也不带任何盈利性质。如有雷同,纯属巧合
如果你觉得不错,请点赞即可!回帖下载

说明:代码写的不太严谨,比如某些数组越界的可能性没去判断,各位需要的话,自行判断一下

EClass_易语言类操作.e (29.96 KB, 下载次数: 142)
QQ截图20190505142932.jpg

评分

参与人数 14好评 +11 精币 +31 收起 理由
[锄禾曰当午] + 1 新技能已get√
皮皮驴 + 1 感谢发布原创作品,精易因你更精彩!
fn1992321 + 1 + 1 支持开源~!感谢分享
含沙射影 + 1 + 2 支持开源~!感谢分享
易语言资源网 + 1 + 5 支持开源~!感谢分享
Ossian + 1 + 2 支持开源~!感谢分享
songue + 1 + 2 精彩文章希望继续努力
kyo9766 + 1 + 2 支持开源~!感谢分享
ljaihong + 1 + 2 支持开源~!感谢分享
101232 + 1 + 2 支持开源~!感谢分享
Sad.XkM + 1 + 2 支持开源~!感谢分享
大司命 + 1 + 5 支持开源~!感谢分享
汉族 + 1 + 2 支持开源~!感谢分享
冯古屋 + 2 支持开源~!感谢分享

查看全部评分


您可以选择打赏方式支持楼主

本帖被以下淘专辑推荐:

签到天数: 2 天

发表于 2019-6-25 09:25:09 | 显示全部楼层
感谢发布原创作品,精易因你更精彩!精彩文章希望继续努力
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (3/3)
发表于 2019-6-24 15:29:47 | 显示全部楼层
这个牛逼了
回复

使用道具 举报

签到天数: 18 天

发表于 2019-6-23 08:13:38 | 显示全部楼层
这个好,现在正缺这个
回复

使用道具 举报

签到天数: 19 天

发表于 2019-6-20 22:37:11 | 显示全部楼层
腻害!!
回复

使用道具 举报

发表于 2019-6-18 10:32:56 | 显示全部楼层
支持开源~!感谢分享
回复

使用道具 举报

签到天数: 12 天

结帖率:100% (2/2)
发表于 2019-6-11 14:19:08 | 显示全部楼层
支持开源~!感谢分享
回复

使用道具 举报

签到天数: 13 天

结帖率:75% (30/40)
发表于 2019-6-10 08:15:09 | 显示全部楼层
谢谢分享  学习
回复

使用道具 举报

发表于 2019-6-3 16:43:34 | 显示全部楼层
谢谢分享  学习
回复

使用道具 举报

签到天数: 12 天

结帖率:0% (0/1)
发表于 2019-6-3 14:20:29 | 显示全部楼层
支持开源~!感谢分享支持开源~!感谢分享支持开源~!感谢分享支持开源~!感谢分享支持开源~!感谢分享
回复

使用道具 举报

发表于 2019-5-31 18:33:52 | 显示全部楼层
我没什么别的了,。。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表