精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到 - 下载易语言


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◆█ 加QQ群:913248956 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989支持测试的加QQ96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989收106短信通道加Q96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989收106短信通道加Q96086█寻QQ群F、QF软件定制高手█高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◇█ 加QQ群:913248956 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◆█ 收运营商量 能测试来 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收百度权重广告位置高价收购【全部行业精准粉】进群!
◇█ 收运营商量 能测试来 █◇◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收wz流量jz流量高价收购【全部行业精准粉】进群!
◆█ 收运营商量 能测试来 █◆◇█高价收地推团队带上实力来█◇收各渠道精准粉有量稳定加Q629989寻有实力的短信群fa通道加Q96086收wz流量jz流量高价收购【全部行业精准粉】进群!
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类大平台小平台寻实力邮箱通道加QQ96086
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类大平台小平台寻实力邮箱通道加QQ96086
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站寻实力邮箱通道加QQ96086
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站寻实力邮箱通道加QQ96086
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989实力收精准粉大量稳定加Q96086收各类高流量网站收邮箱粉 男活粉 QQ1011081819
◆█ 收运营商量 能测试来 █◆◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989重金招SEO合作加QQ:96086收群fa软件 空间软件收验证粉 网游粉 QQ1011081819
◇█ 收运营商量 能测试来 █◇◇█高单价收推广量有渠道的来█◇收各渠道精准粉有量稳定加Q629989重金招SEO合作加QQ:96086收 wz粉 空间粉 群fa粉 jz粉大公司《无限量》收加Q:727999912
◆█ 长期包量收量 有量来谈 █◆◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◇█ 长期包量收量 有量来谈 █◇◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◆█ 长期包量收量 有量来谈 █◆◇█高单价收推广量有渠道的来█◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█40人小群
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█确实想稳定长期做的才来
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█重复量多的不结算
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█死粉充量的不结算
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086█收网吧量、收终端、有实力的来█微商垃圾粉A开头多的不结算
◇█ 长期包量收量 有量来谈 █◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086█收网吧量、收终端、有实力的来█收粉收粉收粉收各种粉加Q478649
◆█ 长期包量收量 有量来谈 █◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086↓寻实力代收付合作↓收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086→支持测试的加Q5770045←收粉收粉收粉收各种粉加Q478649
◆█寻QQ群F,QF软件定制高手█◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086 ↑寻有实力短信群fa通道↑收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招易语言高手合作加QQ:96086
↑寻推广工作室合作◇收精准粉↑
收粉收粉收粉收各种粉加Q478649
◆█寻QQ群F,QF软件定制高手█◆◇█ 合 作 加 QQ:318777777 █◇引流支持测试量大的收购加Q629989重金招SEO合作加QQ:96086↑收各种引流软件推广渠道流量↑收粉收粉收粉收各种粉加Q478649
◇█寻QQ群F,QF软件定制高手█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「SEO搜索引擎优化全包」
◆█寻QQ群F,QF软件定制高手█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「各大搜索引擎快速排名首页」
◇█寻QQ群F,QF软件定制高手█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「单词/整站提权/优化指导」
◆█进群找管理 明镜 认准明镜█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「专业团队/技术过硬」
◇█进群找管理 明镜 认准明镜█◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086收一切真实流量日结联系QQ7971422「您的推广专家」
◆█进群找管理 明镜 认准明镜█◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086█收网吧量、收终端、有实力的来█精准客户引流广告推送
◇█  实力公司 长期有效  █◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989高价收单项好友加QQ:96086大量收微信进群活跃男粉█出各类vx 寻业务合作q2212398
◆█  实力公司 长期有效  █◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989支持测试的加QQ96086实力一手群fa 日发大量Q313952847寻找技术大牛
◇█  实力公司 长期有效  █◇◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989支持测试的加QQ96086██████六年邮件█自助群fa█收 交友粉长期合作 +Q 2422310943
◆█  实力公司 长期有效  █◆◇█收推广工作室合作绝对满意█◇引流支持测试量大的收购加Q629989支持测试的加QQ96086代加指定QQ好友_日加大量_先货后款我要租广告位
查看: 6545|回复: 94
收起左侧

[易语言纯源码] [分享源码] EClass 易语言类操作 模块开源

    [复制链接]

签到天数:16 天

结帖率:100% (1/1)
发表于 2019-5-5 14:44:26 | 显示全部楼层 |阅读模式
分享源码
界面截图: -
是否带模块: 纯源码
备注说明: -
本帖最后由 LeyBc 于 2019-5-5 16:08 编辑

EClass 易语言类操作 本模块主要是为了弥补易语言类的不足
易语言的类:
1、成员无法公开,无法对成员直接赋值
2、未公开的方法,无法直接调用[貌似是废话]

封装了 英文方法和中文方法
  1. .版本 2

  2. .子程序 bindMember, , ,
  3. .参数 MemberNameArr, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 CallFun, 整数型, , 调用方法 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  5. .参数 pFunc, 整数型, ,
  6. .参数 buf, 整数型, 可空 ,
  7. .参数 arg1, 整数型, 可空 ,
  8. .参数 arg2, 整数型, 可空 ,
  9. .参数 arg3, 整数型, 可空 ,
  10. .参数 arg4, 整数型, 可空 ,
  11. .参数 arg5, 整数型, 可空 ,

  12. .子程序 getClassFunCount, 整数型, , 取方法数 先调用 getClassFunPoint

  13. .子程序 getClassFunPoint, 整数型, , 取类方法指针 先调用 getClassPoint

  14. .子程序 getClassPoint, 整数型, , 取类指针
  15. .参数 Class, 通用型, 参考 ,

  16. .子程序 getFunPoint, 整数型, , 取方法指针 先调用  getClassFunCount 取出指针后 可以直接 对方法调用 不论方法是否公开
  17. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  18. .子程序 getMemberCount, 整数型, , 取成员数 先调用 getClassPoint

  19. .子程序 getMemberPoint, 整数型, ,  取成员指针 先调用  getMemberCount  取出指针后 可以直接 对 数据进行读写
  20. .参数 Id, 整数型, ,

  21. .子程序 getVarAddress, 整数型, , 取地址 如果写入数据是非整数型,调用这个
  22. .参数 Var, 通用型, 参考 ,

  23. .子程序 setMemberValueById, 逻辑型, , 置成员值 先调用  getMemberCount
  24. .参数 ID, 整数型, ,
  25. .参数 Value, 整数型, , 非整数型 请调用 取地址

  26. .子程序 setMemberValueByName, 逻辑型, , 先调用  getMemberCount  和 bindMember
  27. .参数 MemberName, 文本型, ,
  28. .参数 Value, 整数型, , 非整数型 请调用 取地址


复制代码



2019-05-05_143240.png




  1. .版本 2

  2. .子程序 绑定成员, , ,
  3. .参数 成员名, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 取成员数, 整数型, , 先调用 取类指针

  5. .子程序 取成员指针, 整数型, , 先调用  取成员数  取出指针后 可以直接 对 数据进行读写
  6. .参数 第几个成员, 整数型, ,

  7. .子程序 取地址, 整数型, , 如果写入数据是非整数型,调用这个
  8. .参数 参数, 通用型, 参考 ,

  9. .子程序 取方法数, 整数型, , 先调用 取类方法指针

  10. .子程序 取方法指针, 整数型, , 先调用  取方法数 取出指针后 可以直接 对方法调用 不论方法是否公开
  11. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  12. .子程序 取类方法指针, 整数型, , 先调用 取类指针

  13. .子程序 取类指针, 整数型, ,
  14. .参数 类, 通用型, 参考 ,

  15. .子程序 调用方法, 整数型, , 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  16. .参数 子程序指针, 整数型, ,
  17. .参数 缓存区, 整数型, 可空 ,
  18. .参数 参数1, 整数型, 可空 ,
  19. .参数 参数2, 整数型, 可空 ,
  20. .参数 参数3, 整数型, 可空 ,
  21. .参数 参数4, 整数型, 可空 ,
  22. .参数 参数5, 整数型, 可空 ,

  23. .子程序 置成员值_ID, 逻辑型, , 先调用  取成员数
  24. .参数 第几个成员, 整数型, ,
  25. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址

  26. .子程序 置成员值_名称, 逻辑型, , 先调用  取成员数 和 绑定成员
  27. .参数 参数名, 文本型, ,
  28. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址</font>


复制代码




2.png


调用代码截图


3.png


类截图


4.png


运行效果演示




ys.gif
调试结果 截图
5.png
此模块中不含任何的广告,也不带任何盈利性质。如有雷同,纯属巧合
如果你觉得不错,请点赞即可!回帖下载

说明:代码写的不太严谨,比如某些数组越界的可能性没去判断,各位需要的话,自行判断一下

EClass_易语言类操作.e (29.96 KB, 下载次数: 210)
QQ截图20190505142932.jpg

评分

参与人数 14好评 +11 精币 +31 收起 理由
[锄禾曰当午] + 1 新技能已get√
皮皮驴 + 1 感谢发布原创作品,精易因你更精彩!
fn1992321 + 1 + 1 支持开源~!感谢分享
含沙射影 + 1 + 2 支持开源~!感谢分享
易语言资源网 + 1 + 5 支持开源~!感谢分享
Ossian + 1 + 2 支持开源~!感谢分享
songue + 1 + 2 精彩文章希望继续努力
kyo9766 + 1 + 2 支持开源~!感谢分享
ljaihong + 1 + 2 支持开源~!感谢分享
101232 + 1 + 2 支持开源~!感谢分享
Sad.XkM + 1 + 2 支持开源~!感谢分享
大司命 + 1 + 5 支持开源~!感谢分享
汉族 + 1 + 2 支持开源~!感谢分享
冯古屋 + 2 支持开源~!感谢分享

查看全部评分


您可以选择打赏方式支持楼主

本帖被以下淘专辑推荐:

签到天数: 4 天

发表于 2020-1-1 08:05:55 | 显示全部楼层
非常感谢工程高效
回复

使用道具 举报

签到天数: 10 天

结帖率:83% (5/6)
发表于 2019-12-28 10:26:18 | 显示全部楼层
支持开源~!感谢分享
回复

使用道具 举报

签到天数: 17 天

结帖率:100% (3/3)
发表于 2019-12-2 16:19:14 | 显示全部楼层
努力学习 天天向上
回复

使用道具 举报

签到天数: 13 天

发表于 2019-11-24 19:16:52 | 显示全部楼层
感谢分享 学习中
回复

使用道具 举报

签到天数: 1 天

发表于 2019-9-5 18:12:54 | 显示全部楼层
一直在学习此类类的软件,非常感谢。
回复

使用道具 举报

发表于 2019-6-25 09:25:09 | 显示全部楼层
感谢发布原创作品,精易因你更精彩!精彩文章希望继续努力
回复

使用道具 举报

签到天数: 17 天

结帖率:100% (3/3)
发表于 2019-6-24 15:29:47 | 显示全部楼层
这个牛逼了
回复

使用道具 举报

签到天数: 28 天

发表于 2019-6-23 08:13:38 | 显示全部楼层
这个好,现在正缺这个
回复

使用道具 举报

签到天数: 27 天

发表于 2019-6-20 22:37:11 | 显示全部楼层
腻害!!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /2 下一条

发布主题 收藏帖子 返回列表 按钮 关注QQ

sitemap| 易语言源码| 易语言教程| 易语言论坛| 诚聘英才| 易语言模块| 手机版| 联系我们| 精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表