精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
2019年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
全国PPTP秒换IP 动态IP仅35元/月诺宾混拨动态vps/PPTP多地区换IP长期 包养全网交友粉大户┗ 模拟器24开,稳 定 不 卡 。┛找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
出兼职,网赚,交友粉,扫码进群出微信qq交友粉网赚粉精准粉兼职长期 包养全网交友粉大户█IP精灵█最强大的动态IP加速器找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
出Q群粉联系QQ:492544249███出售质量精准粉███各种【活粉变现点这里】客服①长期出QQ群QQ号微信精准粉网挣粉找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
┏集团收购:一手短信、邮箱群fa┓╔ 大量现金实力收真实粉 ╗各种【活粉变现点这里】客服①高价收购网赚精准粉找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
┃集团收购:一手短信、邮箱群fa┃ 日消耗X6一辆,无限收粉各种【活粉变现点这里】客服②高价收购网赚精准粉找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
┃集团收购:,一手精准群发用户┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购网赚精准粉找软件作者合作/收购引流软件★高价收购一切粉QQ3388788888★
┃集团收购:,一手精准群发用户┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购网赚精准粉实力团队大量收粉入群找管理★高价收购一切粉QQ3388788888★
┗集团收购:-爬取QQ达人会员号┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购网赚精准粉实力团队大量收粉入群找管理★高价收购一切粉QQ3388788888★
长期大量收一手精准网赚粉收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山██出高质量粉,日产多、实力来谈实力团队大量收粉入群找管理出售长短效HTTP-S5私密IP-高质量
长期收各种精准网赚资源收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 ██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理出售长短效HTTP-S5私密IP-高质量
长期收各种小视频网赚资源收粉丶卖粉丶大型①群██收婚恋粉宝妈粉,找我换钱██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理出网赚粉/精准粉/独家引流软件
长期收各种引流精准网赚粉收粉丶卖粉丶大型①群██收快手火山虎牙,找我换钱██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理█实力公司收网赚兼职粉█
大量收粉真实粉商长期合作收粉丶卖粉丶大型①群██长期大量收粉量大量小都吃██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理寻求实力团队
加华缘社群支持免费担保收粉丶卖粉丶大型①群██ 婚恋/抖音/宝妈/空间/快手██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理高效率合作,
欢迎粉商渠道客户进QQ群收粉丶卖粉丶大型①群███有量有质量,找我换钱███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理欢迎来扰!!
长期收各种粉真实长期合作收粉丶卖粉丶大型①群███实力大型公司收媒体量███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理无限收任何量
真实网赚量点击进华缘社群收粉丶卖粉丶大型①群███大量资金,来一手代理███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理无限收任何量
华缘社Q群号码364884407╚ 全网实力最高单价收粉 ╝ ███有量就有钱,速度来撩███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道█长期大量收购各种活粉█┃  全网大量收  ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道大量收代加QQ各种单双向群┃   网赚粉   ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理拒绝骗子
公司实力收引流软件渠道现加/拉群/现货单双向群通吃┃   游戏粉   ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理拒绝骗子
公司实力收引流软件渠道怕你没量,别怕我没钱┃   婚恋粉   ┃出高质量粉,日产多、实力来谈实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道★★★★短★信★群★Fa★★★★┃  各种活人粉  ┃『实力收扫码进群量』实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道短★-招中介-找中介-寻中介-★短┃   短视频粉  ┃『你量真,我需求大』实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道信★兼职-网赚-量足大量接单★信┃ 全网最高单价收购 ┃『 你不乱,我不断 』实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道群★移动-电信爆卡100%到达★群寻求 媒体量合作 有资源的撩我
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰无限收任何量
公司实力收引流软件渠道Fa★实力机房价高质高不扣量★Fa寻求 媒体量合作 有资源的撩我
『欢迎实力粉商来撩』
寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道无限收QQ网吧关注公众号QQ222561寻求 媒体量合作 有资源的撩我长期收网赚粉 QQ8904040寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道无限收精准网赚粉联系QQ267804寻求 媒体量合作 有资源的撩我实力团队收粉 QQ8904040寻引流高手合作/1万粉以下勿扰大量收男粉扫码进群QQ1324888881
公司实力收引流软件渠道收网赚粉 兼职粉 宝妈粉 9703796寻求 媒体量合作 有资源的撩我长期收网赚粉 QQ8904040寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道收网赚粉 兼职粉 宝妈粉 9703796寻求 媒体量合作 有资源的撩我实力团队收网赚粉入群找管理寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道收网赚粉 兼职粉 宝妈粉 9703796寻求 媒体量合作 有资源的撩我实力团队收网赚粉入群找管理寻引流高手合作/1万粉以下勿扰———群fa资源/邮件群fa代发
改成长期收购微信男活跃粉出QQ群微信QQ号交友粉网赚粉兼职粉寻求 媒体量合作 有资源的撩我收Q粉微信扫码进群qq:2591360085寻引流高手合作/1万粉以下勿扰实力团队收粉,收购引流软件
短信实力卡发量,无视内容█拨号VPS服务器4元/天免费测试█每天稳定出正常话术邮箱交友粉█微信朋友圈投放网赚广告█寻引流高手合作/1万粉以下勿扰出售精准网赚粉、兼职粉
集团超高价收量QQ: 2019306666群fa短信 95达到率国内外长短效HTTP-Socks5高质量IP██████五年推广█邮件代发█寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 189|回复: 8
收起左侧

[已解决] 高手进,为什么编译时出现问题!

 关闭 [复制链接]

签到天数:3 天

结帖率:95% (21/22)
发表于 2019-1-12 13:12:48 | 显示全部楼层 |阅读模式
5精币
如图,求解! 1.JPG

最佳答案

查看完整内容

DLL函数的参数不能为字节集类型,只支持基本类型(文本型,数值型,布尔型(真假)之类的)

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 20 天

结帖率:100% (11/11)
发表于 2019-1-12 13:12:49 | 显示全部楼层
QQ截图20190112171733.png
DLL函数的参数不能为字节集类型,只支持基本类型(文本型,数值型,布尔型(真假)之类的)

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 21 天

结帖率:100% (24/24)
发表于 2019-1-12 13:16:18 | 显示全部楼层
MD过程 子程序你复制了吗

补充内容 (2019-1-12 13:30):
返回 (到小写 (MD过程 (字节集数据, 32772, 20)))
这里其实已经不是字节集了,而是经过MD过程处理之后变为文本型,

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:95% (21/22)
 楼主| 发表于 2019-1-12 13:21:37 | 显示全部楼层
易正易则 发表于 2019-1-12 13:16
MD过程 子程序你复制了吗

.版本 2

.子程序 MD过程, 文本型, 公开
.参数 x, 字节集
.参数 种类, 整数型
.参数 长度, 整数型
.局部变量 hCryptProv, 整数型
.局部变量 hKey, 整数型
.局部变量 hHash, 整数型
.局部变量 pbBuffer, 字节集
.局部变量 cbHash, 整数型
.局部变量 rgbHash, 字节集
.局部变量 rgbDigits, 字节集
.局部变量 局_MD5, 字节集
.局部变量 b, 整数型
.局部变量 i, 整数型
.局部变量 len, 整数型

.如果 (CryptAcquireContextA (hCryptProv, “”, “”, 1, -268435456) = 0)
    .如果真 (CryptAcquireContextA (hCryptProv, “”, “”, 1, 0) = 0)
        返回 (“”)
    .如果真结束

.否则
    .如果 (CryptCreateHash (hCryptProv, 种类, hKey, 0, hHash) = 0)
        CryptReleaseContext (hCryptProv, 0)
        返回 (“”)
    .否则
        pbBuffer = x
        len = 取字节集长度 (x)
        .如果 (CryptHashData (hHash, pbBuffer, len, 0) = 0)
            CryptDestroyHash (hHash)
            CryptReleaseContext (hCryptProv, 0)
            返回 (“”)
        .否则
            rgbHash = 取空白字节集 (长度)
            cbHash = 长度
            .如果 (CryptGetHashParam (hHash, 2, rgbHash, cbHash, 0) = 0)
                CryptDestroyHash (hHash)
                CryptReleaseContext (hCryptProv, 0)
                返回 (“”)
            .否则
                rgbDigits = 到字节集 (“0123456789ABCDEF”)
                局_MD5 = 取空白字节集 (长度 × 2)
                .变量循环首 (0, cbHash - 1, 1, i)
                    b = rgbHash [i + 1]
                    局_MD5 [i × 2 + 1] = rgbDigits [右移 (b, 4) + 1]
                    局_MD5 [i × 2 + 2] = rgbDigits [位与 (b, 15) + 1]
                .变量循环尾 ()
                CryptDestroyHash (hHash)
                CryptReleaseContext (hCryptProv, 0)
            .如果结束

        .如果结束

    .如果结束

.如果结束
返回 (到文本 (局_MD5))

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:95% (21/22)
 楼主| 发表于 2019-1-12 13:23:01 | 显示全部楼层
复制了。


.版本 2

.子程序 MD过程, 文本型, 公开
.参数 x, 字节集
.参数 种类, 整数型
.参数 长度, 整数型
.局部变量 hCryptProv, 整数型
.局部变量 hKey, 整数型
.局部变量 hHash, 整数型
.局部变量 pbBuffer, 字节集
.局部变量 cbHash, 整数型
.局部变量 rgbHash, 字节集
.局部变量 rgbDigits, 字节集
.局部变量 局_MD5, 字节集
.局部变量 b, 整数型
.局部变量 i, 整数型
.局部变量 len, 整数型

.如果 (CryptAcquireContextA (hCryptProv, “”, “”, 1, -268435456) = 0)
    .如果真 (CryptAcquireContextA (hCryptProv, “”, “”, 1, 0) = 0)
        返回 (“”)
    .如果真结束

.否则
    .如果 (CryptCreateHash (hCryptProv, 种类, hKey, 0, hHash) = 0)
        CryptReleaseContext (hCryptProv, 0)
        返回 (“”)
    .否则
        pbBuffer = x
        len = 取字节集长度 (x)
        .如果 (CryptHashData (hHash, pbBuffer, len, 0) = 0)
            CryptDestroyHash (hHash)
            CryptReleaseContext (hCryptProv, 0)
            返回 (“”)
        .否则
            rgbHash = 取空白字节集 (长度)
            cbHash = 长度
            .如果 (CryptGetHashParam (hHash, 2, rgbHash, cbHash, 0) = 0)
                CryptDestroyHash (hHash)
                CryptReleaseContext (hCryptProv, 0)
                返回 (“”)
            .否则
                rgbDigits = 到字节集 (“0123456789ABCDEF”)
                局_MD5 = 取空白字节集 (长度 × 2)
                .变量循环首 (0, cbHash - 1, 1, i)
                    b = rgbHash [i + 1]
                    局_MD5 [i × 2 + 1] = rgbDigits [右移 (b, 4) + 1]
                    局_MD5 [i × 2 + 2] = rgbDigits [位与 (b, 15) + 1]
                .变量循环尾 ()
                CryptDestroyHash (hHash)
                CryptReleaseContext (hCryptProv, 0)
            .如果结束

        .如果结束

    .如果结束

.如果结束
返回 (到文本 (局_MD5))

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:100% (11/11)
发表于 2019-1-12 13:34:04 | 显示全部楼层
都说了,参数1不能是字节集类型的
你可以把 校验_取sha1() 函数的参数1改成整数类型,增加一个参数2,也是整数类型的
然后用 字节集数据 = 指针到字节集(参数1,参数2) 这样取出字节集数据

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:95% (21/22)
 楼主| 发表于 2019-1-12 15:02:11 | 显示全部楼层
为什么这个子程序用在其他程序可以。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:95% (21/22)
 楼主| 发表于 2019-1-12 15:04:22 | 显示全部楼层
2.JPG 用在其他程序可以编译出来。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 3 天

结帖率:95% (21/22)
 楼主| 发表于 2019-1-12 17:47:00 | 显示全部楼层
Copo 发表于 2019-1-12 17:19
DLL函数的参数不能为字节集类型,只支持基本类型(文本型,数值型,布尔型(真假)之类的)

嗯。。         

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表