精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月诺宾混拨动态vps/PPTP多地区换IP长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群长期 包养全网交友粉大户███大量全新活令牌处Q███找软件作者合作/收购引流软件出兼职粉大公司和量大的来
出微信qq交友粉网赚粉精准粉兼职█IP精灵█最强大的动态IP加速器各种【活粉变现点这里】客服①大量出网赚粉/各种粉/各类用户资源找软件作者合作/收购引流软件出高质量微信男粉QQ:644949998
┏集团收购:一手短信、邮箱群fa┓╔ 大量现金实力收真实粉 ╗各种【活粉变现点这里】客服①高价收购陌陌探探粉找软件作者合作/收购引流软件寻求实力团队
┃集团收购:一手短信、邮箱群fa┃ 日消耗X6一辆,无限收粉各种【活粉变现点这里】客服②高价收购陌陌探探粉找软件作者合作/收购引流软件高效率合作,
┃集团收购:,一手精准群发用户┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购陌陌探探粉找软件作者合作/收购引流软件欢迎来扰!!
┃集团收购:,一手精准群发用户┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购陌陌探探粉实力团队大量收粉入群找管理无限收任何量
┗集团收购:-爬取QQ达人会员号┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购陌陌探探粉实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█收粉丶卖粉丶大型①群██收婚恋粉宝妈粉,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█收粉丶卖粉丶大型①群██收快手火山虎牙,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██长期大量收粉量大量小都吃██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█有量支持引QQ/Q群/微信█收粉丶卖粉丶大型①群██ 婚恋/抖音/宝妈/空间/快手██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█欢迎实力来撩,点击进Q群█收粉丶卖粉丶大型①群███有量有质量,找我换钱███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█加星盟社群支持免费担保█收粉丶卖粉丶大型①群███实力大型公司收媒体量███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收粉量真实长期合作█收粉丶卖粉丶大型①群███大量资金,来一手代理███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█星盟社Q群号码859857268█╚ 全网实力最高单价收粉 ╝ ███有量就有钱,速度来撩███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道█长期大量收购各种活粉█┃  全网大量收  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   网赚粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   游戏粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道定制网站找我┃   婚恋粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道定制软件找我┃  各种活人粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道出少量网赚粉+微信:qunfa000┃   短视频粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道出少量网赚粉+微信:qunfa000┃ 全网最高单价收购 ┃『实力收扫码进群量』实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道┃大量收粉.实力来撩 ┃寻求 媒体量合作 有资源的撩我『你量真,我需求大』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
公司实力收引流软件渠道┃   网赚粉   ┃ 寻求 媒体量合作 有资源的撩我『 你不乱,我不断 』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
收购跳转微信QQ加粉量Q88128851┃   精准粉   ┃寻求 媒体量合作 有资源的撩我
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
大量收微信扫码进群男粉2820301656大量出网赚各种精准粉+Q402345寻求 媒体量合作 有资源的撩我
『欢迎实力粉商来撩』
寻引流高手合作/1万粉以下勿扰出Q群粉联系QQ:492544249
███大公司实力收优质wz量███出高质量家庭量说说 价高 寻求 媒体量合作 有资源的撩我
█实力公司收网赚兼职粉█
寻引流高手合作/1万粉以下勿扰出网赚粉 兼职粉
———长期WZ户运营与邮件群fa出微信国内老号,引流稳定不封。大量出活令牌处号一个月号█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰███大量全新令牌QQ███
收微信扫码进群男粉QQ:854122288出QQ群微信QQ号交友粉网赚粉兼职粉大量出活令牌处号一个月号百变IP-每日大量代理IP欢迎合作寻引流高手合作/1万粉以下勿扰收Q粉微信扫码进群qq:2591360085
短信群fa-三网爆卡-量足███QQ小号自动发货平台███大量出活令牌处号一个月号高价收网吧量联系QQ1908886662寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 207|回复: 12
收起左侧

[已解决] 位图操作.置某点颜色(, , , )使用问题。

 关闭 [复制链接]

签到天数:7 天

结帖率:100% (6/6)
发表于 2018-12-7 23:07:33 | 显示全部楼层 |阅读模式
5精币
位图操作.置某点颜色 (, , , )需要4个参数
子程序名:置某点颜色
    设置位图中某点颜色值(成功返回真,失败返回假)
    返回值类型:逻辑型
    参数<1>的名称为“位图句柄”,类型为“整数型”。注明:欲取颜色的位图句柄。
    参数<2>的名称为“横坐标”,类型为“整数型”。
    参数<3>的名称为“纵坐标”,类型为“整数型”。
    参数<4>的名称为“颜色值”,类型为“整数型”。注明:十进制RGB颜色值。
我的位图是一个存储在 一个字节集里。
这个第一个参数应当怎么填写??

我的目的是:取得一个图片,二值化后。与指定的图片对比。
如果利用画板可以实现,但是用画板太浪费时间,而且如果这个画板最小化,还无法取到(显示)颜色(影响程序流程)。
怎么才能把二值化后的图片储存在 字节集里???
也就是说不用画板显示,只用位图的方式来操作??

最佳答案


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 15 天

结帖率:100% (14/14)
发表于 2018-12-7 23:07:34 | 显示全部楼层
澶氶夊尯.gif

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 7 天

结帖率:100% (6/6)
 楼主| 发表于 2018-12-7 23:10:17 | 显示全部楼层
.版本 2
.支持库 eAPI
.支持库 spec

.子程序 _按钮32_被单击, , , 第一次取坐标位置并二值化,122.99--144.115
.局部变量 b, 整数型
.局部变量 c, 整数型
.局部变量 矩形, 矩形数据

' 宽37 ,高20
矩形.左边 = 122
矩形.顶边 = 99
矩形.右边 = 144
矩形.底边 = 115
画板1.底图 = 截取屏幕区域 (矩形, 2, )
延迟 (800)
.计次循环首 (37, b)
    .计次循环首 (20, c)
        .如果 (位与 (画板1.取点 (b - 1, c - 1), 255) ≥ 220 或 位与 (画板1.取点 (b - 1, c - 1), 65280) ÷ 256 ≥ 220 或 位与 (画板1.取点 (b - 1, c - 1), 16711680) ÷ 65536 ≥ 220)
            画板2.画点 (b - 1, c - 1, #白色)
        .否则
            画板2.画点 (b - 1, c - 1, #黑色)
        .如果结束

    .计次循环尾 ()
.计次循环尾 ()

这是我的部分代码。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (6/6)
发表于 2018-12-7 23:10:43 | 显示全部楼层
如果是精易模块的话,可以
位图.从数据创建(图片数据)
位图.置某点颜色 (, , )

如果不是用精易模块,可以参考精易模块的那个 从数据创建(),这个方法里有获取位图句柄

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (36/36)
发表于 2018-12-7 23:15:53 | 显示全部楼层
不懂的话,你可以创建一个画板,   画板.置某点颜色   , 你练练手,从基础走起  基础牢固 后面学习其他不困难,把普通的图片处理好了 再去学习位图,未来的大神,我看好你

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (14/14)
发表于 2018-12-7 23:31:30 | 显示全部楼层
易语言自带 位图   直接 位图  类型  就行了  我个人感觉比 精易模块的 块

补充内容 (2018-12-7 23:32):
系统位图  直接就是 X  Y   rgb

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (14/14)
发表于 2018-12-7 23:32:40 | 显示全部楼层
画板. 自动重画=真

补充内容 (2018-12-7 23:33):
可视为假  都行  前提 设置 宽高

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (3/3)
发表于 2018-12-7 23:38:06 | 显示全部楼层
直接用自带支持库的位图操作就好,你这个是GDI的还是精易上面的?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 7 天

结帖率:100% (6/6)
 楼主| 发表于 2018-12-7 23:38:48 | 显示全部楼层
福仔 发表于 2018-12-7 23:10
如果是精易模块的话,可以
位图.从数据创建(图片数据)
位图.置某点颜色 (, , )

位图操作.创建位图 (),会返回一个位图句柄。
另外还有个问题,不知道你是否遇到了。
我在程序里写:  位图操作.取某点颜色 ()   
在提示栏里显示如下: (需要句柄参数)
子程序名:取某点颜色
    取得位图中某点颜色值(成功返回十进制颜色值,失败返回-1)
    返回值类型:整数型
    参数<1>的名称为“位图句柄”,类型为“整数型”。注明:欲取颜色的位图句柄。
    参数<2>的名称为“横坐标”,类型为“整数型”。
    参数<3>的名称为“纵坐标”,类型为“整数型”。

而在支持库里却不虚言参数。。。。。。。
如下提示:
调用格式: 〈整数型〉 对象.取某点颜色 (整数型 横坐标,整数型 纵坐标) - 位图操作支持库->位图
    英文名称:GetPixelColor
    取得该位图中某点的实际颜色值,以位图的左上角为坐标原点。注意,对位深度为16的位图,取得的颜色可能有少许误差,这是由16位位图的特殊内部结构决定的。如果指定的像素点坐标越界,将导致调用失败,返回-1。如果失败,随后立即调用本对象的“取错误信息”命令将取得一个非空文本,该文本为失败的原因。本命令为初级对象成员命令。
    参数<1>的名称为“横坐标”,类型为“整数型(int)”。以像素为单位。如果该参数指定的坐标超出了位图的实际范围,本命令将失败。
    参数<2>的名称为“纵坐标”,类型为“整数型(int)”。以像素为单位。如果该参数指定的坐标超出了位图的实际范围,本命令将失败。

    操作系统需求: Windows


谁知道这是什么情况????

点评

一个是把位图句柄传进去,一个是在创建位图的时候类成员保存位图句柄 结果都是一样的,就看你用的模块或支持库了,精易模块的 位图操作类也是把位图句柄存到类成员里 用精易模块就行了,或者用位图支持库也可以  详情 回复 发表于 7 天前

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 7 天

结帖率:100% (6/6)
 楼主| 发表于 2018-12-7 23:49:45 | 显示全部楼层
汉族 发表于 2018-12-7 23:31
易语言自带 位图   直接 位图  类型  就行了  我个人感觉比 精易模块的 块

补充内容 (2018-12-7 23:32):

系统位图在哪个支持库里???
我的应用接口支持库里怎么没有????

点评

你要勾选支持库  发表于 2018-12-7 23:53

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表