精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器  ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月诺宾混拨动态vps/PPTP多地区换IP长期 包养全网交友粉大户┗ 模拟器24开,稳 定 不 卡 。┛找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群长期 包养全网交友粉大户███大量全新活令牌处Q███找软件作者合作/收购引流软件出兼职粉大公司和量大的来
出微信qq交友粉网赚粉精准粉兼职█IP精灵█最强大的动态IP加速器各种【活粉变现点这里】客服①大量出网赚粉/各种粉/各类用户资源找软件作者合作/收购引流软件出高质量微信男粉QQ:644949998
┏集团收购:一手短信、邮箱群fa┓╔ 大量现金实力收真实粉 ╗各种【活粉变现点这里】客服①高价收购网赚精准粉找软件作者合作/收购引流软件寻求实力团队
┃集团收购:一手短信、邮箱群fa┃ 日消耗X6一辆,无限收粉各种【活粉变现点这里】客服②高价收购网赚精准粉找软件作者合作/收购引流软件高效率合作,
┃集团收购:,一手精准群发用户┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购网赚精准粉找软件作者合作/收购引流软件欢迎来扰!!
┃集团收购:,一手精准群发用户┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购网赚精准粉实力团队大量收粉入群找管理无限收任何量
┗集团收购:-爬取QQ达人会员号┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购网赚精准粉实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█收粉丶卖粉丶大型①群██收婚恋粉宝妈粉,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█收粉丶卖粉丶大型①群██收快手火山虎牙,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██长期大量收粉量大量小都吃██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█有量支持引QQ/Q群/微信█收粉丶卖粉丶大型①群██ 婚恋/抖音/宝妈/空间/快手██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█欢迎实力来撩,点击进Q群█收粉丶卖粉丶大型①群███有量有质量,找我换钱███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█加星盟社群支持免费担保█收粉丶卖粉丶大型①群███实力大型公司收媒体量███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收粉量真实长期合作█收粉丶卖粉丶大型①群███大量资金,来一手代理███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█星盟社Q群号码859857268█╚ 全网实力最高单价收粉 ╝ ███有量就有钱,速度来撩███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道█长期大量收购各种活粉█┃  全网大量收  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   网赚粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   游戏粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道定制网站找我┃   婚恋粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道定制软件找我┃  各种活人粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道邮件群fa+微信qunfa000┃   短视频粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道邮件群fa+微信qunfa000┃ 全网最高单价收购 ┃『实力收扫码进群量』实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道┃大量收粉.实力来撩 ┃寻求 媒体量合作 有资源的撩我『你量真,我需求大』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
公司实力收引流软件渠道┃   网赚粉   ┃ 寻求 媒体量合作 有资源的撩我『 你不乱,我不断 』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
收购跳转微信QQ加粉量Q88128851┃   精准粉   ┃寻求 媒体量合作 有资源的撩我
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
大量收微信扫码进群男粉2820301656大量出网赚各种精准粉+Q402345寻求 媒体量合作 有资源的撩我
『欢迎实力粉商来撩』
寻引流高手合作/1万粉以下勿扰出Q群粉联系QQ:492544249
███大公司实力收优质wz量███出高质量家庭量说说 价高 寻求 媒体量合作 有资源的撩我
█实力公司收网赚兼职粉█
寻引流高手合作/1万粉以下勿扰出网赚粉 兼职粉
———专业WZ户运营/邮件群fa出微信国内老号,引流稳定不封。大量出活令牌处号一个月号█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰███大量全新令牌QQ███
收购各行各业的行业群出QQ群微信QQ号交友粉网赚粉兼职粉大量出活令牌处号一个月号百变IP-每日大量代理IP欢迎合作寻引流高手合作/1万粉以下勿扰收Q粉微信扫码进群qq:2591360085
短信群fa-三网爆卡-量足███QQ小号自动发货平台███大量出活令牌处号一个月号高价收网吧量联系QQ1908886662寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 264|回复: 15
收起左侧

[已解决] 取指定文本后面的字符

 关闭 [复制链接]

签到天数:15 天

结帖率:85% (52/61)
发表于 2018-12-7 01:41:29 | 显示全部楼层 |阅读模式
50精币
kojjb*9562
obj*785633
exejk*dll6
如何取  “*”  符号后面的文本?


补充内容 (2018-12-7 02:00):
是随机出现的,后面文本有长有短,我只需要 “*”后面的内容即可。

最佳答案

查看完整内容

例子写给你看一下 变量: 文本 取出文本 类型:文本型 文本 = “kojjb*9562” 取出文本 = 文本_取右边 (文本, “*”) 调试输出 (取出文本)

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 8 天

发表于 2018-12-7 01:41:30 | 显示全部楼层
例子写给你看一下   变量: 文本   取出文本   类型:文本型

文本 = “kojjb*9562”

取出文本 = 文本_取右边 (文本, “*”)

调试输出 (取出文本)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 19 天

结帖率:94% (15/16)
发表于 2018-12-7 01:56:36 | 显示全部楼层
精易模块  文本_取右边

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:85% (52/61)
 楼主| 发表于 2018-12-7 02:00:34 | 显示全部楼层
1355568730 发表于 2018-12-7 01:56
精易模块  文本_取右边

不看主题....

点评

认真的吗???  发表于 2018-12-7 05:51

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 19 天

结帖率:94% (15/16)
发表于 2018-12-7 02:05:33 | 显示全部楼层

*后面的  取右边有啥问题?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 16 天

结帖率:100% (6/6)
发表于 2018-12-7 02:14:38 | 显示全部楼层
当确定内容只有一个“*”的时候 可以用分割文本

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 18 天

结帖率:44% (4/9)
发表于 2018-12-7 02:35:17 | 显示全部楼层
调试输出(文本_取右边 ("obj*785633" , "*"))

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 10 天

结帖率:54% (25/46)
发表于 2018-12-7 03:31:13 | 显示全部楼层
.版本 2
.支持库 spec

.局部变量 分组a, 文本型, , "0"
.局部变量 分组b, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 l, 整数型


分组a = 分割文本 (#文本, #换行符, )
l = 取数组成员数 (分组a)
.计次循环首 (l, i)
    加入成员 (分组b, 文本_取右边 (分组a [i], “*”))

.计次循环尾 ()
调试输出 (分组b)



运行结果如下: 数组:3{“9562”,“785633”,“dll6”}

分组a=分割文本(文本文件,#换行符)
l=取数组长度(分组a)
计次

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 10 天

结帖率:54% (25/46)
发表于 2018-12-7 03:32:16 | 显示全部楼层
上面的贴的有问题,不能更改


数组:3{“9562”,“785633”,“dll6”}


.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 分组a, 文本型, , "0"
.局部变量 分组b, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 l, 整数型


分组a = 分割文本 (#文本, #换行符, )
l = 取数组成员数 (分组a)
.计次循环首 (l, i)
    加入成员 (分组b, 文本_取右边 (分组a [i], “*”))

.计次循环尾 ()
调试输出 (分组b)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 18 天

结帖率:100% (8/8)
发表于 2018-12-7 07:17:30 | 显示全部楼层
有点小紧张

  
变量名类 型静态数组备 注
文本数组文本型 0
计数器整数型  
偏移整数型  
文本数组 = 分割文本 ( #常量1, #换行符, )
计次循环首 (取数组成员数 (文本数组), 计数器)
偏移 = 寻找文本 (文本数组 [计数器], “*”, , )
如果真 (偏移 ≠ -1)
调试输出 (取文本右边 (文本数组 [计数器], 取文本长度 (文本数组 [计数器]) - 偏移))

计次循环尾 ()


i支持库列表   支持库注释   
spec特殊功能支持库

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表