精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月┏█收购一切流量Q:503830000█┓长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
▇▇QQ方面最新软件▇▇●国内外动态socks5 可API控制●长期 包养全网交友粉大户诺宾混拨动态vps/PPTP多地区换IP找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群各种【活粉变现点这里】客服①大量出小白兼职宝妈网赚粉找软件作者合作/收购引流软件找实力公司合作
┏集团收购:一手短信、邮箱群fa┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购漂流瓶量找软件作者合作/收购引流软件寻求实力团队
┃集团收购:一手短信、邮箱群fa┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件高效率合作,
┃集团收购:,一手精准群发用户┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件欢迎来扰!!
┃集团收购:,一手精准群发用户┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
┗集团收购:-爬取QQ达人会员号┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱███高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我大量收精准粉██收快手火山虎牙,找我换钱███高价收运营商量和百度竞价量█实力团队大量收粉入群找管理拒绝骗子
工作室长期出粉,需要的撩我大量收精准粉██长期大量收粉量大量小都吃███高价收运营商量和百度竞价量█实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█大量收精准粉██ 婚恋/抖音/宝妈/空间/快手███高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█大量收精准粉███有量有质量,找我换钱████高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█各种家庭量███实力大型公司收媒体量████高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█各种家庭量███大量资金,来一手代理████高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█各种家庭量███有量就有钱,速度来撩████高价收运营商量和百度竞价量█实力团队大量收粉入群找管理无限收任何量
█有量支持引QQ/Q群/微信██长期大量收购各种活粉█┃  全网大量收  ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█欢迎实力来撩,点击进Q群██ 长期收购各种引流软件 █┃ 各种App交友粉 ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█加星盟社群支持免费担保█大量国外微信老号出售┃   网赚粉   ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
█无限收粉量真实长期合作█▇大量批发高质量QQ处号9位10位▇┃   游戏粉   ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█星盟社Q群号码868977025█▇大量批发高质量QQ处号9位10位▇┃   婚恋粉   ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃  各种活人粉  ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理『实力收扫码进群量』
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃   短视频粉  ┃█高价收运营商量和百度竞价量█实力团队大量收粉入群找管理『你量真,我需求大』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000┃ 全网最高单价收购 ┃大量高价收网赚兼职粉,不限平台实力团队大量收粉入群找管理『 你不乱,我不断 』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『欢迎实力粉商来撩』
┃高薪诚聘┃安卓市场APP上架人才公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『 →qq:12587210←』
出兼职粉有实力的来公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量收微信男粉QQ249813919寻引流高手合作/1万粉以下勿扰█全新处Q██活令牌Q██邮箱Q█
出微信qq交友粉网赚粉精准粉兼职大量出探探交友粉联系Q1962626235寻求 媒体量合作 有资源的撩我█微博全新█4级白号█0.18/个█寻引流高手合作/1万粉以下勿扰█IP精灵█最强大的动态IP加速器
██QQ小号1毛钱/太阳Q/各类QQ██大量出网赚粉/各种粉/各类用户资源寻求 媒体量合作 有资源的撩我出高质量微信男粉QQ:644949998寻引流高手合作/1万粉以下勿扰邮箱代发,进箱率高,可测试
收大量微信裂变粉 2820301656
收购跳转微信QQ加粉量Q88128851大量出活令牌处号一个月号大量出网赚各种精准粉+Q402345寻引流高手合作/1万粉以下勿扰高价收网赚粉 / 兼职粉,平台不限
收微信扫码进群男粉QQ:854122288█拨号VPS服务器4元/天免费测试█大量出活令牌处号一个月号出Q群粉联系QQ:492544249寻引流高手合作/1万粉以下勿扰大量出微信 QQ 群网赚粉 精准活粉
███大公司实力收漂流瓶量███低调出流量大量出活令牌处号一个月号——稳定邮件群fa+QQ166666736寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 294|回复: 13
收起左侧

[已解决] 麻烦懂PHP的大佬帮忙看看

 关闭 [复制链接]

签到天数:1 天

结帖率:75% (18/24)
发表于 2018-9-15 01:06:00 | 显示全部楼层 |阅读模式
200精币
  1. private function getRandomHex($length)
  2.     {
  3.         if (function_exists('openssl_random_pseudo_bytes')) {
  4.             return bin2hex(openssl_random_pseudo_bytes($length / 2));
  5.         } else {
  6.             return bin2hex(mcrypt_create_iv($length / 2, MCRYPT_DEV_URANDOM));
  7.         }
  8.     }
复制代码
麻烦大佬帮忙看看这就是普通的取随机数吗?能不能转换成易语言。感谢各位大佬

最佳答案

查看完整内容

假设函数存在即可 子程序 randhex 参数一 len 整数型 变量一 bytes 字节集 bytes = 取空白字节集(len) 计次循环首(len,i) 置随机数种子() bytes = 到字节(取随机数(0,255)) 计次循环尾() 返回(字节集到十六进制(bytes)) 补充内容 (2018-9-15 01:20): 字节集到十六进制 没有这个函数 具体找模块或者 什么鬼也可以自己写 先询问字节集 得到字节 十进制到十六进制也可以,想怎么样就怎么样,或者直接 取十六进制的随 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:100% (2/2)
发表于 2018-9-15 01:06:01 | 显示全部楼层
假设函数存在即可

子程序 randhex
参数一 len 整数型
变量一 bytes 字节集
bytes = 取空白字节集(len)
计次循环首(len,i)
置随机数种子()
bytes = 到字节(取随机数(0,255))
计次循环尾()
返回(字节集到十六进制(bytes))

补充内容 (2018-9-15 01:20):
字节集到十六进制 没有这个函数
具体找模块或者 什么鬼也可以自己写

先询问字节集 得到字节 十进制到十六进制也可以,想怎么样就怎么样,或者直接 取十六进制的随机数,无所谓完全看你的个人爱好

补充内容 (2018-9-15 01:23):
还有那个bytes 后面要有
bytes【i】
bytes
论坛好像会删掉中括号啊

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 5 天

发表于 2018-9-15 01:08:51 | 显示全部楼层
你这少了一个函数,加我QQ吧。1468254623

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:75% (18/24)
 楼主| 发表于 2018-9-15 01:24:27 | 显示全部楼层
无名i 发表于 2018-9-15 01:18
假设函数存在即可

子程序 randhex

你好,麻烦问下 这样得话  变量bytes 是数组吗?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (2/2)
发表于 2018-9-15 01:25:41 | 显示全部楼层
Mata 发表于 2018-9-15 01:24
你好,麻烦问下 这样得话  变量bytes 是数组吗?

是字节集,但是字节集可以当做数组用,论坛会删掉中括号,你自己注意一下就行

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (2/2)
发表于 2018-9-15 01:28:11 | 显示全部楼层
无名i 发表于 2018-9-15 01:25
是字节集,但是字节集可以当做数组用,论坛会删掉中括号,你自己注意一下就行

我只能告诉你这个函数(openssl_random_pseudo_bytes)就是生成随机指定长度的字节,到十六进制是因为他本身呈现的是乱码

对了,还有长度/2

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:75% (18/24)
 楼主| 发表于 2018-9-15 01:34:39 | 显示全部楼层
无名i 发表于 2018-9-15 01:28
我只能告诉你这个函数(openssl_random_pseudo_bytes)就是生成随机指定长度的字节,到十六进制是因为他 ...
  1. .版本 2

  2. .子程序 GetRandomHex, 文本型
  3. .参数 Len, 整数型
  4. .局部变量 i, 整数型
  5. .局部变量 Bytes, 字节集

  6. Bytes = 取空白字节集 (Len)
  7. .计次循环首 (Len, i)
  8.     置随机数种子 ()
  9.     Bytes = Bytes + 到字节集 (取随机数 (0, 255))
  10. .计次循环尾 ()

  11. 返回 (字节集_查看 (Bytes))
复制代码

补充内容 (2018-9-15 01:34):
我这么写出来好像有点问题

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (2/2)
发表于 2018-9-15 01:35:54 | 显示全部楼层
Mata 发表于 2018-9-15 01:34
补充内容 (2018-9-15 01:34):
我这么写出来好像有点问题

你应该这样写
bytes【i】 = 到字节(取随机数(0,255))

补充内容 (2018-9-15 01:38):
而且为了更接近上述PHP代码
在第一行处需要这样写 len = len / 2

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 1 天

结帖率:75% (18/24)
 楼主| 发表于 2018-9-15 01:39:08 | 显示全部楼层
无名i 发表于 2018-9-15 01:35
你应该这样写
bytes【i】 = 到字节(取随机数(0,255))

不行 长度太长了 到十六进制过后  而且 PHP里面 那个长度 /2  但是我输出那个函数 我写32位 输出就是32位数啊

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (2/2)
发表于 2018-9-15 01:41:16 | 显示全部楼层
Mata 发表于 2018-9-15 01:39
不行 长度太长了 到十六进制过后  而且 PHP里面 那个长度 /2  但是我输出那个函数 我写32位 输出就是32位 ...

因为一个字节会用两个十六进制表示
bin2hex(openssl_random_pseudo_bytes(1));
则会输出一个 长度为2的十六进制数值,没必要纠结

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表