精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月┏█收购一切流量Q:503830000█┓长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
▇▇QQ方面最新软件▇▇●国内外动态socks5 可API控制●长期 包养全网交友粉大户诺宾混拨动态vps/PPTP多地区换IP找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群各种【活粉变现点这里】客服①大量出小白兼职宝妈网赚粉找软件作者合作/收购引流软件找实力公司合作
┏集团收量一手短信群fa邮件群发┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购漂流瓶量找软件作者合作/收购引流软件寻求实力团队
┃集团收量一手短信群fa邮件群发┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件高效率合作,
┃集团收量一手短信群fa邮件群发┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件欢迎来扰!!
┃集团收量一手精准号码微信推广┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
┗集团收量一手精准号码微信推广┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱███收收收高质量交友粉收收收██实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我大量收精准粉██收快手火山虎牙,找我换钱██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理拒绝骗子
工作室长期出粉,需要的撩我大量收精准粉██长期大量收粉量大量小都吃██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█大量收精准粉██ 婚恋/抖音/宝妈/空间/快手██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█大量收精准粉███有量有质量,找我换钱███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█各种家庭量███实力大型公司收媒体量███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█各种家庭量███大量资金,来一手代理███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█各种家庭量███有量就有钱,速度来撩███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█有量支持引QQ/Q群/微信██长期大量收购各种活粉█┃  全网大量收  ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█欢迎实力来撩,点击进Q群██ 长期收购各种引流软件 █┃ 各种App交友粉 ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█加星盟社群支持免费担保█大量国外微信老号出售┃   网赚粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
█无限收粉量真实长期合作█▇大量批发高质量QQ处号9位10位▇┃   游戏粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█星盟社Q群号码868977025█▇大量批发高质量QQ处号9位10位▇┃   婚恋粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃  各种活人粉  ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理『实力收扫码进群量』
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃   短视频粉  ┃█收收收高质量交友粉收收收██实力团队大量收粉入群找管理『你量真,我需求大』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000┃ 全网最高单价收购 ┃大量高价收网赚兼职粉,不限平台实力团队大量收粉入群找管理『 你不乱,我不断 』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『欢迎实力粉商来撩』
┃高薪诚聘┃安卓市场APP上架人才公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『 →qq:12587210←』
出兼职粉有实力的来公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量收微信男粉QQ249813919寻引流高手合作/1万粉以下勿扰█全新处Q██活令牌Q██邮箱Q█
出微信qq交友粉网赚粉精准粉兼职大量出探探交友粉联系Q1962626235寻求 媒体量合作 有资源的撩我█微博全新█4级白号█0.18/个█寻引流高手合作/1万粉以下勿扰█IP精灵█最强大的动态IP加速器
██QQ小号1毛钱/太阳Q/各类QQ██大量出网赚粉/各种粉/各类用户资源寻求 媒体量合作 有资源的撩我出高质量微信男粉QQ:644949998寻引流高手合作/1万粉以下勿扰出网赚粉兼职粉各种男女粉
邮箱代发,进箱率高,可测试
收大量微信裂变粉 2820301656
大量出活令牌处号一个月号收购跳转微信QQ加粉量Q88128851寻引流高手合作/1万粉以下勿扰█大量高价收QQ双向群+Q402345█
高价收网赚粉 / 兼职粉,平台不限收微信扫码进群男粉QQ:854122288大量出活令牌处号一个月号█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰出Q群粉联系QQ:492544249
大量出微信 QQ 群网赚粉 精准活粉大公司大量收微信扫群网赚小白粉大量出活令牌处号一个月号多渠道引流,量大来谈寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 254|回复: 8
收起左侧

[易求助] 易语言 多网卡 怎么选择指定网卡WlanEnumInterfaces wifiapi

[复制链接]
结帖率:0% (0/3)
发表于 2018-9-14 23:50:03 | 显示全部楼层 |阅读模式
50精币
2018-09-12_233827.jpg
想实现多网卡选择-取组合框1指定网卡WlanEnumInterfaces


源码
6677.e (16 KB, 下载次数: 2)

2个无线网卡
都是同一个型号的
第一个网卡GWUSSuper300
第二个网卡GWUSSuper300#

想实现组合框1指定网卡,然后点WlanEnumInterfaces取网卡信息。
目前只能单网卡取信息,多网卡无法取!不知道为什么!
还望大神修改一下源码。谢谢!

个人小白写不出来尝试过各种api
SetupDiEnumDeviceInfo
GetAdaptersInfo
WlanEnumInterfaces
不知道怎么写,还望大神帮忙!感谢!

6677.e

16 KB, 下载次数: 3


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:0% (0/3)
 楼主| 发表于 2018-9-14 23:51:58 | 显示全部楼层
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
变量名类 型数组备 注
ver整数型  
InterfaceList2WLAN_INTERFACE_INFO_LIST  
WlanHandle整数型  
WlanVersion整数型  
ppInterfaceList整数型  
InterfaceItems整数型  
InterfaceListWLAN_INTERFACE_INFO  
hDevinfo整数型  
spDevInfoData整数型  
size_link整数型  
AdapterInfoIP_ADAPTER_INFO  
buf_link字节集  
i整数型  
mac文本型  
tmp文本型  
buf_ipIP_ADDR_STRING  
link网卡信息_  
size_dns整数型  
dnsIP_PER_ADAPTER_INFO  
buf_dns字节集  
addr_dns整数型  
getinteraceWLAN_INTERFACE_CAPABILITY  
hwWLAN_INTF_OPCODE  

子程序名返回值类型公开备 注
_按钮1_被单击  
编辑框1.内容 = “”
ver = 到整数 (取文本左边 (取文本zc项 ( #本地机器, “SOFTWARE\Microsoft\Windows NT\CurrentVersion\CurrentVersion”, ), 1))
ver = 选择 (ver ≥ 6, 2, 1)
如果真 (WlanOpenHandle (ver, 0, WlanVersion, WlanHandle) ≠ 0)  ' 第1个参数 NT5.x 系统填1 NT6.x填2 /第1个参数 XP sp2 sp3 系统填1    vista win7 系统填2
信息框 (“打开 WLAN 句柄失败”, 0, )

编辑框1.加入文本 (到文本 (WlanHandle)#换行符 )
编辑框1.加入文本 (到文本 (WlanVersion)#换行符 )
子程序名返回值类型公开备 注
_按钮2_被单击  
WlanEnumInterfaces (WlanHandle, 0, ppInterfaceList)  ' 获取网卡列表,列表的数据类型是变长的,易语言只能填定长的数据类型  所以只能传指针了
InterfaceItems = 取字节集数据 (指针到字节集 (ppInterfaceList, 4), 3, )  ' 列表类型前8个字节中前4字节  表示网卡数量
ppInterfaceList = ppInterfaceList + 8  ' 后4个字节  表示欲修改网卡号码 , 只是获取网卡信息的话可以忽略 ,该参数从0开始 不是易语言的1开始
调试输出 (ppInterfaceList, InterfaceItems, WlanHandle)
计次循环首 (InterfaceItems, i)
RtlMoveMemory_INTERFACE_INFO (InterfaceList2.InterfaceInfo, ppInterfaceList, 532)
调试输出 (InterfaceItems)
编辑框1.加入文本 (到文本 (InterfaceList2.dwIndex)#换行符 )
编辑框1.加入文本 (到文本 (InterfaceList2.dwNumberOfItems)#换行符 )
编辑框1.加入文本 (到文本 (InterfaceList2.InterfaceInfo.InterfaceGuid)#换行符 )
编辑框1.加入文本 (到文本 (Unicode转ANSI2 (InterfaceList2.InterfaceInfo.strInterfaceDescription)) + #换行符 )
编辑框1.加入文本 (到文本 (ppInterfaceList)#换行符 )
' 编辑框1.加入文本 (到文本 (InterfaceList.isState.enum) + #换行符)  ' 连接状态 4断开  1连接
' 编辑框1.加入文本 (到文本 (Unicode转ANSI2 (InterfaceList.strInterfaceDescription)) + #换行符)  ' 网卡名字
调试输出 (InterfaceList2.dwIndex, InterfaceList2.dwNumberOfItems, InterfaceList2.InterfaceInfo.InterfaceGuid, Unicode转ANSI2 (InterfaceList2.InterfaceInfo.strInterfaceDescription))
如果 (InterfaceList.isState.enum = 4)  ' isState是枚举类型 1为正常连接, 4为断开连接
编辑框1.加入文本 (“断开中”#换行符 )



如果真 (InterfaceList.isState.enum = 1 InterfaceList.isState.enum = 7)
编辑框1.加入文本 (“连接中”#换行符 )

计次循环尾 ()
子程序名返回值类型公开备 注
__启动窗口_将被销毁  
WlanCloseHandle (WlanHandle, 0)
子程序名返回值类型公开备 注
Unicode转ANSI2文本型 
参数名类 型参考可空数组备 注
Char字节型  
返回 (到文本 (子字节集替换 (到字节集 (Char), { 0 }, {  }, , )))
子程序名返回值类型公开备 注
__启动窗口_创建完毕  
取网卡信息 ()
子程序名返回值类型公开备 注
取网卡信息 'code by 笨笨
GetAdaptersInfo ({ 0 }, size_link)
buf_link = 取空白字节集 (size_link)
ppInterfaceList = 取淞康刂穇字节集 (buf_link, buf_link, 0)
调试输出 (size_link, buf_link, ppInterfaceList)
如果真 (GetAdaptersInfo (buf_link, size_link) = 0)
循环判断首 ()
CopyMemory_iai (AdapterInfo, ppInterfaceList, 640)
link.名称 = 到文本 (AdapterInfo.Description)
mac = “”
计次循环首 (AdapterInfo.AddressLength - 1, i)
tmp = 取十六进制文本 (AdapterInfo.Address [i])
mac = mac + 选择 (tmp = “0”, “00”, tmp)“-”
计次循环尾 ()
mac = 取文本左边 (mac, 取文本长度 (mac) - 1)
link.Mac = mac
CopyMemory_ias (buf_ip, AdapterInfo.IpAddressList, 40)
link.Ip = 到文本 (buf_ip.IpAddress)
link.掩码 = 到文本 (buf_ip.IpMask)
CopyMemory_ias (buf_ip, AdapterInfo.GatewayList, 40)
link.网关 = 到文本 (buf_ip.IpAddress)
link.连接名称 = 取文本zc项 (4, “SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\”到文本 (AdapterInfo.AdapterName)“\Connection\Name”, )
size_dns = GetPerAdapterInfo (AdapterInfo.Index, buf_dns, size_dns)
buf_dns = 取空白字节集 (size_dns)
addr_dns = 取淞康刂穇字节集 (buf_dns, buf_dns, 0)
如果 (GetPerAdapterInfo (AdapterInfo.Index, buf_dns, size_dns) = 0)
CopyMemory_ipai (dns, addr_dns, 92)
link.DNS1 = 到文本 (dns.CurrentDnsServer.IpAddress)
link.DNS2 = 到文本 (dns.DnsServerList.IpAddress)
link.DNS1 = “”
link.DNS2 = “”

' 组合框_共享链接.加入项目 (list [i].Name, )
组合框1.加入项目 (link.连接名称, )
' 组合框1.加入项目 (到文本 (i), )
组合框1.现行选中项 = i
' 输出调试文本 (link.连接名称)
' 输出调试文本 (link.名称)
' 输出调试文本 (link.Mac)
' 输出调试文本 (link.Ip)
' 输出调试文本 (link.掩码)
' 输出调试文本 (link.网关)
' 输出调试文本 (link.DNS1)
' 输出调试文本 (link.DNS2)
ppInterfaceList = AdapterInfo.Next
循环判断尾 (ppInterfaceList ≠ 0)

子程序名返回值类型公开备 注
_按钮3_被单击  
变量名类 型静态数组备 注
b整数型  
' WlanGetInterfaceCapability (WlanHandle, InterfaceList.InterfaceGuid, 0, getinterace.dwNumberOfSupportedPhys)
' WlanQueryInterface (WlanHandle, InterfaceList.InterfaceGuid, 0)



i支持库列表   支持库注释   
spec特殊功能支持库

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 13 天

结帖率:96% (88/92)
发表于 2018-9-15 10:03:33 | 显示全部楼层
用DOS命令搞呗

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 13 天

结帖率:96% (88/92)
发表于 2018-9-15 10:04:18 | 显示全部楼层
gongtengbsg 发表于 2018-9-14 23:51
[e=0].版本 2
.支持库 spec

或者用WMI对象,都可以轻松取到

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 5 天

结帖率:100% (1/1)
发表于 2018-9-15 11:05:15 | 显示全部楼层
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 ver, 整数型
.程序集变量 InterfaceList2, WLAN_INTERFACE_INFO_LIST
.程序集变量 WlanHandle, 整数型
.程序集变量 WlanVersion, 整数型
.程序集变量 ppInterfaceList, 整数型
.程序集变量 InterfaceItems, 整数型
.程序集变量 InterfaceList, WLAN_INTERFACE_INFO
.程序集变量 hDevinfo, 整数型
.程序集变量 spDevInfoData, 整数型
.程序集变量 size_link, 整数型
.程序集变量 AdapterInfo, IP_ADAPTER_INFO
.程序集变量 buf_link, 字节集
.程序集变量 i, 整数型
.程序集变量 mac, 文本型
.程序集变量 tmp, 文本型
.程序集变量 buf_ip, IP_ADDR_STRING
.程序集变量 link, 网卡信息_
.程序集变量 size_dns, 整数型
.程序集变量 dns, IP_PER_ADAPTER_INFO
.程序集变量 buf_dns, 字节集
.程序集变量 addr_dns, 整数型
.程序集变量 getinterace, WLAN_INTERFACE_CAPABILITY
.程序集变量 hw, WLAN_INTF_OPCODE

.子程序 _按钮1_被单击

编辑框1.内容 = “”



ver = 到整数 (取文本左边 (取文本zc项 (#本地机器, “SOFTWARE\Microsoft\Windows NT\CurrentVersion\CurrentVersion”, ), 1))
ver = 选择 (ver ≥ 6, 2, 1)
.如果真 (WlanOpenHandle (ver, 0, WlanVersion, WlanHandle) ≠ 0)  ' 第1个参数 NT5.x 系统填1 NT6.x填2 /第1个参数 XP sp2 sp3 系统填1    vista win7 系统填2

    信息框 (“打开 WLAN 句柄失败”, 0, )
.如果真结束

编辑框1.加入文本 (到文本 (WlanHandle) + #换行符)
编辑框1.加入文本 (到文本 (WlanVersion) + #换行符)


.子程序 _按钮2_被单击

WlanEnumInterfaces (WlanHandle, 0, ppInterfaceList)  ' 获取网卡列表,列表的数据类型是变长的,易语言只能填定长的数据类型  所以只能传指针了
InterfaceItems = 取字节集数据 (指针到字节集 (ppInterfaceList, 4), 3, )  ' 列表类型前8个字节中前4字节  表示网卡数量
ppInterfaceList = ppInterfaceList + 8  ' 后4个字节  表示欲修改网卡号码 , 只是获取网卡信息的话可以忽略 ,该参数从0开始 不是易语言的1开始
调试输出 (ppInterfaceList, InterfaceItems, WlanHandle)
.计次循环首 (InterfaceItems, i)


    RtlMoveMemory_INTERFACE_INFO (InterfaceList2.InterfaceInfo, ppInterfaceList, 532)
    调试输出 (InterfaceItems)
    编辑框1.加入文本 (到文本 (InterfaceList2.dwIndex) + #换行符)
    编辑框1.加入文本 (到文本 (InterfaceList2.dwNumberOfItems) + #换行符)
    编辑框1.加入文本 (到文本 (InterfaceList2.InterfaceInfo.InterfaceGuid) + #换行符)
    编辑框1.加入文本 (到文本 (Unicode转ANSI2 (InterfaceList2.InterfaceInfo.strInterfaceDescription)) + #换行符)
    编辑框1.加入文本 (到文本 (ppInterfaceList) + #换行符)
    ' 编辑框1.加入文本 (到文本 (InterfaceList.isState.enum) + #换行符)  ' 连接状态 4断开  1连接
    ' 编辑框1.加入文本 (到文本 (Unicode转ANSI2 (InterfaceList.strInterfaceDescription)) + #换行符)  ' 网卡名字
    调试输出 (InterfaceList2.dwIndex, InterfaceList2.dwNumberOfItems, InterfaceList2.InterfaceInfo.InterfaceGuid, Unicode转ANSI2 (InterfaceList2.InterfaceInfo.strInterfaceDescription))
    .如果 (InterfaceList.isState.enum = 4)  ' isState是枚举类型 1为正常连接, 4为断开连接
        编辑框1.加入文本 (“断开中” + #换行符)
    .否则

    .如果结束

    .如果真 (InterfaceList.isState.enum = 1 或 InterfaceList.isState.enum = 7)
        编辑框1.加入文本 (“连接中” + #换行符)
    .如果真结束

.计次循环尾 ()



.子程序 __启动窗口_将被销毁

WlanCloseHandle (WlanHandle, 0)


.子程序 Unicode转ANSI2, 文本型
.参数 Char, 字节型, 数组

返回 (到文本 (子字节集替换 (到字节集 (Char), { 0 }, {  }, , )))

.子程序 __启动窗口_创建完毕

取网卡信息 ()


.子程序 取网卡信息, , , 'code by 笨笨

GetAdaptersInfo ({ 0 }, size_link)
buf_link = 取空白字节集 (size_link)
ppInterfaceList = 取变量地址_字节集 (buf_link, buf_link, 0)
调试输出 (size_link, buf_link, ppInterfaceList)

.如果真 (GetAdaptersInfo (buf_link, size_link) = 0)
    .循环判断首 ()
        CopyMemory_iai (AdapterInfo, ppInterfaceList, 640)

        link.名称 = 到文本 (AdapterInfo.Description)

        mac = “”
        .计次循环首 (AdapterInfo.AddressLength - 1, i)
            tmp = 取十六进制文本 (AdapterInfo.Address <i>)
            mac = mac + 选择 (tmp = “0”, “00”, tmp) + “-”
        .计次循环尾 ()
        mac = 取文本左边 (mac, 取文本长度 (mac) - 1)
        link.Mac = mac

        CopyMemory_ias (buf_ip, AdapterInfo.IpAddressList, 40)
        link.Ip = 到文本 (buf_ip.IpAddress)
        link.掩码 = 到文本 (buf_ip.IpMask)

        CopyMemory_ias (buf_ip, AdapterInfo.GatewayList, 40)
        link.网关 = 到文本 (buf_ip.IpAddress)

        link.连接名称 = 取文本zc项 (4, “SYSTEM\CurrentControlSet\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\” + 到文本 (AdapterInfo.AdapterName) + “\Connection\Name”, )

        size_dns = GetPerAdapterInfo (AdapterInfo.Index, buf_dns, size_dns)
        buf_dns = 取空白字节集 (size_dns)
        addr_dns = 取变量地址_字节集 (buf_dns, buf_dns, 0)
        .如果 (GetPerAdapterInfo (AdapterInfo.Index, buf_dns, size_dns) = 0)
            CopyMemory_ipai (dns, addr_dns, 92)
            link.DNS1 = 到文本 (dns.CurrentDnsServer.IpAddress)
            link.DNS2 = 到文本 (dns.DnsServerList.IpAddress)
        .否则
            link.DNS1 = “”
            link.DNS2 = “”
        .如果结束







        ' 组合框_共享链接.加入项目 (list <i>.Name, )
        组合框1.加入项目 (link.连接名称, )
        ' 组合框1.加入项目 (到文本 (i), )
        组合框1.现行选中项 = i








        ' 输出调试文本 (link.连接名称)
        ' 输出调试文本 (link.名称)
        ' 输出调试文本 (link.Mac)
        ' 输出调试文本 (link.Ip)
        ' 输出调试文本 (link.掩码)
        ' 输出调试文本 (link.网关)
        ' 输出调试文本 (link.DNS1)
        ' 输出调试文本 (link.DNS2)

        ppInterfaceList = AdapterInfo.Next
    .循环判断尾 (ppInterfaceList ≠ 0)

.如果真结束


.子程序 _按钮3_被单击
.局部变量 b, 整数型

' WlanGetInterfaceCapability (WlanHandle, InterfaceList.InterfaceGuid, 0, getinterace.dwNumberOfSupportedPhys)
' WlanQueryInterface (WlanHandle, InterfaceList.InterfaceGuid, 0)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 10 天

发表于 2018-9-15 11:58:57 | 显示全部楼层
用DOS命令搞呗

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:0% (0/3)
 楼主| 发表于 2018-9-15 13:48:43 | 显示全部楼层
何必太在意 发表于 2018-9-15 10:04
或者用WMI对象,都可以轻松取到

取网卡有很多方法。我是要WlanEnumInterfaces指定网卡。未解决问题

评分

参与人数 1好评 -1 精币 -1 收起 理由
何必太在意 -1 -1 我读书少,不要骗我

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:0% (0/3)
 楼主| 发表于 2018-9-15 13:49:28 | 显示全部楼层

API才是王道

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:0% (0/3)
 楼主| 发表于 2018-9-16 17:22:16 | 显示全部楼层
迅游团队 发表于 2018-9-15 11:05
.版本 2
.支持库 spec

请不要而已灌水,未解决问题

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表