精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

订阅<精易模块>源码2018年好项目,每月多挣好多钱【收粉\卖粉\交易①群】┏ 12核24线程 , 模拟器24开 ┓找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱【收粉/卖粉/交易①群】┃ 单进程单IP,最低15元一天 ┃找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
若快打码 快速★准确★稳定★便宜全国PPTP秒换IP 动态IP仅35元/月【收粉\卖粉\交易①群】┗新增E3/16G/750TI最低10元┛找软件作者合作/收购引流软件火眼答题-韩文日文-高质量答题
┏█收购一切流量Q:503830000█┓云速打码全天50%分成★稳定★快速【收粉/卖粉/交易①群】★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
▇QQ新科技软件▇随时更新▇诺宾混拨动态vps/PPTP多地区换IP【脚本/软件/协议/变现群】█IP精灵█最强大的动态IP加速器找软件作者合作/收购引流软件██5年老店大量售各种一手QQ██
┏无限收各种推广资源,推广渠道┓╔ 收粉丶卖粉丶大型①群 ╗【脚本\软件\协议\变现群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收小视频引流,直播平台粉 ┃收粉丶卖粉丶大型①群【收粉\卖粉\交易②群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃   收交友粉/网赚粉/精准粉  ┃收粉丶卖粉丶大型①群【收粉/卖粉/交易②群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收QQ邮箱流量 邮件发送通道 ┃收粉丶卖粉丶大型①群【收粉\卖粉\交易②群】高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┗收QQ群发,微信朋友圈广告代发┛收粉丶卖粉丶大型①群【收粉/卖粉/交易②群】高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┏公司实力高价 收 引流软件渠道┓收粉丶卖粉丶大型①群【脚本/软件/协议/变现群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃收粉丶卖粉丶大型①群【脚本\软件\协议\变现群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃╚ 收粉丶卖粉丶大型①群 ╝【收粉\卖粉\交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉【收粉/卖粉/交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力高价 收 引流软件渠道┃大量收精准粉【收粉\卖粉\交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【收粉/卖粉/交易③群】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【重金求各种作者】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【重金求各种作者】██高价收引流软件Q918213529██寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉大量现金收【各种粉】██高价收引流软件Q918213529██寻求有项目的大神合作██出资源/粉/流量/用户量███
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出资源/粉/流量/用户量███
┃公司实力收 qun 发 邮箱软件 ┃█长期大量收购各种活粉█大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出资源/粉/流量/用户量███
┃公司实力收 qun 发 邮箱软件 ┃█ 长期收购各种引流软件 █大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出资源/粉/流量/用户量███
┃公司实力收 qun 发 邮箱软件 ┃██ 当天处Q 三无Q 带售后 ██大量现金收【各种粉】
 全网重金收各种资源流量QQ:868333 
寻求有项目的大神合作██出资源/粉/流量/用户量███
┃公司实力收 qun 发 邮箱软件 ┃██ 当天处Q 三无Q 带售后 ██大量现金收【各种粉】
 全网重金收各种资源流量QQ:868333 
寻求有项目的大神合作██出资源/粉/流量/用户量███
┗公司实力收 qun 发 邮箱软件 ┛██  量大出微博小号  ██大量现金收【各种粉】大量收微信男粉QQ 2820301656寻求有项目的大神合作██出资源/粉/流量/用户量███
★高价收站群量CPS日结★微信扫码进群QQ9703796大量现金收【各种粉】大量收微信男粉QQ 1289624992寻求有项目的大神合作██出资源/粉/流量/用户量███
★高价收站群量CPS日结★微信扫码进群QQ9723558大量现金收【各种粉】收抖音火山王者引流:1513888885寻求有项目的大神合作██出资源/粉/流量/用户量███
┃     全新QQ一手批发    ┃
大量收国外隔天号交友粉1324888881大量现金收【各种粉】收抖音火山王者引流:1513888885寻求有项目的大神合作██出资源/粉/流量/用户量███
┃     全新QQ一手批发    ┃大量收男粉扫码进群QQ1324888881 大量现金收【各种粉】收QQ邮箱流量 邮件发送通道 寻引流高手合作/1万粉以下勿扰【导群,微信通讯录加粉打群】
日出大量男粉加Q群微信出精准网赚粉███各类QQ小号███大量现金收【各种粉】收微博 QQ群 朋友圈广告代发寻引流高手合作/1万粉以下勿扰
【导群,打小群40人,微信粉】
日出大量男粉加Q群微信出精准网赚粉长期出QQ群QQ号微信精准粉网挣粉大量现金收【各种粉】大量租售各种qq小号 2892721932寻引流高手合作/1万粉以下勿扰日出大量网赚粉微信QQ各行精准活粉
██ 日出大量网赚粉/交友粉 ██API日流水18万,长效稳定S5,HTTPS大量现金收【各种粉】██=收网赚粉=█=收网赚粉=██寻引流高手合作/1万粉以下勿扰███大量出租一手QQ粉███
出微信qq交友粉网赚粉精准粉兼职抖音/微视/快手/小红书▇自助点赞大量现金收【各种粉】高价收网吧量联系QQ2088724059寻引流高手合作/1万粉以下勿扰收兼职粉
【收】抖音/快手/微博等软件寻网吧端,下载站,各种端合作大量联通正常号段寻正规项目合作【收】引流软件/网赚兼职粉/男粉寻引流高手合作/1万粉以下勿扰收各类交友粉等流量,微信:qunfa000
█拨号VPS服务器4元/天免费测试█出兼职,网赚,交友粉,微信拉群大量联通正常号段寻正规项目合作
有精准粉.交友粉.男粉.年龄大
寻引流高手合作/1万粉以下勿扰
████大量收top域名████
出微信精准好友+微信:41752088★动态S5.可换地区可混拨可定时★大量联通正常号段寻正规项目合作█流量大手交流群:734505645█寻引流高手合作/1万粉以下勿扰 我要租广告位
查看: 1918|回复: 24
收起左侧

[优秀原创软件] Relative-RZJ[中文编程通用IDE]V1.7.1.5全面升级

[复制链接]

签到天数:10 天

结帖率:0% (0/1)
发表于 2018-7-30 15:27:05 | 显示全部楼层 |阅读模式
软件展示
软件来源: 原创开发
软件类型: 编程开发
哈勃分析报告: https://habo.qq.com/file/showdetail?pk=AD0GYV1vB28IPls5
界面截图:
本帖最后由 宇智波·佐助 于 2018-7-31 10:37 编辑

历史发布版本:
Relative-RZJ V1.0: https://bbs.125.la/forum.php?mod=viewthread&tid=14178773&page=1&ordertype=1#pid13609553
Relative-RZJ V1.2.1.9:https://bbs.125.la/forum.php?mod=viewthread&tid=14199475&extra=
其它小更新请持续关注QQ群:659077591 或 持续关注最新版本贴的补充内容

本次更新大量内容{
全面优化界面UI(V1.4 更新包内实现
添加 原语言代码 和 新语言代码之间的转换(如英->中、中->英)
JAVA(库):所引用的模块(菜单项操作模块、JSON库处理模块)更新
[动态DLL存放目录]:Relative-RZJ(V1.7.1.5)\dll\fujian
完成主界面和相关动态DLL界面的跨语言化
全面更新DLL
第一次提供带有功能的mian.dll(载入自制皮肤)
修改辅Zhu程序的存储和打开方式:Relative-RZJ(V1.7.1.5)\dll\self
优化程序开启时的自检功能
修改了LOGO.png
修改了各图片组的载入方式Relative-RZJ(V1.7.1.5)\resource\xmt [*.BMP格式,文件名从0.bmp
目前提供界面语言[中文、英文、俄文、日文](采用搜狗、百度翻译)Relative-RZJ(V1.7.1.5)\language
......
}

废话不多说!先上图!
ZW.png
YY.png
以上是中英互译功能效果图。使用方法是:点击界面右下角,即>详细信息<左边的 <- 和 -> 按钮实现互译
EY.png
RY.png
Y_Y.png
当前语言库提供的全部DLL接口(详细使用方法可见:Relative-RZJ(V1.7.1.5)\configure\JAVA\type\普通工程\dlls\Load.e)
DLL名统一为:Load.dll
  1. <p>.版本 2</p><p>.子程序 load, , 公开, 初始化加载
  2. .参数 窗口句柄, 整数型
  3. .参数 总事件为, 子程序指针
  4. .参数 库位置为, 文本型
  5. </p><p>.版本 2</p><p>.子程序 loadR_cdx, , 公开, 编译菜单项
  6. .参数 主窗口菜单句柄, 整数型, , (最高层的菜单句柄)
  7. .参数 程序, 整数型, , (第二层的菜单句柄)1 程序 2 编辑 3 查看 4 工具 5 界面 6帮助 7 禁止栏
  8. .参数 编辑, 整数型
  9. .参数 查看, 整数型
  10. .参数 工具, 整数型
  11. .参数 界面, 整数型
  12. .参数 帮助, 整数型
  13. .参数 禁止栏, 整数型
  14. .参数 左菜单句柄, 整数型, , (第二层的菜单句柄)左菜单句柄
  15. .参数 右菜单句柄, 整数型, , (第二层的菜单句柄)右菜单句柄
  16. .参数 子夹头句柄, 整数型, , (第二层的菜单句柄)存放子夹头菜单项句柄
  17. .参数 右_库句柄, 整数型
  18. .参数 下_常亮句柄, 整数型
  19. </p><p>.版本 2</p><p>.子程序 load_gjsj1, 文本型, 公开, 挂接事件  窗口菜单被选择 [可有可无]
  20. .参数 菜单ID, 整数型
  21. </p><p>.版本 2</p><p>.子程序 load_gjsj2, 文本型, 公开, 挂接事件  系统菜单被选择 [可有可无]
  22. .参数 菜单ID, 整数型
  23. </p><p>.版本 2</p><p>.子程序 load_gjsj3, 文本型, 公开, 挂接事件  鼠标经过菜单项 [可有可无]
  24. .参数 菜单ID, 整数型
  25. </p><p>.版本 2</p><p>.子程序 load_zsxk, , 公开, 判断事件 左树型框右键后执行
  26. .参数 现行选中项文本, 文本型
  27. .参数 是否为文件夹, 逻辑型
  28. .参数 路径, 文本型
  29. .参数 项目索引, 整数型
  30. .参数 项目父索引, 整数型
  31. .参数 总工程路径, 文本型, , 树型框最顶层时的路径
  32. </p><p>.版本 2</p><p>.子程序 load_ysxk, , 公开, 判断事件 右树型框右键后执行
  33. .参数 现行选中项文本, 文本型
  34. .参数 是否为文件夹, 逻辑型
  35. .参数 路径, 文本型
  36. .参数 项目索引, 整数型
  37. .参数 项目父索引, 整数型
  38. </p><p>.版本 2</p><p>.子程序 load_zsyjc, 文本型, 公开, 注释与解除注释
  39. .参数 是否为注释, 逻辑型
  40. .参数 是否多行, 逻辑型
  41. .参数 文本, 文本型
  42. </p><p>.版本 2</p><p>.子程序 load_R_zfsr, , 公开, 代码框输入字符时触发
  43. .参数 字符代码, 整数型
  44. </p><p>.版本 2</p><p>.子程序 load_qsxkzjj, 文本型, 公开, 取树形框的项目(支持库)
  45. </p><p>.版本 2</p><p>.子程序 DM_FG, 文本型, 公开, 设置代码及风格号
  46. </p><p>.版本 2</p><p>.子程序 AI_tall, , 公开, 智能提醒
  47. .参数 输入的文本, 文本型, , 当输入的内容为多项继承时会提供分割 如:(form.left)会传递为:“form . left”
  48. </p><p>.版本 2</p><p>.子程序 AI_retrue, 整数型, 公开, 智能提醒 返回 选中项(返回值为 -1 时自动选择前面的长度替换文本 0插入文本 其它则 选取指定长度替换文本)
  49. .参数 选中项文本, 文本型
  50. .参数 选中项数值, 整数型, ,  
  51. </p><p>.版本 2</p><p>.子程序 KU_SM, , 公开, 取库或命令的说明
  52. .参数 选中项文本, 文本型
  53. .参数 选中项数值, 整数型, ,  
  54. .参数 选中项层次, 整数型
  55. </p><p>.版本 2</p><p>.子程序 OPEN_KU_path, , 公开, 打开库位置
  56. .参数 选中项文本, 文本型
  57. .参数 选中项数值, 整数型, ,  
  58. </p><p>.版本 2</p><p>.子程序 GET_interpret, 文本型, 公开, 返回鼠标停留事件
  59. .参数 停留获得的内容, 文本型
  60. </p><p>.版本 2</p><p>.子程序 GET_HANG, , 公开, 提供当前行文本行文本
  61. .参数 行文本, 文本型
  62. .参数 行数, 整数型
  63. </p><p>.版本 2</p><p>.子程序 GET_ALL, , 公开, 提供当前全部文本
  64. .参数 文本, 文本型
  65. </p><p>.版本 2</p><p>.子程序 DJ_ZJFK, , 公开, 鼠标左键放开事件
  66. .参数 位置, 整数型
  67. .参数 功能键状态, 整数型
  68. </p><p>.版本 2</p><p>.子程序 GET_DUANDIAN, , 公开, 提供当前代码断点
  69. .参数 文本型, 文本型, , 用","分割
  70. </p><p>.版本 2</p><p>.子程序 GET_GCXX, , 公开, 提供当前工程信息
  71. .参数 工程文件夹, 文本型
  72. .参数 工程项位置, 文本型
  73. .参数 工程项编码, 逻辑型, , 真 则使用编码:UTF-8,假 则使用:ANSI
  74. .参数 工程名, 文本型
  75. .参数 对应的树型框索引, 整数型
  76. .参数 对应的树型框父索引, 整数型
  77. </p><p>.版本 2</p><p>.子程序 R_OVER, , 公开, 程序结束时执行</p>
复制代码
进程通信:
在DLL库内部可使用
调用子程序 (load事件下提供的子程序指针:总事件为, , , 进程通信代码)
实现

在外部可使用自带的进程通信模块中的:
R_置R专用消息发送的_ID (“Relative.exe”) ’  这个命令只需要在程序启动时调用一次即可
R_专用消息发送 (“PASS”, 到字节集 (进程通信代码)) ’  本命令在要与Relative实现进程通信控制的时候使用

【Relative提供的进程通信命令有】:
  1. 执行的代码格式>>

  2.     <代码> 代码值1 代码值2 代码值......
  3.     其中若代码值中需要用到空格必须用 <fgf> 来代替!

  4. 下面是代码及格式>>

  5.   {在有工程的前提下才有效!}

  6.         <charu> 内容                           [用处:向代码区当前位置插入“内容”]
  7.             <-> 位移                           [用处:调整代码区光标位置,当“位移”为正数则向右移,反之左移]
  8.        <SET_SQ> 行号                           [用处:设置“行号”行的书签]
  9.        <SET_DD> 行号                           [用处:设置“行号”行的断电]
  10.          <XZ_H> 行号                           [用处:选中“行号”行]
  11.         <XZ_WZ> 起点 终点                      [用处:选中从“起点”到“终点”范围内的内容]
  12.          <XZ_D> 内容                           [用处:将选中区的文本替换为“内容”]
  13.             <R>                                [用处:撤销一步]
  14.             <N>                                [用处:重复一步]
  15.            <CD> ID                             [用处:模拟单机菜单栏中ID为“ID”的菜单项]
  16.            <>>> 类型 内容                      [用处:当“类型”=0,则将“内容”插入到当前位置,否则插入到最后]
  17.      <GET_HANG>                                [用处:为语言DLL库提供行文本和行号]
  18.       <GET_ALL>                                [用处:为语言DLL库提供全部代码文本]
  19. <GET_DUANDIAN>                                [用处:将当前全部断点提供给语言库使用]
  20.     <GET_ALL_E>                                [用处:将当前全部代码翻译后提供给语言库使用]
  21.        <ADD_BL> 变量应用范围|变量数据类型|变量名|项目数值
  22.                                                [用法:按格式加入变量项]
  23.        <ADD_KU> 库名称|库引用地址|项目数值
  24.                                                [用法:按格式加入引用库]
  25.         <SC_KU> index                          [用处:删除第“index”项库引用]
  26.         <SC_BL> index                          [用处:删除第“index”项变量引用]

  27.   {在无工程的前提下也有效!}

  28.          <Tree> 树型框号 图片组文件位置        [用处:设置“树型框号”(1~5) 的图片组为“图片组文件位置”的文件]
  29.            <TS> 内容                           [用处:在提示栏中显示“内容”]
  30.         <SC_SC> 内容                           [用处:在输出栏中追加显示“内容”]
  31.         <SC_QK>                                [用处:清空输出栏的内容]
  32.           <B_L> +/-                            [用处:“+”显示变量夹,“-”隐藏变量夹]
  33.           <C_L> +/-                            [用处:“+”显示常量夹,“-”隐藏常量夹]
  34.         <K_L_J> +/-                            [用处:“+”显示库链接夹,“-”隐藏库链接夹]
  35.      <Tree1_KZ> index                          [用处:扩展树型框1的第 index 项]
  36.   <Tree1_SS-KZ> index                          [用处:[_树型框1_即将扩展(index)事件]一般跟在<Tree1_KZ>后面]
  37.      <Tree1_SS> index                          [用处:收缩树型框1的第 index 项]
  38.      <Tree1_JS>                                [用处:初始化树型框1内容和状态]
  39.      <Tree2_SX>                                [用处:树型框2刷新内容]
复制代码
使用方式如 :
.版本 2
.子程序 __启动窗口_创建完毕

R_置R专用消息发送的_ID (“Relative.exe”)
R_专用消息发送 (“PASS”, 到字节集 (“<TS> IDE代码操作器<fgf>启动完成!”))

Relative-RZJ主程序就会在消息栏输出内容:IDE代码操作器 启动完成!

更多小更新请持续关注最新贴的补充信息或加群了解:659077591
程序下载:https://share.weiyun.com/5sBSjH1
本人会不定期公开部分相关代码,以供大家学习。
本人菜鸟一个,请大家多多指教。
若发现BUG或发现那些地方可以优化请加群与我联系!



界面更新包: 更新包.zip (4.6 KB, 下载次数: 5)

评分

参与人数 3好评 +3 精币 +14 收起 理由
Aurora + 1 + 2 此处应该有鼓励~
胆小的老虎 + 1 + 10 感谢发布原创作品,精易因你更精彩!
[不速之客] + 1 + 2 顶。。。

查看全部评分

您可以选择打赏方式支持楼主

本帖被以下淘专辑推荐:

  • · 鱼木|主题: 716, 订阅: 56

签到天数: 11 天

结帖率:100% (2/2)
发表于 昨天 14:02 | 显示全部楼层
感谢楼主分享
回复

使用道具 举报

签到天数: 1 天

发表于 昨天 10:45 | 显示全部楼层
支持,支持
回复

使用道具 举报

签到天数: 11 天

发表于 前天 10:18 | 显示全部楼层
干货干货6的飞起
回复

使用道具 举报

签到天数: 15 天

结帖率:0% (0/1)
发表于 4 天前 | 显示全部楼层
此处应该有鼓励~
回复

使用道具 举报

签到天数: 2 天

发表于 7 天前 | 显示全部楼层
看着好厉害
回复

使用道具 举报

签到天数: 4 天

发表于 7 天前 | 显示全部楼层
时间。。。。。
回复

使用道具 举报

签到天数: 8 天

发表于 7 天前 | 显示全部楼层
感谢发布原创作品,精易因你更精彩
回复

使用道具 举报

签到天数: 15 天

发表于 2018-8-7 23:34:46 | 显示全部楼层
干嘛用的啊,谢谢分享
回复

使用道具 举报

签到天数: 2 天

发表于 2018-8-7 18:46:14 | 显示全部楼层
6666666666666666666666666666666666
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表