精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

订阅<精易模块>源码2018年好项目,每月多挣好多钱大型收粉卖粉交流群 798257678收抖音火山王者引流:1513888885找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱大型收粉卖粉交流群 798257678收抖音火山王者引流:1513888885找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
若快打码 快速★准确★稳定★便宜全国PPTP秒换IP 动态IP仅35元/月全网最高价收【各种活粉】★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件火眼答题-韩文日文-高质量答题
┏█收购一切流量Q:503830000█┓云速打码全天50%分成★稳定★快速全网最高价收【各种活粉】▇QQ新科技软件▇随时更新▇找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
诺宾混拨动态vps/PPTP多地区换IP█IP精灵█最强大的动态IP加速器全网最高价收【各种活粉】██5年老店大量售各种一手QQ██ 找软件作者合作/收购引流软件┏°短信qun发内容成功率百分百°┓
┏无限收各种推广资源,推广渠道┓┏  12核24线程,模拟器24开  ┓全网最高价收【各种活粉】集团重金收购微信各种引流方式找软件作者合作/收购引流软件┃°短信qun发内容成功率百分百°┃
┃ 收小视频引流,直播平台粉 ┃┃  单进程单IP,最低15元一天  ┃全网最高价收【各种活粉】集团重金收购微信各种引流方式找软件作者合作/收购引流软件┃°手机短信qun发广告量找老板°┃
┃   收交友粉/网赚粉/精准粉  ┃┗新增E3/16G/750TI最低10元┛全网最高价收【各种活粉】集团重金收购微信各种引流方式找软件作者合作/收购引流软件┃°手机短信qun发广告量找老板°┃
┃ 收QQ邮箱流量 邮件发送通道 ┃┏实力公司诚邀引流技术大神合作┓无限收【交友粉】集团重金收购微信各种引流方式寻求有项目的大神合作┃ °短信内容不限制实力接单中°┃
┗收QQ群发,微信朋友圈广告代发┛┃ 长期大量收购 男粉女粉交友粉 ┃无限收【交友粉】集团重金收购微信各种引流方式寻求有项目的大神合作┃ °短信内容不限制实力接单中°┃
┏公司实力高价收引流软件渠道┓┃大量收购一切精准流与推广模式┃无限收【交友粉】高价收购任何微信QQ粉寻求有项目的大神合作┃ °一手卡发机房100%不扣量° ┃
┃公司实力高价收引流软件渠道┃┃ 另招聘技术大牛享受入股分红 ┃无限收【交友粉】高价收购任何微信QQ粉寻求有项目的大神合作┃ °一手卡发机房100%不扣量° ┃
┃公司实力高价收引流软件渠道┃┗--------实力收购一切活跃量-------┛无限收【交友粉】高价收购任何微信QQ粉寻求有项目的大神合作┃低价出各类广告QQ:5968282┃
┃公司实力高价收引流软件渠道┃█长期大量收购各种活粉█无限收【交友粉】高价收购任何微信QQ粉寻求有项目的大神合作┗低价出各类广告QQ:5968282┛
┃公司实力高价收引流软件渠道┃█ 长期收购各种引流软件 █大型引流、出粉、交流群高价收购任何微信QQ粉寻求有项目的大神合作┃  寻求各种项目合作入股  ┃
┃公司实力高价收引流软件渠道┃██ 当天处Q 三无Q 带售后 ██大型引流、出粉、交流群实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作┃  寻求各种项目合作入股  ┃
┃公司实力高价收引流软件渠道┃██ 当天处Q 三无Q 带售后 ██大量现金收【各种粉】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作┃  寻求各种项目合作入股  ┃
┃公司实力高价收引流软件渠道┃██  量大出微博小号  ██大量现金收【各种粉】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作┃ 收网赚粉 / 精准粉 / 兼职粉 ┃
┃公司实力高价收引流软件渠道┃◤重要的事情说N遍,收游戏粉◥大量现金收【各种粉】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作┃ 收网赚粉 / 精准粉 / 兼职粉 ┃
┃公司实力高价收引流软件渠道┃
➊  收购英雄联盟游戏粉  █
大量现金收【各种粉】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作┃ 收网赚粉 / 精准粉 / 兼职粉 ┃
┃ 最高价收 抖音快手各类软件 ┃
➋  收购英雄联盟游戏粉  █
全网最高价收【各种活粉】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作┃ 收网赚粉 / 精准粉 / 兼职粉 ┃
┃ 最高价收 抖音快手各类软件 ┃
➌  收购英雄联盟游戏粉  █
全网最高价收【各种活粉】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作┃ 收快手火山抖音 小视频引流 ┃
┃ 最高价收 抖音快手各类软件 ┃◣长期收各种量联系3628000◢全网最高价收【各种活粉】*全行业各渠道高返点开户运营合作*寻求有项目的大神合作┃ 收快手火山抖音 小视频引流 ┃
┃ 最高价收 抖音快手各类软件 ┃收男粉扫码微群QQ3863588全网最高价收【各种活粉】*大量出一切精准流资源与推广模式*寻求有项目的大神合作┃ 收快手火山抖音 小视频引流 ┃
┗ 最高价收 抖音快手各类软件 ┛收网赚附近K歌 QQ3863588全网最高价收【各种活粉】* 实力各种项目意向高质量精准粉 *寻求有项目的大神合作┃收购地区跳转量跳转量跳转量┃
★高价收站群量CPS日结★大量收国外隔天号交友粉1324888881全网最高价收【各种活粉】*男科、减肥、丰胸、祛斑、祛痘等*寻求有项目的大神合作┃收购地区跳转量跳转量跳转量┃
★高价收站群量CPS日结★大量收男粉扫码进群QQ1324888881 无限收【交友粉】大量租售各种qq小号 2892721932寻求有项目的大神合作┃收购地区跳转量跳转量跳转量┃
┃     全新QQ一手批发    ┃
长效包月API提取无限收【交友粉】日出大量男粉加Q群微信出精准网赚粉寻求有项目的大神合作全网重金找安卓app逆向大神合作
┃     全新QQ一手批发    ┃美国欧洲包月ip无限收【交友粉】日出大量男粉加Q群微信出精准网赚粉寻引流高手合作/1万粉以下勿扰全网重金找安卓app逆向大神合作
长期出QQ群QQ号微信精准粉网挣粉*自由选择合作方式+Q:422286342*无限收【交友粉】███各类QQ小号███寻引流高手合作/1万粉以下勿扰全网重金找安卓app逆向大神合作
大量收微信男粉QQ 2820301656大量收微信男粉QQ 1289624992无限收【交友粉】日出大量网赚粉微信QQ各行精准活粉寻引流高手合作/1万粉以下勿扰██ 当天全新 微博 带售后 ██
█收微信扫码或邀请进群质量粉█收网赚粉,各种引流软件Q172926284无限收【交友粉】███大量出租一手QQ粉███寻引流高手合作/1万粉以下勿扰寻网吧端,下载站,各种端合作
一手全新处Q 南唐QQ网出微信qq交友粉网赚粉精准粉兼职无限收【交友粉】抖音/微视/快手/小红书▇自助点赞寻引流高手合作/1万粉以下勿扰微信解封申诉+微信号qunfa000
优化商城软件排名-做小程序的来收高质量活粉网赚粉QQ435708827无限收【交友粉】收微信裂变粉Q116886339寻引流高手合作/1万粉以下勿扰长期稳定大量出家庭安装Q85107200
收各种引流软件
收网吧端联系QQ2786824405
无限收【交友粉】长期出售引流软件Q792466325寻引流高手合作/1万粉以下勿扰█拨号VPS服务器4元/天免费测试█
收精准网赚粉/游戏粉/棋牌粉5000人微信号-全活跃男粉-无假粉无限收【交友粉】出兼职,网赚,交友粉,微信拉群寻引流高手合作/1万粉以下勿扰 我要租广告位
查看: 263|回复: 9
收起左侧

[已解决] 各路大神快来围观,重大技术问题,求解

 关闭 [复制链接]

签到天数:8 天

结帖率:100% (4/4)
发表于 2018-7-12 22:25:50 | 显示全部楼层 |阅读模式
9精币
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟1.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
结果 = 结果 + 到文本 (数组 [随机位置])
如果真 (取文本长度 (结果) < 2)
结果 = “0” + 结果
如果真 (取文本长度 (结果) > 2)
结果 = 取文本右边 (结果, 20)
结果 = 结果 + “,”
' ’输出调试文本 (结果)
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()
子程序名返回值类型公开备 注
_时钟1_周期事件  
_按钮1_被单击 ()

图片

图片

最佳答案

查看完整内容

[e=4].版本 2 .子程序 _按钮1_被单击 时钟2.时钟周期 = 2000 .子程序 _时钟2_周期事件 .局部变量 数组, 整数型, , "0" .局部变量 计次变量, 整数型 .局部变量 随机位置, 整数型 .局部变量 数量, 整数型 .局部变量 结果, 文本型 .局部变量 经过, 整数型 数量 = 8 .计次循环首 (10, 计次变量) 加入成员 (数组, 计次变量) .计次循环尾 () .计次循环首 (数量, 计次变量) 置随机数种子 () 随机位 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 21 天

结帖率:100% (8/8)
发表于 2018-7-12 22:42:15 | 显示全部楼层
  
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟2.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
如果 (数组 [随机位置] < 10)
结果 = 结果 + “0”到文本 (数组 [随机位置])“,”
结果 = 结果 + 到文本 (数组 [随机位置])“,”
编辑框1.内容 = 取文本左边 (结果, 取文本长度 (结果) - 1)
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 1好评 +1 精币 +1 收起 理由
1636848518 + 1 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 21 天

结帖率:100% (8/8)
发表于 2018-7-12 22:25:51 | 显示全部楼层
  
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟2.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
如果 (数组 [随机位置] < 10)
结果 = 结果 + “0”到文本 (数组 [随机位置])“,”
结果 = 结果 + 到文本 (数组 [随机位置])“,”
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 2好评 +1 精币 +1 荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!
1636848518 + 1 + 1 大神,请收下我的膝盖

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 22 天

结帖率:100% (5/5)
发表于 2018-7-12 22:34:18 | 显示全部楼层
还以为是什么大问题呢,弄这么个标题
你自己调试看吧,只有第一次的时候 "结果" 这个变量长度小于2
你的那个变量在不断的累加

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 5 天

发表于 2018-7-12 22:35:59 | 显示全部楼层
因为这句代码:
  
结果 = 结果 + 到文本 (数组 [随机位置])

这里的结果,不是单单的数字,而是整个字符串。比如:
第一次:结果的值为6
但是第二次累加后,为06,1
超过2个字符了,所以不加前缀0了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 22 天

结帖率:100% (3/3)
发表于 2018-7-12 22:37:19 | 显示全部楼层
二楼已经解答了
解决方法就是弄一个临时的变量如数值内容
然后比较 取文本长度(数值内容)>2比较
然后再是 结果=结果+数值内容

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 5 天

发表于 2018-7-12 22:38:11 | 显示全部楼层
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟1.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))

a=到文本 (数组 [随机位置])
如果真 (取文本长度 (a) < 2)
结果 = “0” + a
如果真 (取文本长度 (a) > 2)
a = 取文本右边 (a, 20)
结果 = 结果 + a
结果 = 结果 + “,”
' ’输出调试文本 (结果)
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()
子程序名返回值类型公开备 注
_时钟1_周期事件  
_按钮1_被单击 ()


可以这么改!

评分

参与人数 1精币 +1 收起 理由
1636848518 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 5 天

结帖率:100% (1/1)
发表于 2018-7-12 22:55:46 | 显示全部楼层
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

时钟2.时钟周期 = 2000

.子程序 _时钟2_周期事件
.局部变量 数组, 整数型, , "0"
.局部变量 计次变量, 整数型
.局部变量 随机位置, 整数型
.局部变量 数量, 整数型
.局部变量 结果, 文本型, , "0"
.局部变量 中间结果, 文本型
.局部变量 最终文本, 文本型
.局部变量 经过, 整数型
.局部变量 i, 整数型

数量 = 8
.计次循环首 (10, 计次变量)
    加入成员 (数组, 计次变量)
.计次循环尾 ()
调试输出 (数组)
置随机数种子 ()
.计次循环首 (数量, 计次变量)
    随机位置 = 取随机数 (1, 取数组成员数 (数组))
    中间结果 = 到文本 (数组 [随机位置])
    .如果真 (取文本长度 (中间结果) < 2)
        中间结果 = “0” + 中间结果
    .如果真结束
    .如果真 (取文本长度 (中间结果) > 2)
        中间结果 = 取文本右边 (中间结果, 2)
    .如果真结束
    加入成员 (结果, 中间结果)
.计次循环尾 ()
.计次循环首 (数量, i)
    最终文本 = 最终文本 + 结果 [i] + “,”
.计次循环尾 ()
编辑框1.内容 = 最终文本
删除成员 (数组, 随机位置, 1)


.子程序 _时钟1_周期事件

_按钮1_被单击 ()

‘还有就是你到底是要一步一步套源码还是什么意思?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 22 天

结帖率:100% (2/2)
发表于 2018-7-12 22:59:30 | 显示全部楼层
  
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
局部文本型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
局部 = 到文本 (数组 [随机位置])
如果真 (取文本长度 (局部) < 2)
局部 = “0” + 局部
如果真 (取文本长度 (局部) > 2)
局部 = 取文本右边 (局部, 2)
结果 = 结果 + 局部
如果真 (计次变量 < 数量)
结果 = 结果 + “,”
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 1精币 +1 收起 理由
1636848518 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 22 天

结帖率:92% (11/12)
发表于 2018-7-12 23:56:55 | 显示全部楼层
跟你说吧 1你这个 属于 累加  所以

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表