精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5各种配置电脑出租 ┓找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
2019年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP,模拟器稳定24开┃找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
全国PPTP秒换IP 动态IP仅35元/月诺宾混拨动态vps/PPTP多地区换IP长期 包养全网交友粉大户┗ E3/8元 E5/10元 双路12元 ┛找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
出兼职,网赚,交友粉,扫码进群出微信qq交友粉网赚粉精准粉兼职长期 包养全网交友粉大户█IP精灵█最强大的动态IP加速器找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
长期出QQ群QQ号微信精准粉网挣粉出网赚粉/精准粉/独家引流软件各种【活粉变现点这里】客服①———邮件群fa/WZ最新资源合作找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
┏集团收购:一手短信、邮箱群fa┓███████████████各种【活粉变现点这里】客服①收购代加QQ单项好友找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
┃集团收购:一手短信、邮箱群fa┃ █         高 分 成         █各种【活粉变现点这里】客服②收购代加QQ单项好友找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
┃集团收购:,一手精准群发用户┃ █         高 转 化         █各种【活粉变现点这里】客服②收购代加QQ单项好友找软件作者合作/收购引流软件★高价收,女性,宝妈粉Q365299999★
┃集团收购:,一手精准群发用户┃█         高 留 存         █各种【活粉变现点这里】客服③收购代加QQ单项好友实力团队大量收粉入群找管理★高价收,女性,宝妈粉Q365299999★
┗集团收购:-爬取QQ达人会员号┛█ 独立后台  实时刷新 █各种【活粉变现点这里】客服③收购代加QQ单项好友实力团队大量收粉入群找管理★高价收,女性,宝妈粉Q365299999★
长期大量收一手精准网赚粉█        C   游  戏        ███大量收婚恋宝妈 快手 火山██出高质量粉,日产多、实力来谈实力团队大量收粉入群找管理出售长短效HTTP-S5私密IP-高质量
长期收各种精准网赚资源█        P   分  成        ███ 稳定收交友粉,找我换钱 ██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理出售长短效HTTP-S5私密IP-高质量
长期收各种小视频网赚资源█        S   合  作        ███收婚恋粉宝妈粉,找我换钱██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
长期收各种引流精准网赚粉█   8 2 5 1 3 7 7 7 7  ███收快手火山虎牙,找我换钱██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
大量收粉真实粉商长期合作█████████████████长期大量收粉量大量小都吃██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
加华缘社群支持免费担保█长期大量收购各种活粉███ 婚恋/抖音/宝妈/空间/快手██精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
欢迎粉商渠道客户进QQ群█ 长期收购各种引流软件 ████有量有质量,找我换钱███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
长期收各种粉真实长期合作大量收代加QQ各种单双向群███实力大型公司收媒体量███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
真实网赚量点击进华缘社群现加/拉群/现货单双向群通吃███大量资金,来一手代理███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
华缘社Q群号码364884407怕你没量,别怕我没钱███有量就有钱,速度来撩███精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道收网赚粉 兼职粉 宝妈粉 9703796┃  全网大量收  ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道收网赚粉 兼职粉 宝妈粉 9703796┃ 各种App交友粉 ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道大量出各种粉联系QQ222561┃   网赚粉   ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道大量出各种粉联系QQ222561┃   游戏粉   ┃精准粉-产量高-时速快-质量好实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道┃集团高价回收 WZ 兼职 精准粉┃┃   婚恋粉   ┃出高质量粉,日产多、实力来谈实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道┃ 收一切可用资源QQ:293950 ┃┃  各种活人粉  ┃『实力收扫码进群量』实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道┃集团高价回收 WZ 兼职 精准粉┃┃   短视频粉  ┃『你量真,我需求大』实力团队大量收粉入群找管理公司实力收粉进群滴滴管理
公司实力收引流软件渠道┃ 收一切可用资源QQ:293950 ┃┃ 全网最高单价收购 ┃『 你不乱,我不断 』实力团队大量收粉入群找管理收男粉微信扫码进群QQ584121900
公司实力收引流软件渠道┃集团高价回收 WZ 兼职 精准粉┃无限收学生粉,宝妈,女性粉,游戏粉
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ584121900
公司实力收引流软件渠道┃ 收一切可用资源QQ:293950 ┃无限收学生粉,宝妈,女性粉,游戏粉
『欢迎实力粉商来撩』
寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ584121900
公司实力收引流软件渠道出QQ群微信QQ号交友粉网赚粉兼职粉无限收学生粉,宝妈,女性粉,游戏粉长期收网赚粉 QQ8904040寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ584121900
公司实力收引流软件渠道█实力招收朋友圈 QQ群 邮件 推广无限收学生粉,宝妈,女性粉,游戏粉实力团队收粉 QQ8904040寻引流高手合作/1万粉以下勿扰收男粉微信扫码进群QQ584121900
公司实力收引流软件渠道国内外长短效HTTP-Socks5高质量IP无限收学生粉,宝妈,女性粉,游戏粉长期收网赚粉 QQ8904040寻引流高手合作/1万粉以下勿扰██████五年推广█邮件代发█
公司实力收引流软件渠道█拨号VPS服务器4元/天免费测试█无限收学生粉,宝妈,女性粉,游戏粉实力团队收网赚粉入群找管理寻引流高手合作/1万粉以下勿扰大量收微信扫码进群男粉2820301656
公司实力收引流软件渠道███高价收购任何粉QQ84888591█无限收学生粉,宝妈,女性粉,游戏粉实力团队收网赚粉入群找管理寻引流高手合作/1万粉以下勿扰高价收网吧量联系QQ1908886662
〓〓〓收粉〓〓〓工作室出-交友粉-速度快-产量高无限收学生粉,宝妈,女性粉,游戏粉实力出粉,诚心来谈,眼子勿扰寻引流高手合作/1万粉以下勿扰高价收网吧量家庭量q2221333978
出精准网赚粉兼职粉
出售QQ群fa网赚精准粉 QQ13395509
无限收学生粉,宝妈,女性粉,游戏粉出抖音热门WZ精准粉Q159907寻引流高手合作/1万粉以下勿扰常年出精准粉 认证空间粉 加群量
来上微信QQ粉了加Q5555650群fa短信 95达到率无限收学生粉,宝妈,女性粉,游戏粉每天大量出邮箱交友粉,求稳定客户我要租广告位集团超高价收量QQ: 7305830
查看: 674|回复: 9
收起左侧

[已解决] 各路大神快来围观,重大技术问题,求解

 关闭 [复制链接]
结帖率:100% (4/4)
发表于 2018-7-12 22:25:50 | 显示全部楼层 |阅读模式
9精币
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟1.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
结果 = 结果 + 到文本 (数组 [随机位置])
如果真 (取文本长度 (结果) < 2)
结果 = “0” + 结果
如果真 (取文本长度 (结果) > 2)
结果 = 取文本右边 (结果, 20)
结果 = 结果 + “,”
' ’输出调试文本 (结果)
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()
子程序名返回值类型公开备 注
_时钟1_周期事件  
_按钮1_被单击 ()

图片

图片

最佳答案

查看完整内容

[e=4].版本 2 .子程序 _按钮1_被单击 时钟2.时钟周期 = 2000 .子程序 _时钟2_周期事件 .局部变量 数组, 整数型, , "0" .局部变量 计次变量, 整数型 .局部变量 随机位置, 整数型 .局部变量 数量, 整数型 .局部变量 结果, 文本型 .局部变量 经过, 整数型 数量 = 8 .计次循环首 (10, 计次变量) 加入成员 (数组, 计次变量) .计次循环尾 () .计次循环首 (数量, 计次变量) 置随机数种子 () 随机位 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:90% (9/10)
发表于 2018-7-12 22:42:15 | 显示全部楼层
  
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟2.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
如果 (数组 [随机位置] < 10)
结果 = 结果 + “0”到文本 (数组 [随机位置])“,”
结果 = 结果 + 到文本 (数组 [随机位置])“,”
编辑框1.内容 = 取文本左边 (结果, 取文本长度 (结果) - 1)
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 1好评 +1 精币 +1 收起 理由
1636848518 + 1 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:90% (9/10)
发表于 2018-7-12 22:25:51 | 显示全部楼层
  
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟2.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
如果 (数组 [随机位置] < 10)
结果 = 结果 + “0”到文本 (数组 [随机位置])“,”
结果 = 结果 + 到文本 (数组 [随机位置])“,”
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 2好评 +1 精币 +1 荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!
1636848518 + 1 + 1 大神,请收下我的膝盖

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:100% (5/5)
发表于 2018-7-12 22:34:18 | 显示全部楼层
还以为是什么大问题呢,弄这么个标题
你自己调试看吧,只有第一次的时候 "结果" 这个变量长度小于2
你的那个变量在不断的累加

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-7-12 22:35:59 | 显示全部楼层
因为这句代码:
  
结果 = 结果 + 到文本 (数组 [随机位置])

这里的结果,不是单单的数字,而是整个字符串。比如:
第一次:结果的值为6
但是第二次累加后,为06,1
超过2个字符了,所以不加前缀0了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 18 天

结帖率:100% (3/3)
发表于 2018-7-12 22:37:19 | 显示全部楼层
二楼已经解答了
解决方法就是弄一个临时的变量如数值内容
然后比较 取文本长度(数值内容)>2比较
然后再是 结果=结果+数值内容

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-7-12 22:38:11 | 显示全部楼层
  
窗口程序集名保 留  保 留备 注
窗口程序集_启动窗口   
子程序名返回值类型公开备 注
_按钮1_被单击  
时钟1.时钟周期 = 2000
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))

a=到文本 (数组 [随机位置])
如果真 (取文本长度 (a) < 2)
结果 = “0” + a
如果真 (取文本长度 (a) > 2)
a = 取文本右边 (a, 20)
结果 = 结果 + a
结果 = 结果 + “,”
' ’输出调试文本 (结果)
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()
子程序名返回值类型公开备 注
_时钟1_周期事件  
_按钮1_被单击 ()


可以这么改!

评分

参与人数 1精币 +1 收起 理由
1636848518 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 8 天

结帖率:100% (3/3)
发表于 2018-7-12 22:55:46 | 显示全部楼层
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

时钟2.时钟周期 = 2000

.子程序 _时钟2_周期事件
.局部变量 数组, 整数型, , "0"
.局部变量 计次变量, 整数型
.局部变量 随机位置, 整数型
.局部变量 数量, 整数型
.局部变量 结果, 文本型, , "0"
.局部变量 中间结果, 文本型
.局部变量 最终文本, 文本型
.局部变量 经过, 整数型
.局部变量 i, 整数型

数量 = 8
.计次循环首 (10, 计次变量)
    加入成员 (数组, 计次变量)
.计次循环尾 ()
调试输出 (数组)
置随机数种子 ()
.计次循环首 (数量, 计次变量)
    随机位置 = 取随机数 (1, 取数组成员数 (数组))
    中间结果 = 到文本 (数组 [随机位置])
    .如果真 (取文本长度 (中间结果) < 2)
        中间结果 = “0” + 中间结果
    .如果真结束
    .如果真 (取文本长度 (中间结果) > 2)
        中间结果 = 取文本右边 (中间结果, 2)
    .如果真结束
    加入成员 (结果, 中间结果)
.计次循环尾 ()
.计次循环首 (数量, i)
    最终文本 = 最终文本 + 结果 [i] + “,”
.计次循环尾 ()
编辑框1.内容 = 最终文本
删除成员 (数组, 随机位置, 1)


.子程序 _时钟1_周期事件

_按钮1_被单击 ()

‘还有就是你到底是要一步一步套源码还是什么意思?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 19 天

结帖率:100% (2/2)
发表于 2018-7-12 22:59:30 | 显示全部楼层
  
子程序名返回值类型公开备 注
_时钟2_周期事件  
变量名类 型静态数组备 注
数组整数型 0
计次变量整数型  
随机位置整数型  
数量整数型  
结果文本型  
经过整数型  
局部文本型  
数量 = 8
计次循环首 (10, 计次变量)
加入成员 (数组, 计次变量)
计次循环尾 ()
计次循环首 (数量, 计次变量)
置随机数种子 ()
随机位置 = 取随机数 (1, 取数组成员数 (数组))
局部 = 到文本 (数组 [随机位置])
如果真 (取文本长度 (局部) < 2)
局部 = “0” + 局部
如果真 (取文本长度 (局部) > 2)
局部 = 取文本右边 (局部, 2)
结果 = 结果 + 局部
如果真 (计次变量 < 数量)
结果 = 结果 + “,”
编辑框1.内容 = 结果
删除成员 (数组, 随机位置, 1)
计次循环尾 ()

评分

参与人数 1精币 +1 收起 理由
1636848518 + 1 支持开源~!感谢分享

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 19 天

结帖率:100% (15/15)
发表于 2018-7-12 23:56:55 | 显示全部楼层
跟你说吧 1你这个 属于 累加  所以

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表