精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
全国PPTP秒换IP 动态IP仅35元/月火眼答题-韩文日文-高质量答题长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件┏█收购一切流量Q:503830000█┓
云速打码全天50%分成★稳定★快速▇QQ新科技软件▇随时更新▇长期 包养全网交友粉大户★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
诺宾混拨动态vps/PPTP多地区换IP█IP精灵█最强大的动态IP加速器各种【活粉变现点这里】客服①长期出QQ群QQ号微信精准粉网挣粉找软件作者合作/收购引流软件大量租售各种qq小号 2892721932
┏ 集团收量,高价无限收一切量 ┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短视频引流,直播平台粉┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:各大招聘网站一手简历 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短信、邮箱qun发通道 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┗ 收粉:网赚粉/精准粉,交友粉 ┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┏公司实力高价 收 引流软件渠道┓收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山██实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 ██实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱██实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉██收快手火山虎牙,找我换钱██实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力高价 收 引流软件渠道┃大量收精准粉██长期大量收粉量大量小都吃██实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉██ 婚恋/抖音/宝妈/空间/快手██★高薪诚聘SEO大牛 高价买任何量★寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量有质量,找我换钱███★高薪诚聘SEO大牛 高价买任何量★寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███实力大型公司收媒体量███★高薪诚聘SEO大牛 高价买任何量★寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███大量资金,来一手代理███★高薪诚聘SEO大牛 高价买任何量★寻求有项目的大神合作收精准粉、用户量、也可联运营
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量就有钱,速度来撩███★高薪诚聘SEO大牛 高价买任何量★寻求有项目的大神合作收精准粉、用户量、也可联运营
┃公司最高价收 邮件qun发软件┃█长期大量收购各种活粉█┃  全网大量收  ┃███各类QQ小号███寻求有项目的大神合作收精准粉、用户量、也可联运营
┃公司最高价收 邮件qun发软件┃█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃███各类QQ小号███寻求有项目的大神合作收精准粉、用户量、也可联运营
┃公司最高价收 邮件qun发软件┃大量微信寻合作 接各种扫码授权┃   网赚粉   ┃收抖音火山王者引流:1513888885寻求有项目的大神合作收精准粉、用户量、也可联运营
┃公司最高价收 邮件qun发软件┃大量出2年以上三无QQ 可秒绑微信┃   游戏粉   ┃收抖音火山王者引流:1513888885寻求有项目的大神合作收精准粉、用户量、也可联运营
┗公司最高价收 邮件qun发软件┛▇ 1卡绑10QQ 0月租 10张包邮 ▇┃   婚恋粉   ┃┃找邮件代发,邮件群发通道┃寻求有项目的大神合作收精准粉、用户量、也可联运营
██---收网吧量exe下发量---██收男粉微信扫码进群QQ1324888881┃  各种活人粉  ┃找QQ群,微博,微信朋友圈广告推广寻求有项目的大神合作收精准粉、用户量、也可联运营
██-----收PC量 下载站量-----██大量收男粉扫码进群QQ1324888881 ┃   短视频粉  ┃代发短信+邮件寻求有项目的大神合作收精准粉、用户量、也可联运营
██ 欢迎QQ产品类作者私聊 ██☆收微信公众号粉丝.日结┃ 全网最高单价收购 ┃代发短信+邮件寻求有项目的大神合作收精准粉、用户量、也可联运营
██完全无投诉静默不影响产品██☆收微信公众号粉丝.日结寻求 媒体量合作 有资源的撩我代发短信+邮件寻引流高手合作/1万粉以下勿扰十年暴利项目实地考察+上门服务
██日收入几K至1W+ 正规用途██☆收微信公众号粉丝.日结寻求 媒体量合作 有资源的撩我代发短信+邮件寻引流高手合作/1万粉以下勿扰十年暴利项目实地考察+上门服务
量收微信扫码进群粉,实力粉商来撩☆收微信公众号粉丝.日结寻求 媒体量合作 有资源的撩我代发短信+邮件寻引流高手合作/1万粉以下勿扰十年暴利项目实地考察+上门服务
量收微信扫码进群粉,实力粉商来撩出少量网赚粉+微信:qunfa000寻求 媒体量合作 有资源的撩我██ 日出大量网赚粉/交友粉 ██寻引流高手合作/1万粉以下勿扰高价收网吧量联系QQ2088724059
量收微信扫码进群粉,实力粉商来撩出少量网赚粉+微信:qunfa000寻求 媒体量合作 有资源的撩我寻网吧端,下载站,各种端合作寻引流高手合作/1万粉以下勿扰★长期收购各种粉★引流软件★
★动态S5.可换地区可混拨可定时★收购跳转微信QQ加粉量Q88128851大量出活令牌处号一个月号出精准粉,量大来谈寻引流高手合作/1万粉以下勿扰====QQ小号====
GPK AG OG流量交流群出兼职粉有实力的来大量出活令牌处号一个月号大量收微信男粉QQ249813919寻引流高手合作/1万粉以下勿扰收大量微信裂变粉Q2820301656
█全新处Q██活令牌Q██邮箱Q██拨号VPS服务器4元/天免费测试█大量出活令牌处号一个月号出兼职,网赚,交友粉,扫码进群寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 627|回复: 3
收起左侧

[已解决] 求大神帮忙把C语言串口校验和,转易语言。

 关闭 [复制链接]

签到天数:6 天

结帖率:87% (13/15)
发表于 2018-7-11 23:55:20 | 显示全部楼层 |阅读模式
20精币
各位老爷,新手帖就是来求助的。奉上我的20jb,对于我来说,这可是大出血,希望各位老爷见谅。

刚刚在官方论坛上发了个求助,没人看,估计没有啥人qi。

QQ截图20180711231456.jpg

完整的数据  :01 0B A8 20 2A 01 E8 03 00 00 BD     其中最后的BD就是校验和。

官方的给的校验和计算如下,在下才疏学浅无法把它转成易语言。希望好心的大爷帮帮忙!


校验和是从包的第一个字节到第包长减一个字节的异或值,最后取反,也就是从第一个字节到倒数第二个字节的
异或值,最后取反。例如数据存储在数组Buf中(C语言),包长度存储在数组的第二个字节Buf[1]中,校验和存
放在数组的最后一个字节中Buf[Buf[1]-1];
charchecksum;
char
i;
checksum=0;
for(I=0;I<(Buf[1]-1);i++)
{
Checksum
^=Buf;//异或
}
Buf[Buf[1]-1]
=
~Checksum;
//按位取反




感谢!感谢!感谢!

最佳答案

查看完整内容

* 字节集:11{1,11,168,32,42,1,232,3,0,0,189} * “我们计算的校验值:” | 189 | “是否正确:” | 真

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 22 天

发表于 2018-7-11 23:55:21 | 显示全部楼层



  1. .版本 2
  2. .支持库 spec

  3. .子程序 _按钮1_被单击
  4. .局部变量 arr, 字节集
  5. .局部变量 i, 整数型
  6. .局部变量 checkSum, 整数型
  7. .局部变量 字节, 字节型

  8. arr = 字节集_十六进制到字节集 (子文本替换 (“01 0B A8 20 2A 01 E8 03 00 00 BD”, “ ”, “”, , , 真))
  9. 调试输出 (arr)
  10. .计次循环首 (arr [2] - 1, i)
  11.     checkSum = 位异或 (checkSum, 到整数 (arr [i]))
  12. .计次循环尾 ()
  13. ' 输出我们计算的校验值。
  14. 字节 = 位与 (位取反 (checkSum), 255)  ' 与上 255     保证 正值
  15. 调试输出 (“我们计算的校验值:”, 字节, “是否正确:”, 字节 = 189)
复制代码


* 字节集:11{1,11,168,32,42,1,232,3,0,0,189}
* “我们计算的校验值:” | 189 | “是否正确:” | 真

您可以选择打赏方式支持他

打赏

打赏

参与人数 1 打赏积分 理由 收起 打赏时间
小小七 +200   精币 可以用,谢谢。 2018-7-12 09:10

查看全部打赏

回复

使用道具 举报

签到天数: 12 天

结帖率:100% (37/37)
发表于 2018-7-12 06:39:39 | 显示全部楼层
是把代码写成易语言形式吗?

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 6 天

结帖率:87% (13/15)
 楼主| 发表于 2018-7-12 08:46:31 | 显示全部楼层
赤梦 发表于 2018-7-12 06:39
是把代码写成易语言形式吗?

可以的。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /2 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表