精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

订阅<精易模块>源码2018年好项目,每月多挣好多钱【收粉\卖粉\交易①群】┏ 12核24线程 , 模拟器24开 ┓找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱【收粉/卖粉/交易①群】┃ 单进程单IP,最低15元一天 ┃找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
若快打码 快速★准确★稳定★便宜全国PPTP秒换IP 动态IP仅35元/月【收粉\卖粉\交易①群】┗新增E3/16G/750TI最低10元┛找软件作者合作/收购引流软件火眼答题-韩文日文-高质量答题
┏█收购一切流量Q:503830000█┓云速打码全天50%分成★稳定★快速【收粉/卖粉/交易①群】★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
▇QQ新科技软件▇随时更新▇诺宾混拨动态vps/PPTP多地区换IP【脚本/软件/协议/变现群】█IP精灵█最强大的动态IP加速器找软件作者合作/收购引流软件██5年老店大量售各种一手QQ██
┏无限收各种推广资源,推广渠道┓╔ 收粉丶卖粉丶大型①群 ╗【脚本\软件\协议\变现群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收小视频引流,直播平台粉 ┃收粉丶卖粉丶大型①群【收粉\卖粉\交易②群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃   收交友粉/网赚粉/精准粉  ┃收粉丶卖粉丶大型①群【收粉/卖粉/交易②群】高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收QQ邮箱流量 邮件发送通道 ┃收粉丶卖粉丶大型①群【收粉\卖粉\交易②群】高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┗收QQ群发,微信朋友圈广告代发┛收粉丶卖粉丶大型①群【收粉/卖粉/交易②群】高价收购任何微信QQ粉寻求有项目的大神合作 收快手火山抖音 小视频引流
┏公司实力高价 收 引流软件渠道┓收粉丶卖粉丶大型①群【脚本/软件/协议/变现群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃收粉丶卖粉丶大型①群【脚本\软件\协议\变现群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃╚ 收粉丶卖粉丶大型①群 ╝【收粉\卖粉\交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉【收粉/卖粉/交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力高价 收 引流软件渠道┃大量收精准粉【收粉\卖粉\交易③群】实力公司日消耗大量QQ粉有货MM寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【收粉/卖粉/交易③群】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【重金求各种作者】┃ 小发卡自助发卡平台 ┃寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉【重金求各种作者】██高价收引流软件Q918213529██寻求有项目的大神合作收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉大量现金收【各种粉】██高价收引流软件Q918213529██寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃公司实力收 qun 发 邮箱软件 ┃█长期大量收购各种活粉█大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃公司实力收 qun 发 邮箱软件 ┃█ 长期收购各种引流软件 █大量现金收【各种粉】全网重金收各种资源流量QQ:868333寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃公司实力收 qun 发 邮箱软件 ┃██ 当天处Q 三无Q 带售后 ██大量现金收【各种粉】
 全网重金收各种资源流量QQ:868333 
寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃公司实力收 qun 发 邮箱软件 ┃██ 当天处Q 三无Q 带售后 ██大量现金收【各种粉】
 全网重金收各种资源流量QQ:868333 
寻求有项目的大神合作██出网赚粉、精准粉、流量███
┗公司实力收 qun 发 邮箱软件 ┛██  量大出微博小号  ██大量现金收【各种粉】大量收微信男粉QQ 2820301656寻求有项目的大神合作██出网赚粉、精准粉、流量███
★高价收站群量CPS日结★大量收国外隔天号交友粉1324888881大量现金收【各种粉】大量收微信男粉QQ 1289624992寻求有项目的大神合作██出网赚粉、精准粉、流量███
★高价收站群量CPS日结★大量收男粉扫码进群QQ1324888881 大量现金收【各种粉】收抖音火山王者引流:1513888885寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃ 全新QQ一手批发 ┃日出大量男粉加Q群微信出精准网赚粉大量现金收【各种粉】收抖音火山王者引流:1513888885寻求有项目的大神合作██出网赚粉、精准粉、流量███
┃ 全新QQ一手批发 ┃日出大量男粉加Q群微信出精准网赚粉大量现金收【各种粉】收QQ邮箱流量 邮件发送通道 寻引流高手合作/1万粉以下勿扰【导群,微信通讯录加粉打群】
███各类QQ小号███长期出QQ群QQ号微信精准粉网挣粉大量现金收【各种粉】收微博 QQ群 朋友圈广告代发寻引流高手合作/1万粉以下勿扰
【导群,打小群40人,微信粉】
大量租售各种qq小号 2892721932日出大量网赚粉微信QQ各行精准活粉大量现金收【各种粉】██ 日出大量网赚粉/交友粉 ██寻引流高手合作/1万粉以下勿扰API日流水18万,长效稳定S5,HTTPS
██=收网赚粉=█=收网赚粉=█████大量出租一手QQ粉███大量现金收【各种粉】出微信qq交友粉网赚粉精准粉兼职寻引流高手合作/1万粉以下勿扰抖音/微视/快手/小红书▇自助点赞
高价收网吧量联系QQ2088724059收兼职粉大量现金收【各种粉】【收】抖音/快手/微博等软件寻引流高手合作/1万粉以下勿扰寻网吧端,下载站,各种端合作
【收】引流软件/网赚兼职粉/男粉收各类交友粉等流量,微信:qunfa000大量短信接发码寻作者及老板合作█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰出兼职,网赚,交友粉,微信拉群
有精准粉.交友粉.男粉.年龄大
████大量收top域名████大量短信接发码寻作者及老板合作出微信精准好友+微信:41752088寻引流高手合作/1万粉以下勿扰★动态S5.可换地区可混拨可定时★
█流量大手交流群:734505645█收购跳转微信QQ加粉量Q88128851大量短信接发码寻作者及老板合作收所有量  QQ:741188920寻引流高手合作/1万粉以下勿扰 我要租广告位
查看: 375|回复: 4
收起左侧

[已解决] 问大家一个逻辑性比较强的算式

 关闭 [复制链接]

签到天数:9 天

结帖率:95% (21/22)
发表于 2018-5-16 21:15:44 | 显示全部楼层 |阅读模式
5精币
比如:已知,数字7我要生成5个1-99随机数  然后加起来尾数7这种情况 该怎么写代码。。
例如:
已知   9 生成5个1-99随机数字 1,9,11,14,15,19  相加    1+9+11+14+15+19=69     结果为 69的尾数是9   也就是已知数 9

最佳答案

查看完整内容

补充内容 (2018-5-16 21:28): 忘记判断位数了,你自己改

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 2 天

结帖率:100% (10/10)
发表于 2018-5-16 21:15:45 | 显示全部楼层
demo.e (3.46 KB, 下载次数: 8)

点评

运行好像不对  发表于 2018-5-16 23:28

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 6 天

结帖率:50% (2/4)
发表于 2018-5-16 21:29:01 | 显示全部楼层
可以前面的四个数是随机生成,最后一个数是半随机生成。。。。。。。比如前四个数的个位数相加为5,那第五位数就是在个位是4+10*(1-10随机)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 19 天

结帖率:100% (8/8)
发表于 2018-5-16 22:31:02 | 显示全部楼层
.版本 2
.支持库 spec

.子程序 __启动窗口_创建完毕
.局部变量 数组, 整数型, , "0"

定尾数随机和 (5, 7, 数组)
调试输出 (数组)

.子程序 定尾数随机和, 整数型
.参数 随机个数, 整数型
.参数 指定尾数, 整数型
.参数 数组, 整数型, 参考 数组
.局部变量 总和, 整数型
.局部变量 m, 整数型
.局部变量 n, 整数型

置随机数种子 ()
.循环判断首 ()
    总和 = 0
    清除数组 (数组)
    .计次循环首 (随机个数, m)
        n = 取随机数 (1, 99)
        加入成员 (数组, n)
        总和 = 总和 + n
    .计次循环尾 ()
    .如果真 (总和 % 10 = 指定尾数)
        跳出循环 ()
    .如果真结束

.循环判断尾 (总和 % 10 ≠ 指定尾数)
返回 (取数组成员数 (数组))


补充内容 (2018-5-16 22:33):
子程序,其实不需要设置返回值,多余了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表