精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
全国PPTP秒换IP 动态IP仅35元/月火眼答题-韩文日文-高质量答题长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件┏█收购一切流量Q:503830000█┓
云速打码全天50%分成★稳定★快速▇▇QQ方面最新软件▇▇长期 包养全网交友粉大户★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
诺宾混拨动态vps/PPTP多地区换IP长期出QQ群QQ号微信精准粉网挣粉各种【活粉变现点这里】客服①大量租售各种qq小号 2892721932找软件作者合作/收购引流软件出王者交友粉,k歌粉 成品Q群
┏ 集团收量,高价无限收一切量 ┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短视频引流,直播平台粉┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:各大招聘网站一手简历 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短信、邮箱qun发通道 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉实力团队大量收粉入群找管理大量收QQ活粉交友粉
┗ 收粉:网赚粉/精准粉,交友粉 ┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉实力团队大量收粉入群找管理大量收QQ活粉交友粉
┏公司实力高价 收 引流软件渠道┓收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 ██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉██收快手火山虎牙,找我换钱██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉██长期大量收粉量大量小都吃██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉██ 婚恋/抖音/宝妈/空间/快手█████大量全新令牌QQ███实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量有质量,找我换钱██████大量全新令牌QQ███实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███实力大型公司收媒体量███收抖音火山王者引流:1513888885实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███大量资金,来一手代理███收抖音火山王者引流:1513888885实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量就有钱,速度来撩███实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司最高价收 邮件qun发软件┃█长期大量收购各种活粉█┃  全网大量收  ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█
┃公司最高价收 邮件qun发软件┃█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█
┃公司最高价收 邮件qun发软件┃大量微信寻合作 接各种扫码授权┃   网赚粉   ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█
┃公司最高价收 邮件qun发软件┃▇大量批发高质量QQ处号9位10位▇┃   游戏粉   ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█
┗公司最高价收 邮件qun发软件┛▇大量批发高质量QQ处号9位10位▇┃   婚恋粉   ┃『实力收扫码进群量』实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█
收男粉微信扫码进群QQ1324888881 ┃  各种活人粉  ┃『你量真,我需求大』实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█大量收男粉扫码进群QQ1324888881
┃   短视频粉  ┃『 你不乱,我不断 』实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█一一一一一收qq老接口一一一一一┃ 全网最高单价收购 ┃
『欢迎实力粉商来撩』
实力团队大量收粉入群找管理█高价收运营商量和百度竞价量█出少量网赚粉+微信:qunfa000一一一一一收qq老接口一一一一一寻求 媒体量合作 有资源的撩我
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰█高价收运营商量和百度竞价量█出少量网赚粉+微信:qunfa000出兼职,网赚,交友粉,扫码进群寻求 媒体量合作 有资源的撩我
★长期收网赚粉★流量.引流软件★寻引流高手合作/1万粉以下勿扰█高价收运营商量和百度竞价量█●国内外动态socks5 可API控制●指定群发精准网赚粉 合作来谈寻求 媒体量合作 有资源的撩我
提供聚合支付系统源码+售后寻引流高手合作/1万粉以下勿扰出兼职粉有实力的来大量收微信男粉QQ249813919█全新处Q██活令牌Q██邮箱Q█寻求 媒体量合作 有资源的撩我
█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰出各种精准粉QQ:1955599983出微信qq交友粉网赚粉精准粉兼职大量出探探交友粉联系Q1962626235寻求 媒体量合作 有资源的撩我
寻渠道,收网盟量 Q:1561032994寻引流高手合作/1万粉以下勿扰█微博全新█4级白号█0.18/个█出售/网赚粉兼职粉精准粉/质量第一██ 出微信女粉/可项目合作 ██大量出活令牌处号一个月号
高价收网赚粉 / 兼职粉,平台不限寻引流高手合作/1万粉以下勿扰★高价收网赚兼职粉,引流软件★大量出qq邮箱推广引流qq950092█IP精灵█最强大的动态IP加速器大量出活令牌处号一个月号
q空间转发直发精准网赚粉:q771112寻引流高手合作/1万粉以下勿扰
 ██QQ小号1毛钱/太阳Q/各类QQ██
大量出网赚粉/各种粉/各类用户资源出高质量微信男粉QQ:644949998大量出活令牌处号一个月号
出网赚粉兼职粉各种男女粉寻引流高手合作/1万粉以下勿扰我要租广告位   
12
返回列表
楼主: 旧之
收起左侧

[易求助] 如何将文本分割并分割成几部分?

[复制链接]
结帖率:80% (4/5)
 楼主| 发表于 2018-5-16 20:12:54 | 显示全部楼层
yihrmc1 发表于 2018-5-16 19:57
你可以考虑用js执行一下,直接得到结果

可以发个例程吗 不会用e跑js

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-5-16 20:17:57 | 显示全部楼层
旧之 发表于 2018-5-16 20:12
可以发个例程吗 不会用e跑js

那你还是继续用文本分割吧

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-5-16 20:28:16 | 显示全部楼层
第一步:
寻找文本"L",记录位置,起始位置是上一次寻找文本"="的位置+1或0
寻找文本"=",记录位置,起始位置是上一次寻找文本"="的位置+1或0

然后接可以截取 L到=的数字了;
接着继续寻找文本,依次类推,截取

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:80% (4/5)
 楼主| 发表于 2018-5-16 22:48:59 | 显示全部楼层
yihrmc1 发表于 2018-5-16 20:28
第一步:
寻找文本"L",记录位置,起始位置是上一次寻找文本"="的位置+1或0
寻找文本"=",记录位置,起始 ...

可是有很多重复的呀

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-5-25 16:52:04 | 显示全部楼层
旧之 发表于 2018-5-16 22:48
可是有很多重复的呀

全部数据发一下

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-5-25 18:57:05 | 显示全部楼层
老铁我又回来了,帮你解决了,我先吃饭,等会发源码给你

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-5-25 20:57:31 | 显示全部楼层
OK了,下载测试吧

  1. .版本 2

  2. .子程序 Yihrmc高级截取文本, 逻辑型
  3. .参数 被截取文本, 文本型
  4. .参数 前文本组, 文本型, 数组
  5. .参数 后文本组, 文本型, 数组
  6. .参数 返回数据组, 文本型, 参考 数组, 二维数组
  7. .参数 是否不区分大小写, 逻辑型
  8. .局部变量 i, 整数型
  9. .局部变量 n, 整数型
  10. .局部变量 next, 逻辑型
  11. .局部变量 l, 整数型
  12. .局部变量 r, 整数型
  13. .局部变量 结果组, 文本型, , "0"
  14. .局部变量 全部结果组, 文本型, , "0"

  15. .如果真 (取数组成员数 (前文本组) ≠ 取数组成员数 (后文本组))  ' 一定要数量对应
  16.     返回 (假)
  17. .如果真结束
  18. l = 0
  19. r = 0
  20. n = 0
  21. .循环判断首 ()
  22.     next = 假
  23.     清除数组 (结果组)
  24.     .计次循环首 (取数组成员数 (前文本组), i)
  25.         l = 寻找文本 (被截取文本, 前文本组 [i], r, 是否不区分大小写)
  26.         .如果真 (l = -1)
  27.             跳出循环 ()
  28.         .如果真结束
  29.         r = 寻找文本 (被截取文本, 后文本组 [i], l, 是否不区分大小写)
  30.         .如果真 (r = -1)
  31.             跳出循环 ()
  32.         .如果真结束
  33.         加入成员 (结果组, 取文本中间 (被截取文本, l + 取文本长度 (前文本组 [i]), r - l - 取文本长度 (前文本组 [i])))
  34.         next = 真
  35.     .计次循环尾 ()
  36.     .如果真 (取数组成员数 (结果组) = 取数组成员数 (前文本组))  ' 所有的截取文本都要有结果
  37.         n = n + 1
  38.         重定义数组 (全部结果组, 真, n, 取数组成员数 (结果组))
  39.         .计次循环首 (取数组成员数 (结果组), i)
  40.             全部结果组 [n] [i] = 结果组 [i]
  41.         .计次循环尾 ()
  42.     .如果真结束

  43. .循环判断尾 (next)
  44. 返回数据组 = 全部结果组
  45. 返回 (真)
复制代码



高级截取文本.e

6.59 KB, 下载次数: 1

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表