精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱┃ 服务器出租E3单路E5双路E5 ┃ 长期 包养全网交友粉大户高价收购QQ单项双向好友日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
2019年好项目,每月多挣好多钱┃ 模拟器虚拟机多开! 单进程 ┃长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█长期大量收购各种活粉█长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道█ 长期收购各种引流软件 █长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①高价包养交友粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①实力公司大量收粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
寻找有实力的短信群fa通道寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服①交友粉 婚恋粉 各种活粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群无限收各种引流资源寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服②另收土豆社交APP活粉日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群无限收精准网赚资源寻有实力的短信群fa通道加Q525253各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群免费帮对接担保交易实力收精准粉大量稳定加Q525253各种【活粉变现点这里】客服②无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群欢迎买卖方进群合作实力收精准粉大量稳定加Q525253┏┏ 全网大量收交友粉 ┓┓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
星盟社群免费帮对接渠道资源实力收精准粉大量稳定加Q525253〓 各种APP交友粉 〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█    高 收 益 项 目   █实力收精准粉大量稳定加Q525253〓  抖音 快手 火山  〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█     耗资巨大    █实力收精准粉大量稳定加Q525253〓   附 近 人    〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█     市场最牛    █★★★出售抖音网赚精准粉 Q317738〓 各论坛美拍部落 〓无限收交友粉 引流软件 qq7305830日吃8000+收一手零转化微信小群粉高价收购【全部行业精准粉】进群!
█   支 持     日 结  █★★★出售抖音网赚精准粉 Q317738〓各种活人粉实力对接〓无限收交友粉 引流软件 qq7305830高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█  咨询QQ   880194  █★█实力收精准粉QQ825270505█★〓大小量通吃欢迎来撩〓无限收交友粉 引流软件 qq7305830高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作██收精准引流粉,微信公众号粉█〓 稳定全年365天收 〓无限收交友粉 引流软件 qq7305830高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作██收精准引流粉,微信公众号粉█〓 无限 收交友粉 〓收男女粉+q53779879高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作██收精准引流粉,微信公众号粉█┗┗ 全网最高单价收粉 ┛┛收男女粉+q53779879高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█★█实力收精准粉QQ825270505█★◆大量收婚恋宝妈快手火山◆收收收大量宝妈粉QQ289259高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█公司实力寻引流高手商务合作█【实力公司无限收各种思路引流活粉】◇稳定收交友粉,找我换钱◇收收收.微信扫码进群.加QQ9703796高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 █↑↑↑↑↑↑↑↑↑加QQ:575199999◆收快手火山虎牙找我换钱◆鼎信社群高价收WZ各类热门资源高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 实力公司 长期有效 ██◇长期收交友粉大小量通吃◇鼎信社万人对接基地高效出粉收粉高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 引流软件 ██◆ 婚恋/抖音/空间/快手 ◆███ 鼎信社群 行业顶尖 ███高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 引流脚本 ██◇ 优质有量的找我换钱 ◇鼎信社群欢迎各类 商人对接入驻高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
█ 公司 高价 收 引流 软件 渠道 ███ 收收收收 引流思路 ██◆ 实力大型公司收媒体量 ◆鼎信社欢迎各类粉商精英对接交流高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
全网最高单价收粉QQ420073██ 收收收收 精准wz粉██◇ 大量资金 ,来一收代理 ◇█★█长期收购网赚精准粉█★█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
实力收购各种粉加QQ420073██ 收收收收 精 准 粉 ██◆ 无限收交友粉交友粉 ◆█★█长期收购网赚精准粉█★█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购精准兼职粉加QQ420073██ 收收收收 引流人才 ██◇ 各种活人粉实力对接 ◇高价收qq渠道,交友粉+q7042641高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购精准网赚粉加QQ420073██ 收收收收 引流方式 ██全网大量收各种APP交友粉,高价收qq渠道,交友粉+q7042641高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
收购软件渠道思路QQ420073██ 加qq群:839661627 ██包养全网交友粉大户█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
大量收微信进群粉联系q584121900██进群找管理 备注引流██全网大量收各种APP交友粉,█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
出微信qq交友粉网赚粉精准粉兼职长期出QQ群QQ号微信精准粉网挣粉包养全网交友粉大户█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
大量出各类精准用户粉,全行业私信出QQ群微信QQ号交友粉网赚粉兼职粉全网大量收各种APP交友粉,█收交友粉 价格美丽 只走担保█高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
限时限量出售高精准网赚粉★工作室长期出抖音WZ粉Q159907包养全网交友粉大户大量出QQ网赚粉微信粉Q群精准活粉高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
高价收网吧终端量联系Q1908886662█网站统计█I引流系统█I全网大量收各种APP交友粉,大量出wz粉质量好单价低QQ222561高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
Q群粉及交友一手资源Q:492544224940人的精准小群 /一手截图报表包养全网交友粉大户██████出精准网赚粉兼职粉高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
高价收微信进群活跃男粉Q858529686公司高价收购流量全网大量收各种APP交友粉,服务器出租E3-E5-单进程高价收购【全部行业精准粉】进群!高价收购【全部行业精准粉】进群!
软件开发商实力出QQ网赚粉兼职粉出游戏粉 游戏粉加Q245014016包养全网交友粉大户出Q群微信直播粉联系Q2604720501高价收购【全部行业精准粉】进群!我要租广告位
查看: 17803|回复: 494
收起左侧

[易语言模块源码] 易语言操作EXCEL的模块2

  [复制链接]

签到天数:14 天

结帖率:89% (32/36)
发表于 2018-3-8 17:41:46 | 显示全部楼层 |阅读模式
分享例程
界面截图:
备注说明: -
好久没用这个了,把我自己用的共享出来吧,比之前发的多很多命令,比如排序筛选设置数据透视表什么的,用法和之前的一样
PS:源码最下面的一些命令,我并没有测试,如果没有用,自己修改吧,如果公开那里没有打钩的,那基本是无效的,需要用也自己修改
我看一些人总纠结在切换工作表这个问题上,源码里面有切换工作表和切换工作薄的命令,自己用吧
另外,使用的时候注意参数和参数的备注,不要用E.读单元格文本(1).取文本()这样的命令,根本不是这样用
还有些人要求在线程或者内存中使用的,自己修改吧,可以的话发上来大家共享,我是没劲弄了
易语言操作EXCEK模块-加加1222修改.e (263.92 KB, 下载次数: 1891)

点评

很好,超级方便!  发表于 2018-3-10 21:24

评分

参与人数 1好评 +1 精币 +2 收起 理由
为你存在 + 1 + 2 新技能已get√

查看全部评分


友情提醒:请选择可信度高的模块,勿用未知模块,防止小人在模块内加入木马程序。【发现问题模块请到站务投诉】。

您可以选择打赏方式支持楼主

打赏

参与人数 2 打赏积分 理由 收起 打赏时间
倾风听雨声 +10   精币 小小心意,意思一下 2018-4-4 01:48
为你存在 +10   精币 很好,很方便!谢谢 2018-3-10 21:24

查看全部打赏

本帖被以下淘专辑推荐:

签到天数: 14 天

结帖率:89% (32/36)
 楼主| 发表于 2018-3-24 20:34:26 | 显示全部楼层
这里也加上例子吧,上一贴本来有的
首先将模块加载(自己将源码编译)
然后定义一个变量,例如“E”,类型为“EXCEL”
接下来是正式使用
E.创建()‘对EXCEL操作之前必须创建EXCEL对象
E.打开()’打开EXCEL文件
E.置单元格文本()‘对EXCEL操作
E.保存()’如果不需要保存可以跳过
E.关闭()‘操作完毕后注意要关闭,否则等于EXCEL放在那里

另外有一个代码“取行数列数”,是这样使用的,首先定义行数和列数这2个整数型变量,然后
E.取行数列数(行数,列数)
这样行数就取到了总行数,列数就取到了总列数
回复

使用道具 举报

签到天数: 14 天

结帖率:89% (32/36)
 楼主| 发表于 2019-1-15 22:33:56 | 显示全部楼层
本帖最后由 ttt0410 于 2019-1-15 22:35 编辑
靓123 发表于 2019-1-15 21:08
EXCEL.创建 () 返回假 怎么解决?

你们这种创建为假或者对象为空的,是变量有问题还是EXCEL没安装?还是版本问题,我只用过03和13,没这些情况
回复

使用道具 举报

签到天数: 2 天

发表于 3 天前 | 显示全部楼层
感谢楼主分享,不知道能不能用
回复

使用道具 举报

签到天数: 14 天

结帖率:89% (32/36)
 楼主| 发表于 2019-6-1 12:25:16 | 显示全部楼层
dhbdjl 发表于 2019-6-1 02:11
多线程创建问题总算解决了,用精易模块“线程_启动2”启动子程序,再在自编译子程序首部加入“线程_初始化C ...

线程使用本来就要初始化com库

而且不是有读单元格文本这个命令吗
回复

使用道具 举报

签到天数: 4 天

发表于 2019-6-1 02:11:17 | 显示全部楼层
本帖最后由 dhbdjl 于 2019-6-1 02:58 编辑

多线程创建问题总算解决了,用精易模块“线程_启动2”启动子程序,再在自编译子程序首部加入“线程_初始化COM库 () ”子程序,完美运行,感谢版主分享~~~
在此也分享下测试例子,希望可以帮到有需要的人~~
OFFICE2007读取例子:读EXCEL sheel1;第1,2,4列;第2。。。。。101行的表格数据
.版本 2
.子程序 测试读EXCEL, , ,

.局部变量 EX , 第三方_EXCEL类, , , 第三方编译类模块
.局部变量 EX行 , 整数型, , ,
.局部变量 变量1 ,文本型, , ,
.局部变量 变量2 ,文本型, , ,
.局部变量 变量3 ,文本型, , ,

.版本 2
        线程_初始化COM库 ()  ' 因多线程进行EXCEL操作时异常,加入子程序后才能稳定运行   
        EX行=1
        .如果 (EX.创建 () = 真)
            输出调试文本 (“ex创建成功”)
        .否则
            输出调试文本 (“ex创建失败”)
        .如果结束
        EX.打开 (“E:\**.xlsx”) '打开的excel文件路径
        EX.可视 (假) '(真)为可见
        计次循环首(100,)     
        EX行 = EX行 + 1
        变量1 = EX.读单元格数据 (1, EX行, 1).取文本 ()
        变量2 = EX.读单元格数据 (1, EX行, 2).取文本 ()
        变量3 = EX.读单元格数据 (1, EX行, 4).取文本 ()
        输出调试文本 (变量1 , 变量2, 变量3)
        计次循环尾()
        EX.关闭 ()




回复

使用道具 举报

签到天数: 4 天

发表于 2019-5-31 04:39:58 | 显示全部楼层
多线程创建时,有的时候可以创建成功,有的时候创建失败,有办法解决吗?
回复

使用道具 举报

发表于 2019-5-30 19:47:37 | 显示全部楼层
真是我需要的,非常感谢
回复

使用道具 举报

结帖率:100% (4/4)
发表于 2019-5-30 14:58:19 | 显示全部楼层
感谢分享,下载学习
回复

使用道具 举报

发表于 2019-5-16 22:07:32 | 显示全部楼层
谢谢楼主分享
回复

使用道具 举报

发表于 2019-5-15 08:50:57 | 显示全部楼层
下载一下,一枚金币,评论一下,一枚金币
回复

使用道具 举报

签到天数: 1 天

发表于 2019-5-14 09:46:16 | 显示全部楼层
                  
回复

使用道具 举报

签到天数: 3 天

发表于 2019-5-6 15:50:54 | 显示全部楼层
支持学习学习
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

发布主题 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表