精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月诺宾混拨动态vps/PPTP多地区换IP长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群长期 包养全网交友粉大户█全新处Q██活令牌Q██邮箱Q█找软件作者合作/收购引流软件出兼职粉大公司和量大的来
出微信qq交友粉网赚粉精准粉兼职█IP精灵█最强大的动态IP加速器各种【活粉变现点这里】客服①大量出网赚粉/各种粉/各类用户资源找软件作者合作/收购引流软件出高质量微信男粉QQ:644949998
┏集团收购:一手短信、邮箱群fa┓╔ 大量现金实力收真实粉 ╗各种【活粉变现点这里】客服①高价收购陌陌探探粉找软件作者合作/收购引流软件寻求实力团队
┃集团收购:一手短信、邮箱群fa┃ 日消耗X6一辆,无限收粉各种【活粉变现点这里】客服②高价收购陌陌探探粉找软件作者合作/收购引流软件高效率合作,
┃集团收购:,一手精准群发用户┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购陌陌探探粉找软件作者合作/收购引流软件欢迎来扰!!
┃集团收购:,一手精准群发用户┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购陌陌探探粉实力团队大量收粉入群找管理无限收任何量
┗集团收购:-爬取QQ达人会员号┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购陌陌探探粉实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█收粉丶卖粉丶大型①群██收婚恋粉宝妈粉,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█收粉丶卖粉丶大型①群██收快手火山虎牙,找我换钱██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█收粉丶卖粉丶大型①群██长期大量收粉量大量小都吃██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理拒绝骗子
█有量支持引QQ/Q群/微信█收粉丶卖粉丶大型①群██ 婚恋/抖音/宝妈/空间/快手██长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█欢迎实力来撩,点击进Q群█收粉丶卖粉丶大型①群███有量有质量,找我换钱███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█加星盟社群支持免费担保█收粉丶卖粉丶大型①群███实力大型公司收媒体量███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█无限收粉量真实长期合作█收粉丶卖粉丶大型①群███大量资金,来一手代理███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
█星盟社Q群号码868977025█╚ 全网实力最高单价收粉 ╝ ███有量就有钱,速度来撩███长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理无限收任何量
公司实力收引流软件渠道█长期大量收购各种活粉█┃  全网大量收  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   网赚粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
公司实力收引流软件渠道██████QQ处号██████┃   游戏粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道收项目┃   婚恋粉   ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
公司实力收引流软件渠道有需求找我┃  各种活人粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道出少量网赚粉+微信:qunfa000┃   短视频粉  ┃长期收交友粉,正规项目、稳定实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道出少量网赚粉+微信:qunfa000┃ 全网最高单价收购 ┃『实力收扫码进群量』实力团队大量收粉入群找管理大量收各类精准粉加Q2835414471
公司实力收引流软件渠道┃大量收粉.实力来撩 ┃寻求 媒体量合作 有资源的撩我『你量真,我需求大』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
公司实力收引流软件渠道┃   网赚粉   ┃ 寻求 媒体量合作 有资源的撩我『 你不乱,我不断 』寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
收购跳转微信QQ加粉量Q88128851┃   精准粉   ┃寻求 媒体量合作 有资源的撩我
『 →qq:12587210←』
寻引流高手合作/1万粉以下勿扰██别收粉了 最新引流技术███
大量收微信扫码进群男粉2820301656大量出网赚各种精准粉+Q402345寻求 媒体量合作 有资源的撩我
『欢迎实力粉商来撩』
寻引流高手合作/1万粉以下勿扰出Q群粉联系QQ:492544249
███大公司实力收优质wz量███出高质量家庭量说说 价高 寻求 媒体量合作 有资源的撩我
█实力公司收网赚兼职粉█
寻引流高手合作/1万粉以下勿扰出网赚粉 兼职粉
———专业邮件代发+Q166666736出微信国内老号,引流稳定不封。大量出活令牌处号一个月号█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰███大量全新令牌QQ███
收微信扫码进群男粉QQ:854122288出QQ群微信QQ号交友粉网赚粉兼职粉大量出活令牌处号一个月号百变IP-每日大量代理IP欢迎合作寻引流高手合作/1万粉以下勿扰收Q粉微信扫码进群qq:2591360085
短信群fa-三网爆卡-量足███QQ小号自动发货平台███大量出活令牌处号一个月号高价收网吧量联系QQ1908886662寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 11390|回复: 452
收起左侧

[易语言模块源码] 易语言操作EXCEL的模块2

  [复制链接]

签到天数:2 天

结帖率:33% (1/3)
发表于 2018-3-8 17:41:46 | 显示全部楼层 |阅读模式
分享例程
界面截图:
备注说明: -
好久没用这个了,把我自己用的共享出来吧,比之前发的多很多命令,比如排序筛选设置数据透视表什么的,用法和之前的一样
PS:源码最下面的一些命令,我并没有测试,如果没有用,自己修改吧,如果公开那里没有打钩的,那基本是无效的,需要用也自己修改
我看一些人总纠结在切换工作表这个问题上,源码里面有切换工作表和切换工作薄的命令,自己用吧
另外,使用的时候注意参数和参数的备注,不要用E.读单元格文本(1).取文本()这样的命令,根本不是这样用
还有些人要求在线程或者内存中使用的,自己修改吧,可以的话发上来大家共享,我是没劲弄了
易语言操作EXCEK模块-加加1222修改.e (263.92 KB, 下载次数: 1332)

点评

很好,超级方便!  发表于 2018-3-10 21:24

评分

参与人数 1好评 +1 精币 +2 收起 理由
为你存在 + 1 + 2 新技能已get√

查看全部评分


友情提醒:请选择可信度高的模块,勿用未知模块,防止小人在模块内加入木马程序。【发现问题模块请到站务投诉】。

您可以选择打赏方式支持楼主

打赏

参与人数 2 打赏积分 理由 收起 打赏时间
倾风听雨声 +10   精币 小小心意,意思一下 2018-4-4 01:48
为你存在 +10   精币 很好,很方便!谢谢 2018-3-10 21:24

查看全部打赏

本帖被以下淘专辑推荐:

签到天数: 2 天

结帖率:33% (1/3)
 楼主| 发表于 2018-3-24 20:34:26 | 显示全部楼层
这里也加上例子吧,上一贴本来有的
首先将模块加载(自己将源码编译)
然后定义一个变量,例如“E”,类型为“EXCEL”
接下来是正式使用
E.创建()‘对EXCEL操作之前必须创建EXCEL对象
E.打开()’打开EXCEL文件
E.置单元格文本()‘对EXCEL操作
E.保存()’如果不需要保存可以跳过
E.关闭()‘操作完毕后注意要关闭,否则等于EXCEL放在那里

另外有一个代码“取行数列数”,是这样使用的,首先定义行数和列数这2个整数型变量,然后
E.取行数列数(行数,列数)
这样行数就取到了总行数,列数就取到了总列数
回复

使用道具 举报

签到天数: 5 天

结帖率:77% (24/31)
发表于 7 天前 | 显示全部楼层
牛批啊楼主 感谢!
回复

使用道具 举报

发表于 2018-11-23 09:49:22 | 显示全部楼层
支持下楼主!
回复

使用道具 举报

发表于 2018-11-16 13:32:11 | 显示全部楼层
请问有办法控制表单控件吗?
回复

使用道具 举报

签到天数: 4 天

发表于 2018-11-14 16:20:35 | 显示全部楼层
比之前发的多很多命令
回复

使用道具 举报

发表于 2018-11-7 20:50:52 | 显示全部楼层
看看效果啊 ,怎么样,正好用
回复

使用道具 举报

签到天数: 2 天

发表于 2018-10-26 14:28:26 | 显示全部楼层
111111111111111111111111111111111
回复

使用道具 举报

签到天数: 3 天

发表于 2018-10-26 14:07:36 | 显示全部楼层
谢谢分享,支持开源
回复

使用道具 举报

签到天数: 2 天

结帖率:56% (5/9)
发表于 2018-10-22 12:04:07 | 显示全部楼层
.版本 2

.程序集 窗口程序集1
.程序集变量 E, EXCEL类

.子程序 _按钮1_被单击

E.创建 ()  ' 对EXCEL操作之前必须创建EXCEL对象
E.打开EXCEL (“D:\1.XLSX”)  ' 打开EXCEL文件
E.置单元格文本 (“A1”, “写入的文本”)  ' 对EXCEL操作
E.保存 ()  ' 如果不需要保存可以跳过
E.关闭 ()  ' 操作完毕后注意要关闭,否则等于EXCEL放在那里
请问一下,按照操作,一直提示“对象为空”,是为什么呢,诚心请教一下了。
回复

使用道具 举报

签到天数: 2 天

结帖率:56% (5/9)
发表于 2018-10-22 12:03:05 | 显示全部楼层
dfgtrhgt 发表于 2018-9-26 11:06
.版本 2

.程序集 窗口程序集1

你好,你的问题解决了吗,我也是一直按照操作,提示“对象为空”,和你的一模一样。
回复

使用道具 举报

签到天数: 2 天

结帖率:92% (54/59)
发表于 2018-10-20 20:54:20 | 显示全部楼层
不错不错 学习下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表