精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件██打码兔秒杀一切验证码██
若快打码 快速★准确★稳定★便宜2018年好项目,每月多挣好多钱长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件█打码兔答题 速度快 极稳定█
全国PPTP秒换IP 动态IP仅35元/月火眼答题-韩文日文-高质量答题长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件┏█收购一切流量Q:503830000█┓
云速打码全天50%分成★稳定★快速▇▇QQ方面最新软件▇▇长期 包养全网交友粉大户★滴滴答题★8元万码★分成任加★找软件作者合作/收购引流软件Thewolf语音验证码接收平台可API
诺宾混拨动态vps/PPTP多地区换IP长期出QQ群QQ号微信精准粉网挣粉各种【活粉变现点这里】客服①大量租售各种qq小号 2892721932找软件作者合作/收购引流软件██ 日出大量网赚粉/交友粉 ██
┏ 集团收量,高价无限收一切量 ┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短视频引流,直播平台粉┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:各大招聘网站一手简历 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购任何微信QQ粉找软件作者合作/收购引流软件大量收QQ活粉交友粉
┃ 收量:短信、邮箱qun发通道 ┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉实力团队大量收粉入群找管理大量收QQ活粉交友粉
┗ 收粉:网赚粉/精准粉,交友粉 ┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购任何微信QQ粉实力团队大量收粉入群找管理大量收QQ活粉交友粉
┏公司实力高价 收 引流软件渠道┓收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 ██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉██收快手火山虎牙,找我换钱██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力高价 收 引流软件渠道┃大量收精准粉██长期大量收粉量大量小都吃██★高薪诚聘SEO大牛 高价买任何量★实力团队大量收粉入群找管理 收快手火山抖音 小视频引流
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉██ 婚恋/抖音/宝妈/空间/快手█████大量全新令牌QQ███实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量有质量,找我换钱██████大量全新令牌QQ███实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███实力大型公司收媒体量███收抖音火山王者引流:1513888885实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███大量资金,来一手代理███收抖音火山王者引流:1513888885实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司实力收 qun 发 邮箱软件 ┃大量收精准粉███有量就有钱,速度来撩███实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理收网赚粉 / 精准粉 / 兼职粉
┃公司最高价收 邮件qun发软件┃█长期大量收购各种活粉█┃  全网大量收  ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
┃公司最高价收 邮件qun发软件┃█ 长期收购各种引流软件 █┃ 各种App交友粉 ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
┃公司最高价收 邮件qun发软件┃大量微信寻合作 接各种扫码授权┃   网赚粉   ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
┃公司最高价收 邮件qun发软件┃▇大量批发高质量QQ处号9位10位▇┃   游戏粉   ┃实力公司 招代理、技术 收线上资源实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
┗公司最高价收 邮件qun发软件┛▇大量批发高质量QQ处号9位10位▇┃   婚恋粉   ┃
实力收扫码进群量
实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
量收微信扫码进群粉,实力粉商来撩收男粉微信扫码进群QQ1324888881 ┃  各种活人粉  ┃
你量真,我需求大
实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
量收微信扫码进群粉,实力粉商来撩大量收男粉扫码进群QQ1324888881 ┃   短视频粉  ┃
你不乱,我不断
实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
量收微信扫码进群粉,实力粉商来撩☆收微信公众号粉丝.日结┃ 全网最高单价收购 ┃一一一一一收qq老接口一一一一一实力团队大量收粉入群找管理█出精准粉/出精准粉/出精准粉█
出少量网赚粉+微信:qunfa000☆收微信公众号粉丝.日结寻求 媒体量合作 有资源的撩我一一一一一收qq老接口一一一一一寻引流高手合作/1万粉以下勿扰█出精准粉/出精准粉/出精准粉█
出少量网赚粉+微信:qunfa000出兼职,网赚,交友粉,扫码进群寻求 媒体量合作 有资源的撩我★长期收网赚粉★流量.引流软件★寻引流高手合作/1万粉以下勿扰█出精准粉/出精准粉/出精准粉█
●国内外动态socks5 可API控制●出精准粉,量大来谈寻求 媒体量合作 有资源的撩我提供聚合支付系统源码+售后寻引流高手合作/1万粉以下勿扰出兼职粉有实力的来
大量收微信男粉QQ249813919█全新处Q██活令牌Q██邮箱Q█寻求 媒体量合作 有资源的撩我█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰出各种精准粉QQ:1955599983
出微信qq交友粉网赚粉精准粉兼职大量出探探交友粉联系Q1962626235寻求 媒体量合作 有资源的撩我寻渠道,收网盟量 Q:1561032994寻引流高手合作/1万粉以下勿扰█微博全新█4级白号█0.18/个█
出售/网赚粉兼职粉精准粉/质量第一██ 出微信女粉/可项目合作 ██大量出活令牌处号一个月号高价收网赚粉 / 兼职粉,平台不限寻引流高手合作/1万粉以下勿扰★高价收网赚兼职粉,引流软件★
大量出qq邮箱推广引流qq950092█IP精灵█最强大的动态IP加速器大量出活令牌处号一个月号q空间转发直发精准网赚粉:q771112寻引流高手合作/1万粉以下勿扰
 ██QQ小号1毛钱/太阳Q/各类QQ██
大量出网赚粉/各种粉/各类用户资源出高质量微信男粉QQ:644949998大量出活令牌处号一个月号出网赚粉兼职粉各种男女粉寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 9943|回复: 437
收起左侧

[易语言模块源码] 易语言操作EXCEL的模块2

  [复制链接]

签到天数:1 天

结帖率:17% (1/6)
发表于 2018-3-8 17:41:46 | 显示全部楼层 |阅读模式
分享例程
界面截图:
备注说明: -
好久没用这个了,把我自己用的共享出来吧,比之前发的多很多命令,比如排序筛选设置数据透视表什么的,用法和之前的一样
PS:源码最下面的一些命令,我并没有测试,如果没有用,自己修改吧,如果公开那里没有打钩的,那基本是无效的,需要用也自己修改
我看一些人总纠结在切换工作表这个问题上,源码里面有切换工作表和切换工作薄的命令,自己用吧
另外,使用的时候注意参数和参数的备注,不要用E.读单元格文本(1).取文本()这样的命令,根本不是这样用
还有些人要求在线程或者内存中使用的,自己修改吧,可以的话发上来大家共享,我是没劲弄了
易语言操作EXCEK模块-加加1222修改.e (263.92 KB, 下载次数: 1203)

点评

很好,超级方便!  发表于 2018-3-10 21:24

评分

参与人数 1好评 +1 精币 +2 收起 理由
为你存在 + 1 + 2 新技能已get√

查看全部评分


友情提醒:请选择可信度高的模块,勿用未知模块,防止小人在模块内加入木马程序。【发现问题模块请到站务投诉】。

您可以选择打赏方式支持楼主

打赏

参与人数 2 打赏积分 理由 收起 打赏时间
倾风听雨声 +10   精币 小小心意,意思一下 2018-4-4 01:48
为你存在 +10   精币 很好,很方便!谢谢 2018-3-10 21:24

查看全部打赏

本帖被以下淘专辑推荐:

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 2018-3-24 20:34:26 | 显示全部楼层
这里也加上例子吧,上一贴本来有的
首先将模块加载(自己将源码编译)
然后定义一个变量,例如“E”,类型为“EXCEL”
接下来是正式使用
E.创建()‘对EXCEL操作之前必须创建EXCEL对象
E.打开()’打开EXCEL文件
E.置单元格文本()‘对EXCEL操作
E.保存()’如果不需要保存可以跳过
E.关闭()‘操作完毕后注意要关闭,否则等于EXCEL放在那里

另外有一个代码“取行数列数”,是这样使用的,首先定义行数和列数这2个整数型变量,然后
E.取行数列数(行数,列数)
这样行数就取到了总行数,列数就取到了总列数
回复 支持 反对

使用道具 举报

签到天数: 6 天

结帖率:0% (0/3)
发表于 昨天 22:14 | 显示全部楼层
ttt0410 发表于 2018-10-12 23:01
我没遇到过,建议你可以只用变量打开一个EXCEL,然后记录这个EXCEL的ID啊句柄什么的,用变量关闭后在查 ...

我是EXCEL2007 ,
后来 我 这样解决:  在启动前记录下进程中的EXCEL,在启动后再记录进程中的EXCEL, 比较得知哪个是模块启动的EXCEL, 最后退出时  就中止模块EXCEL进程
回复 支持 反对

使用道具 举报

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 4 天前 | 显示全部楼层
yworld 发表于 2018-8-17 23:48
我技术不过关呀,我现在设置打印纸张大小都是在控制版面-》打印机那里新建打印纸张的,我以为模块可以新 ...

我又不是给得模块,给的源码对吧,自己修改呗,不会就慢慢学吧,我也是没人教,自己试的,你这个问题我没有需求所以没弄吧大概
回复 支持 反对

使用道具 举报

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 4 天前 | 显示全部楼层
航母上看风景 发表于 2018-9-18 15:36
有点困扰, 进程中的EXCEL 一直存在 ,

EXCEL.关闭工作薄 ()

我没遇到过,建议你可以只用变量打开一个EXCEL,然后记录这个EXCEL的ID啊句柄什么的,用变量关闭后在查看看,一样的话就是没有关闭成功咯,那你就换个软件或者版本试试,我用的是2003和2013,没遇到过
回复 支持 反对

使用道具 举报

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 4 天前 | 显示全部楼层
991238883 发表于 2018-9-24 10:37
.版本 2

.程序集 窗口程序集1

看435楼,紫薯布丁
回复 支持 反对

使用道具 举报

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 4 天前 | 显示全部楼层
dfgtrhgt 发表于 2018-9-26 11:06
.版本 2

.程序集 窗口程序集1

我哪知道你为什么不行,自己调试吧,先看下创建的时候有没有创建到,源码不是有返回值么
回复 支持 反对

使用道具 举报

签到天数: 1 天

结帖率:17% (1/6)
 楼主| 发表于 4 天前 | 显示全部楼层
yjippp 发表于 2018-10-1 21:47
谢谢分享,内容很全面,可以问个问题吗? 对象.获取 (“Excel.Application”) ,可以同时操作2个对象吗?我 ...

你可以一个变量打开2个EXCEL,也可以建立2个EXCEL对象变量来进行操作
回复 支持 反对

使用道具 举报

签到天数: 2 天

结帖率:0% (0/1)
发表于 2018-10-1 21:47:10 | 显示全部楼层
谢谢分享,内容很全面,可以问个问题吗? 对象.获取 (“Excel.Application”) ,可以同时操作2个对象吗?我现在是操作完一个关掉再操作下一个。因为我想同时在2个Excel上操作。Excel就另一个软件打开的,有多个进程的。
回复 支持 反对

使用道具 举报

发表于 2018-9-26 11:06:58 | 显示全部楼层

.版本 2

.程序集 窗口程序集1
.程序集变量 E, EXCEL类

.子程序 _按钮1_被单击

E.创建 ()  ' 对EXCEL操作之前必须创建EXCEL对象
E.打开EXCEL (“D:\1.XLSX”)  ' 打开EXCEL文件
E.置单元格文本 (“A1”, “写入的文本”)  ' 对EXCEL操作
编辑框1.内容 = E.读单元格文本 (1, “A1”)
E.保存 ()  ' 如果不需要保存可以跳过
E.关闭 ()  ' 操作完毕后注意要关闭,否则等于EXCEL放在那里
为什么不好使呢? 一直提示 对象为空!
回复 支持 反对

使用道具 举报

签到天数: 2 天

结帖率:100% (3/3)
发表于 2018-9-24 18:35:30 | 显示全部楼层
支持开源,谢谢分享
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表