精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┏ E3 E5 X58超强双路服务器 ┓找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
2018年好项目,每月多挣好多钱收抖音火山王者引流:1513888885长期 包养全网交友粉大户┃单进程单IP每个模拟器IP不同┃找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
全国PPTP秒换IP 动态IP仅35元/月┏█收购一切流量Q:503830000█┓长期 包养全网交友粉大户┗价格美丽。性能无敌 请咨询┛找软件作者合作/收购引流软件出售长短效HTTP-S5私密IP-高质量
▇▇QQ方面最新软件▇▇●国内外动态socks5 可API控制●长期 包养全网交友粉大户诺宾混拨动态vps/PPTP多地区换IP找软件作者合作/收购引流软件长期出QQ群QQ号微信精准粉网挣粉
大量租售各种qq小号 2892721932出兼职,网赚,交友粉,扫码进群各种【活粉变现点这里】客服①大量出小白兼职宝妈网赚粉找软件作者合作/收购引流软件找实力公司合作
┏集团收量一手短信群fa邮件群发┓╔ 收粉丶卖粉丶大型①群 ╗各种【活粉变现点这里】客服①高价收购漂流瓶量找软件作者合作/收购引流软件寻求实力团队
┃集团收量一手短信群fa邮件群发┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件高效率合作,
┃集团收量一手短信群fa邮件群发┃ 收粉丶卖粉丶大型①群各种【活粉变现点这里】客服②高价收购漂流瓶量找软件作者合作/收购引流软件欢迎来扰!!
┃集团收量一手精准号码微信推广┃收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
┗集团收量一手精准号码微信推广┛收粉丶卖粉丶大型①群各种【活粉变现点这里】客服③高价收购漂流瓶量实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██大量收婚恋宝妈 快手 火山█████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我收粉丶卖粉丶大型①群██ 稳定收交友粉,找我换钱 █████大量全新令牌QQ███实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我╚ 收粉丶卖粉丶大型①群 ╝██收婚恋粉宝妈粉,找我换钱███收收收高质量交友粉收收收██实力团队大量收粉入群找管理无限收任何量
工作室长期出粉,需要的撩我大量收精准粉██收快手火山虎牙,找我换钱██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理拒绝骗子
工作室长期出粉,需要的撩我大量收精准粉██长期大量收粉量大量小都吃██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理拒绝骗子
█无限收各种精准网赚资源█大量收精准粉██ 婚恋/抖音/宝妈/空间/快手██收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种精准引流资源█大量收精准粉███有量有质量,找我换钱███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种群fa指定话术█各种家庭量███实力大型公司收媒体量███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种小视频引流粉█各种家庭量███大量资金,来一手代理███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█无限收各种精准网赚资源█各种家庭量███有量就有钱,速度来撩███收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理无限收任何量
█有量支持引QQ/Q群/微信██长期大量收购各种活粉█┃  全网大量收  ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█欢迎实力来撩,点击进Q群██ 长期收购各种引流软件 █┃ 各种App交友粉 ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█加星盟社群支持免费担保█大量国外微信老号出售┃   网赚粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理大量收男粉扫码进群QQ1324888881
█无限收粉量真实长期合作█▇大量批发高质量QQ处号9位10位▇┃   游戏粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
█星盟社Q群号码868977025█▇大量批发高质量QQ处号9位10位▇┃   婚恋粉   ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理收男粉微信扫码进群QQ1324888881
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃  各种活人粉  ┃收高质量交友粉/只看质量不计成本实力团队大量收粉入群找管理『实力收扫码进群量』
┃高薪诚聘┃安卓市场APP上架人才█8█收批量自动加qq好友软件█8█┃   短视频粉  ┃█收收收高质量交友粉收收收██实力团队大量收粉入群找管理『你量真,我需求大』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000┃ 全网最高单价收购 ┃大量高价收网赚兼职粉,不限平台实力团队大量收粉入群找管理『 你不乱,我不断 』
┃高薪诚聘┃安卓市场APP上架人才出少量网赚粉+微信:qunfa000寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『欢迎实力粉商来撩』
┃高薪诚聘┃安卓市场APP上架人才公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量高价收网赚兼职粉,不限平台寻引流高手合作/1万粉以下勿扰
『 →qq:12587210←』
出兼职粉有实力的来公司实力收引流软件渠道寻求 媒体量合作 有资源的撩我大量收微信男粉QQ249813919寻引流高手合作/1万粉以下勿扰█全新处Q██活令牌Q██邮箱Q█
出微信qq交友粉网赚粉精准粉兼职大量出探探交友粉联系Q1962626235寻求 媒体量合作 有资源的撩我█微博全新█4级白号█0.18/个█寻引流高手合作/1万粉以下勿扰█IP精灵█最强大的动态IP加速器
██QQ小号1毛钱/太阳Q/各类QQ██大量出网赚粉/各种粉/各类用户资源寻求 媒体量合作 有资源的撩我出高质量微信男粉QQ:644949998寻引流高手合作/1万粉以下勿扰出网赚粉兼职粉各种男女粉
邮箱代发,进箱率高,可测试
收大量微信裂变粉 2820301656
大量出活令牌处号一个月号收购跳转微信QQ加粉量Q88128851寻引流高手合作/1万粉以下勿扰█大量高价收QQ双向群+Q402345█
高价收网赚粉 / 兼职粉,平台不限收微信扫码进群男粉QQ:854122288大量出活令牌处号一个月号█拨号VPS服务器4元/天免费测试█寻引流高手合作/1万粉以下勿扰出Q群粉联系QQ:492544249
大量出微信 QQ 群网赚粉 精准活粉大公司大量收微信扫群网赚小白粉大量出活令牌处号一个月号低调出流量寻引流高手合作/1万粉以下勿扰我要租广告位
查看: 418|回复: 6
收起左侧

[已解决] 新手求大神超级列表框怎么写排列数字问题

 关闭 [复制链接]

签到天数:7 天

结帖率:100% (13/13)
发表于 2018-2-13 21:47:21 | 显示全部楼层 |阅读模式
25精币
360截图1843070810098110.bmp

比如 排列出来的数字 从1到25。

我现在删掉 4、5、6、9、的表项,

360截图18750815246063.bmp

到后面我需要的时候,就重新从1开始对比,什么数字被删了,

就添加什么数字进去 4、5、6、9、

最后就排序到后面变成图的样子

360截图175810106487101.bmp

纯新手没学易语言多久,只知道很简单,就是想不出来怎么写。

跪求大神 写个例子。谢谢

最佳答案


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 15 天

发表于 2018-2-13 21:47:22 | 显示全部楼层
超级列表框比对.e (2.76 KB, 下载次数: 8)

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 9 天

结帖率:46% (48/105)
发表于 2018-2-13 21:50:13 | 显示全部楼层
百度搜索冒泡排序之前写过    或者使用   系统核心支持库->数组操作  数组排序 (, )  精易模块  数组_排序 ()

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 9 天

结帖率:46% (48/105)
发表于 2018-2-13 21:56:16 | 显示全部楼层
效果附件已附上 最佳谢谢

排序.e

673.11 KB, 下载次数: 1

排序.gif

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 15 天

结帖率:100% (13/13)
发表于 2018-2-13 22:02:53 | 显示全部楼层
如果程序不关闭
添加一个程序集变量或全局变量数组A
可以在删除表项时把,取标题取到数组A里面
然后要放回去
计次循环
插入表项
置标题

如果程序关闭
那只有双重计次循环
依次取标题,得数组C
标准数组D={1到25}
依次拿1-25和C的每个成员比较
如果相等就
标记=标记+1

如果 标记=0
加入数组A

后面一样

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-2-13 22:34:42 | 显示全部楼层
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 被删除的的项目, 整数型, , "0"

.子程序 __启动窗口_创建完毕
.局部变量 计次1, 整数型

.计次循环首 (20, 计次1)
    超级列表框1.插入表项 (计次1, 到文本 (计次1), , , , )
.计次循环尾 ()

.子程序 _删除表项_按钮_被单击

加入成员 (被删除的的项目, 到整数 (超级列表框1.取标题 (超级列表框1.现行选中项, 0)))
数组排序 (被删除的的项目, 真)
超级列表框1.删除表项 (超级列表框1.现行选中项)

.子程序 _显示被删除的列到尾部_选择框_被单击
.局部变量 计次1, 整数型
.局部变量 计次2, 整数型

.判断开始 (显示被删除的列到尾部_选择框.选中)
    .计次循环首 (取数组成员数 (被删除的的项目), 计次1)
        超级列表框1.插入表项 (-1, 到文本 (被删除的的项目 [计次1]), , , , )
    .计次循环尾 ()
.默认
    .计次循环首 (取数组成员数 (被删除的的项目), 计次1)
        超级列表框1.删除表项 (超级列表框1.查找表项 (到文本 (被删除的的项目 [计次1]), , , ))
    .计次循环尾 ()

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

发表于 2018-2-13 22:40:19 | 显示全部楼层
这里是源码,

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表