精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 论坛浏览速度太慢? 教你赚取精币 - 每日签到

谋生 求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

搜索
订阅<精易模块>源码若快打码 快速★准确★稳定★便宜2017年好项目,每月多挣好多钱██【免费网络验证】无需服务器█实力收购网赚粉长期合作加Q834138██打码兔秒杀一切验证码██
全国PPTP秒换IP 动态IP仅35元/月
若快打码 快速★准确★稳定★便宜
2017年好项目,每月多挣好多钱
██【易卡发卡平台】无需服务器█
实力收购网赚粉长期合作加Q834138█打码兔答题 速度快 极稳定█
★滴滴答题★8元万码★分成任加★火眼答题-韩文日文-高质量答题
██免费网络验证 收款即时到帐█
云速打码全天50%分成★稳定★快速实力收购网赚粉长期合作加Q834138收购一切流量☞QQ:503830000☜
提供稳定微信支付渠道Q:3237546076
全自动手机APP引流脚本,日1000+大量收购一切流量  995799457长期出漂流瓶回复量/男性QQ好友号
实力收购网赚粉长期合作加Q834138
短信接码平台 高提成 Q3404393049
┏高价收各种量,运营商,分光等┓
长期收购微信各种推广渠道
┏--长期收购各类成品引流软件--┓
收网吧转发空间QQ:1513888885
实力收购网赚粉长期合作加Q834138┏ °短信群发内容成功率百分百°┓
┆   高价收网吧,空间转发量  ┆长期收购微信各种推广渠道
║ 长期收购针对性精准QQ人群 ║
收网吧转发空间QQ:1513888885实力收购网赚粉长期合作加Q834138┃ °手机短信群发广告量找老板°┃
┆狂收各类引流, 找软件制作者┆
长期收购微信各种推广渠道
║    合作QQ:2665555557    ║
收网吧转发空间QQ:1513888885
实力收购网赚粉长期合作加Q834138
┗低价出各类广告QQ:5690990┛
┆     联系qq:985013583    ┆
长期收购微信各种推广渠道
║ 长期诚聘各大引擎SEO合作  ║
收网吧转发空间QQ:1513888885实力收购网赚粉长期合作加Q834138
┏x58双路租机,模拟器24开  ┓
┗┈收购物各类资料,短信群发┈┛长期收购微信各种推广渠道
┗-收针对性人群引流加Q群流量┛
出微信男粉空间说说转发Q83099971实力收购网赚粉长期合作加Q834138
┗单进程单IP,最低15元一天 ┛
█IP精灵█最强大的动态IP加速器
长期收购微信各种推广渠道
Thewolf语音验证码接收平台可API
有技术寻项目合作,违规和小单不接
实力收购网赚粉长期合作加Q834138
出加群网吧空间转发量qq;771112
空间转发,相册上传,加群 好友量
长期收购微信各种推广渠道
██给力引流脚本日引2000+
高价收QQ|微信活粉QQ1833448828
实力收购精准粉长期合作加Q834138
日产几万25➕以上活粉.qq5393367
┏--------国外集团重金收购--------
长期收购微信各种推广渠道
█Q群引流 适合国外团队炒群█
收网吧转发空间QQ:1379111111
实力收购精准粉长期合作加Q834138
长期大量收二手微信男粉QQ317573
┃     大量软件单,急需作者      ┃
长期收购微信各种推广渠道
█一手邀请入群量 招稳定代理█
收QQ微信新闻转发:1379111111
实力收购精准粉长期合作加Q834138长期大量收二手微信男粉QQ317573
┃    流量人头网赚量大小都要    ┃
长期收购微信各种推广渠道
█可测试可担保交易 安全放心█
你有量,我有钱QQ:1379111111
实力收购精准粉长期合作加Q834138长期大量收二手微信男粉QQ317573
┃       招SEO大神实地办公       ┃
长期收购微信各种推广渠道
收活粉量大的来
┏ 个人-自动发卡平台源码-出售 ┓
实力收购精准粉长期合作加Q834138长期大量收二手微信男粉QQ317573
┃   高薪招推广客服人事等职位  ┃
长期收购微信各种推广渠道
收活粉量大的来
┗众优支付接口扫码PCWAP网银┛
实力收购精准粉长期合作加Q834138
长期大量收二手微信男粉QQ317573
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
QQ群发量/空间相册量+Q532402
┏██人傻钱多 QQ:753310██┓
实力收购精准粉长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
日产王者量3W+QQ3006306
█ 收成品群/成品号/成品微信  █
实力收购精准粉长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
┏        出高质量交友男粉          ┓
█    收男粉/精准粉/网赚粉     █
实力收购精准粉长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
┗ 日出5000+微信男粉一手引流  ┛
█反正就是人傻钱多收各种活粉█
实力收购精准粉长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
██稳定高产,时速不低██
┗██  菲律宾集团诚招合作 ██┛
实力收广告引流长期合作加Q834138
实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
┏长期收直播APP接口,找实力合作┓
实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
┗收直播APP采集加Q:2381274905┛
实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
出活人加Q群量各种渠道QQ14669699
实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
高价收站群量/运营商量/WAP安卓量
实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
收QQ不封登录或免码接口收Q协议实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
长期收购微信各种推广渠道
████LOL游戏男粉████
高价收各种量、高薪招聘引流大神实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃大量租售各种qq小号 2892721932
███QQ:38336720███
出Q量每天3w+ 550016882
实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃【收西瓜等平台邀请软件】
网咖好友量空间转发 相册转发加群
专业代加QQ微信好友 QQ724881383实力收广告引流长期合作加Q834138实力收各种推广引流渠道和资源
┃重金大量收各种推广渠道/流量┃
出V信男粉QQ男粉要的加Q:5555650
QQ分享引流裂变源码▇日引上万▇
大量收微信粉 QQ2820301656实力收广告引流长期合作加Q834138
大量Q群寻协议合作Q249128710
┗-------点击这里!!找我拿钱-------┛出一手加群量转发量q45343882
█拨号VPS服务器4元/天免费测试█
收微信粉 QQ联系:2286852884 我要租广告位 
查看: 571|回复: 2
收起左侧

[易求助] 鱼刺线程池问题

[复制链接]
结帖率:43% (6/14)
发表于 2017-3-21 00:23:23 | 显示全部楼层 |阅读模式
5精币
这个是论坛里的鱼刺模板,为什么使用5个线程查询100个目标号码,他会5个线程同时查询一个号码,然后就在5个线程查下一个号码,也就是说100目标,使用5个线程就要查询号码500次,不知道什么问题,按道理是5条线程同时查询5个号码,然后已次向下查询才对,谁能帮忙修改下



[e=4].版本 2
.支持库 iext

.子程序 _按钮_开始停止_被单击
.局部变量 text, 文本型
.局部变量 bool, 逻辑型
.局部变量 len, 整数型


集_计次s = 0
集_任务 = 真
集_任务完成 = 假
按钮_开始停止.禁止 = 真
text = 按钮_开始停止.标题
.判断开始 (text = “启动线程”)
    len = 超级列表框1.取表项数 ()
    .如果真 (len < 1)
        信息框 (“请先导入账号”, 48 + 65536, , )
        按钮_开始停止.禁止 = 假
        返回 ()
    .如果真结束

    连续赋值 (0, 已完成数量, 保证显示索引)
    bool = 线程.创建 (&工作)
    .如果真 (bool = 真)
        返回 ()
    .如果真结束

.判断 (text = “停止线程”)
    按钮_开始停止.标题 = “正在停止”
    按钮_暂停继续.禁止 = 真
    按钮_暂停继续.标题 = “暂停验证”
    线程池.销毁 (2, , 真)
    线程.等待2 ()
    按钮_开始停止.标题 = “启动线程”
.默认

.判断结束
按钮_开始停止.禁止 = 假


.子程序 工作
.局部变量 并发线程数, 整数型
.局部变量 bool, 逻辑型
.局部变量 len, 整数型
.局部变量 i, 整数型
.局部变量 空闲线程数, 整数型
.局部变量 int, 整数型
.局部变量 线程工作数, 整数型


按钮_开始停止.标题 = “正在启动”
临界.进入 ()
并发线程数 = 到整数 (编辑框线程.内容)
临界.退出 ()
.如果真 (并发线程数 < 1)
    并发线程数 = 1
.如果真结束
bool = 线程池.创建 (并发线程数)
.如果真 (bool = 假)
    临界.进入 ()
    按钮_开始停止.标题 = “启动线程”
    按钮_开始停止.禁止 = 假
    临界.退出 ()
    返回 ()
.如果真结束

临界.进入 ()
按钮_开始停止.标题 = “停止线程”
按钮_开始停止.禁止 = 假

按钮_暂停继续.标题 = “暂停线程”
按钮_暂停继续.禁止 = 假
len = 超级列表框1.取表项数 () - 1  ' 列表索引从0开始
临界.退出 ()
i = 0
.判断循环首 (i ≤ len)
    内存_优化1 ()
    空闲线程数 = 线程池.取_空闲线程数 ()
    .如果真 (空闲线程数 > 0)
        int = len - i + 1
        .如果真 (int > 空闲线程数)
            int = 空闲线程数
        .如果真结束
        .计次循环首 (int, )
            .如果真 (集_任务完成 = 真)  ' 表示没有目标号码查询,跳出循环
                跳出循环 ()
            .如果真结束
            内存_优化1 ()
            线程池.投递任务 (&Login, i, )
            i = i + 1
            线程工作数 = 线程工作数 + 1
            .如果真 (len + 1 ≠ 线程工作数)
                .判断循环首 (到整数 (编辑框_几次换IP.内容) > 0 且 线程工作数 = 到整数 (编辑框_几次换IP.内容))
                    处理事件 ()
                    .如果真 (IP已工作数 = 到整数 (编辑框_几次换IP.内容))
                        _按钮_拨号_被单击 ()
                        IP已工作数 = 0
                        线程工作数 = 0
                    .如果真结束

                .判断循环尾 ()
            .如果真结束
            程序_延时 (50)
            处理事件 ()
        .计次循环尾 ()
    .如果真结束
    bool = 线程池.等待任务动态 ()
    .如果真 (bool = 假)  ' 返回假 表示线程池被执行销毁 也表示用户手动点了停止
        返回 ()
    .如果真结束
    .如果真 (集_任务完成 = 真)  ' 表示没有目标号码查询,跳出循环
        跳出循环 ()
    .如果真结束

    处理事件 ()
.判断循环尾 ()

' 等待剩余任务执行完毕
.判断循环首 (线程池.取_是否空闲 () = 假)
    .如果真 (线程池.取_状态 () ≠ #线程池_正在工作)
        返回 ()
    .如果真结束
    bool = 线程池.等待任务动态 (100)
    处理事件 ()
.判断循环尾 ()


' 执行停止
临界.进入 ()
按钮_开始停止.禁止 = 真
按钮_开始停止.标题 = “正在停止”
按钮_暂停继续.禁止 = 真
按钮_暂停继续.标题 = “暂停线程”
临界.退出 ()
线程池.销毁 (2, , 真)

信息框 (“执行完毕!”, 64 + 65536, , )
临界.进入 ()
按钮_开始停止.标题 = “启动线程”
按钮_开始停止.禁止 = 假
临界.退出 ()


.子程序 Login
.参数 index, 整数型
.局部变量 正则, 正则表达式类
.局部变量 U, 账户
.局部变量 session, 文本型
.局部变量 文本, 文本型
.局部变量 i, 整数型
.局部变量 bool, 逻辑型


.如果真 (线程池.取_状态 () ≠ #线程池_正在工作)
    返回 ()
.如果真结束
临界.进入 ()
U.Num = 删首尾空 (超级列表框1.取标题 (index, 1))
U.Pwd = 删首尾空 (超级列表框1.取标题 (index, 2))
临界.退出 ()
超级列表框1.置标题 (index, 3, “开始执行”)
U.str = 登录QQ (U.Num, U.Pwd, U.Cookies, U.G_tk, U.nc)
.如果 (U.str = “登录成功”)
    超级列表框1.置标题 (index, 3, “登录成功”)
    超级列表框1.置标题 (index, 4, U.Cookies)
    Log (U.Num + “登录成功”)
    U.skey = 计算GetSkey (U.Cookies)
    U.G_tk = 计算GetG_tk (U.skey)
    超级列表框1.置标题 (index, 5, U.G_tk)
    查询 (index)
.否则
    超级列表框1.置标题 (index, 3, U.str)
    Log (U.Num + U.str)

.如果结束
原子_递增 (IP已工作数)
原子_递增 (已完成数量)

.子程序 查询
.参数 index, 整数型
.局部变量 A, 账户
.局部变量 S, 文本型
.局部变量 集_计次i, 整数型
.局部变量 c_计次s, 整数型

临界.进入 ()
A.Num = 删首尾空 (超级列表框1.取标题 (index, 1))
A.Cookies = 删首尾空 (超级列表框1.取标题 (index, 4))
A.LDW = 删首尾空 (超级列表框1.取标题 (index, 5))
超级列表框1.置标题 (index, 6, “查询中”)
临界.退出 ()
.循环判断首 ()
    内存_优化1 ()
    .如果真 (集_任务 = 假)  ' 表示手动停止,跳出循环
        跳出循环 ()
    .如果真结束
    A.目标 = 超级列表框2.取标题 (集_计次i, 1)
    超级列表框2.置标题 (集_计次i, 2, “搜索中”)
    A.str = 查询昵称 (A.目标, A.Cookies, A.LDW)
    临界.进入 ()
    .如果 (寻找文本 (A.str, #频繁, , 假) ≠ -1 或 寻找文本 (A.str, “


补充内容 (2017-3-21 12:57):
附件:下载地址链接:https://share.weiyun.com/1ecfc37bb07c7a5a108b4b3d3d93d0d8 (密码:cV2cNe)


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 25 天

结帖率:91% (21/23)
发表于 2017-3-21 00:33:48 | 显示全部楼层
直接上传附件吧

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:43% (6/14)
 楼主| 发表于 2017-3-21 01:03:36 | 显示全部楼层
拉面 发表于 2017-3-21 00:33
直接上传附件吧

附件:下载地址链接:https://share.weiyun.com/1ecfc37bb07c7a5a108b4b3d3d93d0d8 (密码:cV2cNe)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|Archiver|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表