精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 论坛浏览速度太慢? 教你赚取精币 - 每日签到

找工作/接单 百度招聘- 论坛招聘- 论坛接单- 猪八戒接单- 威客中国-

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

搜索
订阅<精易模块>源码若快打码 快速★准确★稳定★便宜
██招贤纳士:10K-30k保底██
██【免费网络验证】无需服务器███打码兔秒杀一切验证码██
全国PPTP秒换IP 动态VPN仅35元/月
若快打码 快速★准确★稳定★便宜
█招聘技术兼职或者公司全职皆可
██【易卡发卡平台】无需服务器█
█打码兔答题 速度快 极稳定█
★滴滴答题★8元万码★分成任加★█火眼答题-超速-极稳-高质量█
█不管是pc还是移动端的技术皆可
云速打码全天50%分成★稳定★快速█斗鱼/熊猫人气招代理Q5919620█
免费淘客内部券API接口,技术支持
高价收针对粉 Q1685993352
█必须精通c++或者java作为基础
☆英数打码☆
大量令牌QQ6毛一个求大量业务合作
免费淘客内部券API接口,技术支持
高价长期收网吧端家庭端空间转发量
█通讯协议、内存接口、php皆可
████百万资金收各种暴力项目
★★★★收引流源码Q987303★★★
收各种渠道引流量--可测试的来
高价长期收网吧端家庭端空间转发量
QQ38336720,非技术勿加,请自重
 ┏ - --百万佣金_____诚招代理-- - ┓
★★★★出各种量Q987303★★★★
收各种运营商量
高价长期收网吧端家庭端空间转发量
斗鱼最便宜人气招代理QQ910222910
║收各种引流渠道/_招SEO黑白帽║
高价收网吧端家庭端转发量各种量
收各种棋牌引流渠道
高价长期收网吧端家庭端空间转发量
斗鱼高等级人气招代理QQ910222910
║收各种棋牌引流渠道192375066║
高价收网吧端家庭端转发量各种量
收各种棋牌引流渠道
高价长期收网吧端家庭端空间转发量
斗鱼经济公司接口招代理910222910
║高价-收安卓预装或静默安装量║
高价收网吧端家庭端转发量各种量
收各种棋牌引流渠道全网最强微博助手加微信免费送
斗鱼大主播超级智能弹幕招合作
┗- - - ---收各种渠道引流量--- - - ┛
高价收网吧端家庭端转发量各种量
收安卓预装或静默安装量出售令牌QQ 0.8元
斗鱼全屏弹幕招代理QQ910222910
代引高质量Q好友,微信粉qq6075189
高价收网吧端家庭端转发量各种量
无限高价收各种量 联系Q52334800
收网吧转发空间QQ:1513888885
大量收优酷好莱坞【一手】激活码
多省市动态VPS动态PPTP推广有返利
█出网吧QQ好友/群量Q:2129527889
【高价出售IOS云控源码Q4765236】
收网吧转发空间QQ:1513888885
出运营商弹窗 跳转量 Q3264734403高价收各种量联系QQ86952358█出网吧QQ好友/群量Q:2129527889
┏ - --百万佣金_____诚招代理-- - ┓收一手真实微信女粉QQ331391816
██----大量--手机卡--接码----██
新天诚自动发卡平台
█出网吧QQ好友/群量Q:2129527889
║百万佣金_诚招代理Q10868768║
超高价格收各种量 空间转发量全收██----接--短---信--验证码----██
结算最快、服务最好
█出网吧QQ好友/群量Q:2129527889
║收各种引流渠道/_招SEO黑白帽║
超高价格收各种量 空间转发量全收
██----接--短---信--验证码----██多个美女客服任你选择█出网吧QQ好友/群量Q:2129527889
║百万佣金_诚招代理Q10868768║超高价格收各种量 空间转发量全收
██散单勿扰QQ:1557371777██
██████网站防360微信QQ拦截
出直播平台主播关注量Q:977322367
┗- - - ---百万佣金诚招代理--- - - ┛
█码云打码 秒过一切主流验证码█
██----只接一手--贩子勿扰----██
!!!!!招聘安卓HOOK开发人员!!!!!出精准微信号关注量日产百万粉丝
微奇兵微信群发助手秒杀炮手蓝狐
█↑↑↑速度快 价格低 超稳定█
出微信男粉:QQ80000627
!!!!!可独立分析APK程序!!!!!出精准微信号关注量日产百万粉丝
令牌QQ0.5元(已养好,7天回收包补)
全自动手机APP引流脚本,日1000+安徽实地工作,有封包基础即可!网吧好友量每天10W新量QQ8571909大量出售陌陌流量
极速识别 滑块/汉字/字母 低至2元
日出十万主动加群男粉Q2322979792
出售QQ好友代加双向拉群空间
 <免费网络验证>自动收款新手包教
集团实力收购一切流量q:3518191744
高价收购各种引流渠道Q1241404222
█收购精准风水算命粉丝█
收购一切流量☞QQ:503830000☜ 我要租此广告位 
查看: 291|回复: 2
收起左侧

[易求助] 鱼刺线程池问题

[复制链接]

签到天数:28 天

结帖率:43% (6/14)
发表于 2017-3-21 00:23:23 | 显示全部楼层 |阅读模式
5精币
这个是论坛里的鱼刺模板,为什么使用5个线程查询100个目标号码,他会5个线程同时查询一个号码,然后就在5个线程查下一个号码,也就是说100目标,使用5个线程就要查询号码500次,不知道什么问题,按道理是5条线程同时查询5个号码,然后已次向下查询才对,谁能帮忙修改下



[e=4].版本 2
.支持库 iext

.子程序 _按钮_开始停止_被单击
.局部变量 text, 文本型
.局部变量 bool, 逻辑型
.局部变量 len, 整数型


集_计次s = 0
集_任务 = 真
集_任务完成 = 假
按钮_开始停止.禁止 = 真
text = 按钮_开始停止.标题
.判断开始 (text = “启动线程”)
    len = 超级列表框1.取表项数 ()
    .如果真 (len < 1)
        信息框 (“请先导入账号”, 48 + 65536, , )
        按钮_开始停止.禁止 = 假
        返回 ()
    .如果真结束

    连续赋值 (0, 已完成数量, 保证显示索引)
    bool = 线程.创建 (&工作)
    .如果真 (bool = 真)
        返回 ()
    .如果真结束

.判断 (text = “停止线程”)
    按钮_开始停止.标题 = “正在停止”
    按钮_暂停继续.禁止 = 真
    按钮_暂停继续.标题 = “暂停验证”
    线程池.销毁 (2, , 真)
    线程.等待2 ()
    按钮_开始停止.标题 = “启动线程”
.默认

.判断结束
按钮_开始停止.禁止 = 假


.子程序 工作
.局部变量 并发线程数, 整数型
.局部变量 bool, 逻辑型
.局部变量 len, 整数型
.局部变量 i, 整数型
.局部变量 空闲线程数, 整数型
.局部变量 int, 整数型
.局部变量 线程工作数, 整数型


按钮_开始停止.标题 = “正在启动”
临界.进入 ()
并发线程数 = 到整数 (编辑框线程.内容)
临界.退出 ()
.如果真 (并发线程数 < 1)
    并发线程数 = 1
.如果真结束
bool = 线程池.创建 (并发线程数)
.如果真 (bool = 假)
    临界.进入 ()
    按钮_开始停止.标题 = “启动线程”
    按钮_开始停止.禁止 = 假
    临界.退出 ()
    返回 ()
.如果真结束

临界.进入 ()
按钮_开始停止.标题 = “停止线程”
按钮_开始停止.禁止 = 假

按钮_暂停继续.标题 = “暂停线程”
按钮_暂停继续.禁止 = 假
len = 超级列表框1.取表项数 () - 1  ' 列表索引从0开始
临界.退出 ()
i = 0
.判断循环首 (i ≤ len)
    内存_优化1 ()
    空闲线程数 = 线程池.取_空闲线程数 ()
    .如果真 (空闲线程数 > 0)
        int = len - i + 1
        .如果真 (int > 空闲线程数)
            int = 空闲线程数
        .如果真结束
        .计次循环首 (int, )
            .如果真 (集_任务完成 = 真)  ' 表示没有目标号码查询,跳出循环
                跳出循环 ()
            .如果真结束
            内存_优化1 ()
            线程池.投递任务 (&Login, i, )
            i = i + 1
            线程工作数 = 线程工作数 + 1
            .如果真 (len + 1 ≠ 线程工作数)
                .判断循环首 (到整数 (编辑框_几次换IP.内容) > 0 且 线程工作数 = 到整数 (编辑框_几次换IP.内容))
                    处理事件 ()
                    .如果真 (IP已工作数 = 到整数 (编辑框_几次换IP.内容))
                        _按钮_拨号_被单击 ()
                        IP已工作数 = 0
                        线程工作数 = 0
                    .如果真结束

                .判断循环尾 ()
            .如果真结束
            程序_延时 (50)
            处理事件 ()
        .计次循环尾 ()
    .如果真结束
    bool = 线程池.等待任务动态 ()
    .如果真 (bool = 假)  ' 返回假 表示线程池被执行销毁 也表示用户手动点了停止
        返回 ()
    .如果真结束
    .如果真 (集_任务完成 = 真)  ' 表示没有目标号码查询,跳出循环
        跳出循环 ()
    .如果真结束

    处理事件 ()
.判断循环尾 ()

' 等待剩余任务执行完毕
.判断循环首 (线程池.取_是否空闲 () = 假)
    .如果真 (线程池.取_状态 () ≠ #线程池_正在工作)
        返回 ()
    .如果真结束
    bool = 线程池.等待任务动态 (100)
    处理事件 ()
.判断循环尾 ()


' 执行停止
临界.进入 ()
按钮_开始停止.禁止 = 真
按钮_开始停止.标题 = “正在停止”
按钮_暂停继续.禁止 = 真
按钮_暂停继续.标题 = “暂停线程”
临界.退出 ()
线程池.销毁 (2, , 真)

信息框 (“执行完毕!”, 64 + 65536, , )
临界.进入 ()
按钮_开始停止.标题 = “启动线程”
按钮_开始停止.禁止 = 假
临界.退出 ()


.子程序 Login
.参数 index, 整数型
.局部变量 正则, 正则表达式类
.局部变量 U, 账户
.局部变量 session, 文本型
.局部变量 文本, 文本型
.局部变量 i, 整数型
.局部变量 bool, 逻辑型


.如果真 (线程池.取_状态 () ≠ #线程池_正在工作)
    返回 ()
.如果真结束
临界.进入 ()
U.Num = 删首尾空 (超级列表框1.取标题 (index, 1))
U.Pwd = 删首尾空 (超级列表框1.取标题 (index, 2))
临界.退出 ()
超级列表框1.置标题 (index, 3, “开始执行”)
U.str = 登录QQ (U.Num, U.Pwd, U.Cookies, U.G_tk, U.nc)
.如果 (U.str = “登录成功”)
    超级列表框1.置标题 (index, 3, “登录成功”)
    超级列表框1.置标题 (index, 4, U.Cookies)
    Log (U.Num + “登录成功”)
    U.skey = 计算GetSkey (U.Cookies)
    U.G_tk = 计算GetG_tk (U.skey)
    超级列表框1.置标题 (index, 5, U.G_tk)
    查询 (index)
.否则
    超级列表框1.置标题 (index, 3, U.str)
    Log (U.Num + U.str)

.如果结束
原子_递增 (IP已工作数)
原子_递增 (已完成数量)

.子程序 查询
.参数 index, 整数型
.局部变量 A, 账户
.局部变量 S, 文本型
.局部变量 集_计次i, 整数型
.局部变量 c_计次s, 整数型

临界.进入 ()
A.Num = 删首尾空 (超级列表框1.取标题 (index, 1))
A.Cookies = 删首尾空 (超级列表框1.取标题 (index, 4))
A.LDW = 删首尾空 (超级列表框1.取标题 (index, 5))
超级列表框1.置标题 (index, 6, “查询中”)
临界.退出 ()
.循环判断首 ()
    内存_优化1 ()
    .如果真 (集_任务 = 假)  ' 表示手动停止,跳出循环
        跳出循环 ()
    .如果真结束
    A.目标 = 超级列表框2.取标题 (集_计次i, 1)
    超级列表框2.置标题 (集_计次i, 2, “搜索中”)
    A.str = 查询昵称 (A.目标, A.Cookies, A.LDW)
    临界.进入 ()
    .如果 (寻找文本 (A.str, #频繁, , 假) ≠ -1 或 寻找文本 (A.str, “


补充内容 (2017-3-21 12:57):
附件:下载地址链接:https://share.weiyun.com/1ecfc37bb07c7a5a108b4b3d3d93d0d8 (密码:cV2cNe)


回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 29 天

结帖率:91% (21/23)
发表于 2017-3-21 00:33:48 | 显示全部楼层
直接上传附件吧

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 28 天

结帖率:43% (6/14)
 楼主| 发表于 2017-3-21 01:03:36 | 显示全部楼层
拉面 发表于 2017-3-21 00:33
直接上传附件吧

附件:下载地址链接:https://share.weiyun.com/1ecfc37bb07c7a5a108b4b3d3d93d0d8 (密码:cV2cNe)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|Archiver|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3400082,企业QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表