精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 论坛浏览速度太慢? 教你赚取精币 - 每日签到

找工作/接单 百度招聘- 论坛招聘- 论坛接单- 猪八戒接单- 威客中国-

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

搜索
订阅<精易模块>源码若快打码 快速★准确★稳定★便宜免费淘客内部券API接口,技术支持██【免费网络验证】无需服务器███打码兔秒杀一切验证码██
斗鱼最便宜人气招代理QQ910222910
全国PPTP秒换IP 动态VPN仅35元/月
若快打码 快速★准确★稳定★便宜
免费淘客内部券API接口,技术支持
██【易卡发卡平台】无需服务器█
█打码兔答题 速度快 极稳定█
斗鱼经济公司接口招代理910222910
★滴滴答题★8元万码★分成任加★█火眼答题-超速-极稳-高质量█
极速识别 滑块/汉字/字母 低至2元
云速打码全天50%分成★稳定★快速
██免费网络验证 收款即时到帐█
出租出售百万好友,合作双向代加
██防护██网站防360微信QQ拦截
收购一切流量☞QQ:503830000☜
☆英数打码☆
██软件作者+q:5208060求合作██
好友量 加群量 逆向群 微信粉
全自动手机APP引流脚本,日1000+
收各种运营商量
┏--实力收各种引流渠道有实力来--┓
 ┎      长期高价收各种量     ┓
┎高价回收各类流量Q1634469555┓
高价收质量网吧好友量.QQ2222221
长期高价收相册转发量:352509500
收各种棋牌引流渠道
║   长期高价收各种量:Q群量    ║
┆高价收各种量 空间转发量┆
┆ 承包各类引流,找软件制作者 ┆
高价收质量网吧好友量.QQ2222221
长期高价收相册转发量:352509500
收各种棋牌引流渠道
║   长期高价收各种量:空间量    ║
┆高价收各种量 空间转发量┆
┆        百万诚聘站群优化者      ┆
高价收质量网吧好友量.QQ2222221
另高价收上传相册号:352509500
收各种棋牌引流渠道
║   长期高价收各种量:转发量    ║
┆       高价大量收q群量     ┆
┆     高价收网吧,空间转发量   ┆
高价收质量网吧好友量.QQ2222221
另高价收上传相册号:352509500
收安卓预装或静默安装量┗---------收各种渠道引流量---------┛
┗ ┈ 收各种渠道引流流量 ┈ ┛
┗ ┈ 收购物各类资料,短信群发 ┈ ┛
量越大越好 价格好商量 稳定的来
另高价收上传相册号:352509500
收网吧转发空间QQ:1513888885
长期高价收男性流量  QQ363717313 
 精准附近人采集wxid附近人打招呼
┏---高arpu棋牌运营团队---┓
代加微信好友和代拉人加指定微群
重金求Q群拉活人,联系Q:2015886292
收网吧转发空间QQ:1513888885
长期高价收男性流量  QQ363717313 
精准添加手机号微信号无需提取wxid
 ‖---- 找渠道商长期合作 ---‖   
----单价0.8-2元起/个---
重金求Q群拉活人,联系Q:2015886292
【网络公司百万数据接广告推广】
█长期高价收微信男粉-稳定来█微信全套引流软件
┗--- QQ :178954370 ---┛ 
----好友来源广告群发-----
┏----收wap站 裂变量-微信流量---┓
【大量出Q好友/转发/加群/空间】
█长期高价收微信男粉-稳定来█
█欧美包月静态稳定socks5/http█
收租企业Q好友出空间男粉加Q群联系qq7785559
║收各种渠道流量/一手微信批发商║ 
【寻求大公司实力合作包量变现】
█长期高价收微信男粉-稳定来█
█国外优质API代理socks5/https█
收租活跃Q群出空间男粉加Q群联系qq7785559
┗--有货的请加微信:41752088谈--┛
出直播平台主播关注量Q:977322367┏--收量日结QQ308539080--┓
提供稳定微信支付渠道Q:3237546076
收租QQ群排名合作
出精准粉,量大需要联系18441169
高价收各种流量诚邀逆向开发合作
1y发卡网欢迎入驻,免一月手续费
┗--收量日结QQ308539080--┛Q群现货出售 代加代发 Q970224799模拟器VPN 手机VPN 切换 稳定高效
出售一手活人加群量Q2213857791
出粉 出粉 出粉 出粉
网吧好友量转发相册加群逆向加群
【7折全国全网手机话费代充+技术】
长期收购各类引流软件/协议
收网吧转发空间QQ:1513888885
出租出售百万单双好友,代加双向
█联众打码低至65/万作者分成46.5% 
大量接短信-语音验证码-支持aip对接长期收各种流量 995799457 我要租此广告位   
查看: 161|回复: 5
收起左侧

[已解决] 判断文件夹内最新创建的文件名

 关闭 [复制链接]
结帖率:91% (137/151)
发表于 2017-8-13 00:33:14 | 显示全部楼层 |阅读模式
5精币
问题:获取文件夹内最新创建的文件名. 也就是最后创建的文件是哪个.

自己也能弄出来,但是方法觉得很笨,看看大家用的啥方法

最佳答案

查看完整内容

我这里只贴出了txt的.最后创建文件夹时间对比.用到了精易模块.代码如下.有问题追问题: .版本 2 .支持库 spec .子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行 .局部变量 局_数组, 文本型, , "0" .局部变量 局_计次, 整数型 .局部变量 局_创建时间, 文本型 .局部变量 局_上次时间, 文本型 文件_枚举 (“E:\ceshi”, “*.txt”, 局_数组, 真) .计次循环首 (取数组成员数 (局_数组), 局_计次) 文件 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳
结帖率:50% (3/6)
发表于 2017-8-13 00:33:15 | 显示全部楼层
我这里只贴出了txt的.最后创建文件夹时间对比.用到了精易模块.代码如下.有问题追问题:

.版本 2
.支持库 spec

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 局_数组, 文本型, , "0"
.局部变量 局_计次, 整数型
.局部变量 局_创建时间, 文本型
.局部变量 局_上次时间, 文本型

文件_枚举 (“E:\ceshi”, “*.txt”, 局_数组, 真)
.计次循环首 (取数组成员数 (局_数组), 局_计次)
    文件_取时间 (局_数组 [局_计次], 局_创建时间, , )
    .判断开始 (到时间 (局_创建时间) > 到时间 (局_上次时间))
        调试输出 (局_创建时间)
    .默认

    .判断结束
    局_上次时间 = 局_创建时间
.计次循环尾 ()


补充内容 (2017-8-13 00:44):
上面代码有问题.修改后重新贴上.测试失误.

评分

参与人数 1荣誉 +1 收起 理由
笨潴 + 1 热心帮助他人,荣誉+1,希望继续努力(*^__^*) 嘻嘻!

查看全部评分

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 6 天

结帖率:100% (4/4)
发表于 2017-8-13 00:34:44 | 显示全部楼层
枚举文件,取创建时间,排序时间。

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:50% (3/6)
发表于 2017-8-13 00:49:11 | 显示全部楼层
不好意思.重新贴上.
.版本 2
.支持库 spec

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 局_文件名, 文本型
.局部变量 局_创建时间, 文本型

子程序1 (局_文件名, 局_创建时间)
调试输出 (局_文件名, 局_创建时间)
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 子程序1
.参数 参_接收文件名, 文本型, 参考
.参数 参_接收创建时间, 文本型, 参考
.局部变量 局_数组, 文本型, , "0"
.局部变量 局_计次, 整数型
.局部变量 局_创建时间, 文本型
.局部变量 局_上次时间, 文本型
.局部变量 局_最新创建文件时间, 文本型

文件_枚举 (“E:\ceshi”, “*.txt”, 局_数组, 真)
.计次循环首 (取数组成员数 (局_数组), 局_计次)
    文件_取时间 (局_数组 [局_计次], 局_创建时间, , )
    .如果真 (到时间 (局_创建时间) > 到时间 (局_上次时间))
        局_上次时间 = 局_创建时间
        参_接收文件名 = 局_数组 [局_计次]
        参_接收创建时间 = 局_创建时间
    .如果真结束

.计次循环尾 ()

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 13 天

结帖率:100% (5/5)
发表于 2017-8-13 00:57:49 | 显示全部楼层
http://bbs.eyuyan.com/read.php?tid=397806
把相关文件数据写在自定数据数组中,时间排序就OK了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

结帖率:90% (9/10)
发表于 2017-8-13 11:26:05 | 显示全部楼层
这个不是太清楚

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|Archiver|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 8000736861120671429,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表