精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 我关注人的新帖 教你赚取精币 - 每日签到


求职/招聘- 论坛接单- 资源出售

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

2019年好项目,每月多挣好多钱高价收购宝妈、女性粉:1513888885长期 包养全网交友粉大户高价收购QQ单项双向好友日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
2019年好项目,每月多挣好多钱高价收购宝妈、女性粉:1513888885长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
寻找有实力的短信群fa通道███████████████长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
寻找有实力的短信群fa通道█         高 收 益         █长期 包养全网交友粉大户高价包养交友粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
寻找有实力的短信群fa通道█         高 转 化         █各种【活粉变现点这里】客服①高价包养交友粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
寻找有实力的短信群fa通道█         高 留 存         █各种【活粉变现点这里】客服①┃ 服务器出租E3单路E5双路E5 ┃ 日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
寻找有实力的短信群fa通道█ 独立后台 实时刷新 █各种【活粉变现点这里】客服①┃ 模拟器虚拟机多开! 单进程 ┃日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
星盟社群无限收各种引流资源█        游       戏        █各种【活粉变现点这里】客服②实力公司大量收40人小群日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
星盟社群无限收精准网赚资源█       收       益        █各种【活粉变现点这里】客服② 大量收 交友粉 游戏粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
星盟社群免费帮对接担保交易█        合       作        █各种【活粉变现点这里】客服②婚恋粉 各种活粉日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
星盟社群欢迎买卖方进群合作█   5 2 4 1 2 0 0 3 2  █┏┏ 全网大量收交友粉 ┓┓出兼职粉 网赚粉 媒体竞价开户日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
星盟社群免费帮对接渠道资源███████████████〓 各种APP交友粉 〓出兼职粉 网赚粉 媒体竞价开户日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
█████████████████████长期大量收购各种活粉█〓  抖音 快手 火山  〓██████████████████日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
█    高 收 益 项 目   ██ 长期收购各种引流软件 █〓   附 近 人    〓█    高价 收购   █日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
█    寻 大 佬 合 作   █寻有实力的短信群fa通道加Q293950〓 各论坛美拍部落 〓█  qq群发量 群发技术 █日吃8000+收一手零转化微信小群粉★高价收精准粉加微信365299999★
█   支 持     日 结  █寻有实力的短信群fa通道加Q293950〓各种活人粉实力对接〓█  联系 qq7305830  █收收收.微信扫码进群.加QQ9703796★高价收精准粉加微信365299999★
█  咨询QQ   880194  █寻有实力的短信群fa通道加Q293950〓大小量通吃欢迎来撩〓█    高价 收购   █收收收.微信扫码进群.加QQ9703796★高价收精准粉加微信365299999★
█ 公司最高价收群发软件渠道 █寻有实力的短信群fa通道加Q293950〓 稳定全年365天收 〓█  qq群发量 群发技术 █收邮件群fa+q7463544★高价收精准粉加微信365299999★
█ 公司最高价收群发软件渠道 █寻有实力的短信群fa通道加Q293950〓 无限 收交友粉 〓█  联系 qq7305830  █收邮件群fa+q7463544★高价收精准粉加微信365299999★
█ 公司最高价收群发软件渠道 █实力收精准粉大量稳定加v293950┗┗ 全网最高单价收粉 ┛┛█ 点击进入流量资源共享群███ 人傻钱多 QQ:753310 ██★高价收精准粉加微信365299999★
█ 公司最高价收群发软件渠道 █实力收精准粉大量稳定加v293950◆大量收婚恋宝妈快手火山◆█ 点击进入流量资源共享群█职业短信代发13年QQ:811000★高价收精准粉加微信365299999★
█ 公司最高价收群发软件渠道 █实力收精准粉大量稳定加v293950◇稳定收交友粉,找我换钱◇██████████████████广告费 30万/天★高价收精准粉加微信365299999★
█ 公司高价收 引流 软件 渠道 █实力收精准粉大量稳定加v293950◆收快手火山虎牙找我换钱◆盛辉社群无限收各种引流资源150个人客服团队★高价收精准粉加微信365299999★
█ 公司高价收 引流 软件 渠道 █实力收精准粉大量稳定加v293950◇长期收交友粉大小量通吃◇盛辉社群无限收精准网赚资源微信303142385★高价收精准粉加微信365299999★
█ 公司高价收 引流 软件 渠道 █★实力出抖音网赚精准粉加Q317738◆ 婚恋/抖音/空间/快手 ◆盛辉社群免费帮对接担保交易实力正规男科★高价收精准粉加微信365299999★
█ 公司高价收 引流 软件 渠道 █★实力出抖音网赚精准粉加Q317738◇ 优质有量的找我换钱 ◇盛辉社群欢迎买卖方进群合作高价收精准粉丝★高价收精准粉加微信365299999★
████████████████████无限量收宝妈、女性、兼职粉◆ 实力大型公司收媒体量 ◆盛辉社群免费帮对接渠道资源寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
长期收网赚粉 QQ8904040无限量收宝妈、女性、兼职粉◇ 大量资金 ,来一收代理 ◇★█实力收精准粉QQ825270505█★寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
实力团队收粉 QQ8904040无限量收宝妈、女性、兼职粉◆ 无限收交友粉交友粉 ◆█收精准引流粉,微信公众号粉█寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
长期收网赚粉 QQ8904040无限量收宝妈、女性、兼职粉◇ 各种活人粉实力对接 ◇█收精准引流粉,微信公众号粉█寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
实力团队收网赚粉入群找管理无限量收宝妈、女性、兼职粉全网大量收各种APP交友粉,█收精准引流粉,微信公众号粉█寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
实力团队收网赚粉入群找管理【实力公司无限收各种思路引流活粉】包养全网交友粉大户★█实力收精准粉QQ825270505█★寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
大量收微信进群粉联系q584121900↑↑↑↑↑↑↑↑↑加QQ:575199999全网大量收各种APP交友粉,鼎信社群高价收WZ各类热门资源寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
出微信qq交友粉网赚粉精准粉兼职长期出QQ群QQ号微信精准粉网挣粉包养全网交友粉大户鼎信社万人对接基地高效出粉收粉寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
大量出各类精准用户粉,全行业私信出QQ群微信QQ号交友粉网赚粉兼职粉全网大量收各种APP交友粉,███ 鼎信社群 行业顶尖 ███寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
最新引流方式,告别引流难题★工作室长期出抖音WZ粉Q159907包养全网交友粉大户鼎信社群欢迎各类 商人对接入驻寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
出APP精准网赚兼职粉★█大量收微信朋友圈粉█★全网大量收各种APP交友粉,鼎信社欢迎各类粉商精英对接交流寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
高价收网吧终端量联系Q1908886662大量出QQ网赚粉微信粉Q群精准活粉包养全网交友粉大户█网站统计█I引流系统█I寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
大量收精准网赚兼职粉 Q979168819Q群粉及交友一手资源Q:4925442249大量出wz粉质量好单价低QQ22256140人小群/精准小群/一手带报表寻求引流高手商务合作,进群找管理★高价收精准粉加微信365299999★
40人的精准小群 /一手截图报表██████出精准网赚粉兼职粉高价收微信进群活跃男粉公司高价收购流量寻求引流高手商务合作,进群找管理我要租广告位
查看: 2856|回复: 78
收起左侧

[易语言纯源码] EClass 易语言类操作 模块开源

  [复制链接]

签到天数:22 天

结帖率:100% (1/1)
发表于 2019-5-5 14:44:26 | 显示全部楼层 |阅读模式
分享源码
界面截图: -
是否带模块: 纯源码
备注说明: -
本帖最后由 LeyBc 于 2019-5-5 16:08 编辑

EClass 易语言类操作 本模块主要是为了弥补易语言类的不足
易语言的类:
1、成员无法公开,无法对成员直接赋值
2、未公开的方法,无法直接调用[貌似是废话]

封装了 英文方法和中文方法
  1. .版本 2

  2. .子程序 bindMember, , ,
  3. .参数 MemberNameArr, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 CallFun, 整数型, , 调用方法 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  5. .参数 pFunc, 整数型, ,
  6. .参数 buf, 整数型, 可空 ,
  7. .参数 arg1, 整数型, 可空 ,
  8. .参数 arg2, 整数型, 可空 ,
  9. .参数 arg3, 整数型, 可空 ,
  10. .参数 arg4, 整数型, 可空 ,
  11. .参数 arg5, 整数型, 可空 ,

  12. .子程序 getClassFunCount, 整数型, , 取方法数 先调用 getClassFunPoint

  13. .子程序 getClassFunPoint, 整数型, , 取类方法指针 先调用 getClassPoint

  14. .子程序 getClassPoint, 整数型, , 取类指针
  15. .参数 Class, 通用型, 参考 ,

  16. .子程序 getFunPoint, 整数型, , 取方法指针 先调用  getClassFunCount 取出指针后 可以直接 对方法调用 不论方法是否公开
  17. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  18. .子程序 getMemberCount, 整数型, , 取成员数 先调用 getClassPoint

  19. .子程序 getMemberPoint, 整数型, ,  取成员指针 先调用  getMemberCount  取出指针后 可以直接 对 数据进行读写
  20. .参数 Id, 整数型, ,

  21. .子程序 getVarAddress, 整数型, , 取地址 如果写入数据是非整数型,调用这个
  22. .参数 Var, 通用型, 参考 ,

  23. .子程序 setMemberValueById, 逻辑型, , 置成员值 先调用  getMemberCount
  24. .参数 ID, 整数型, ,
  25. .参数 Value, 整数型, , 非整数型 请调用 取地址

  26. .子程序 setMemberValueByName, 逻辑型, , 先调用  getMemberCount  和 bindMember
  27. .参数 MemberName, 文本型, ,
  28. .参数 Value, 整数型, , 非整数型 请调用 取地址


复制代码



2019-05-05_143240.png




  1. .版本 2

  2. .子程序 绑定成员, , ,
  3. .参数 成员名, 文本型, 数组, {arg1,arg2,arg3}按顺序绑定

  4. .子程序 取成员数, 整数型, , 先调用 取类指针

  5. .子程序 取成员指针, 整数型, , 先调用  取成员数  取出指针后 可以直接 对 数据进行读写
  6. .参数 第几个成员, 整数型, ,

  7. .子程序 取地址, 整数型, , 如果写入数据是非整数型,调用这个
  8. .参数 参数, 通用型, 参考 ,

  9. .子程序 取方法数, 整数型, , 先调用 取类方法指针

  10. .子程序 取方法指针, 整数型, , 先调用  取方法数 取出指针后 可以直接 对方法调用 不论方法是否公开
  11. .参数 第几个方法, 整数型, , 1、_初始化 2 、_销毁 固定

  12. .子程序 取类方法指针, 整数型, , 先调用 取类指针

  13. .子程序 取类指针, 整数型, ,
  14. .参数 类, 通用型, 参考 ,

  15. .子程序 调用方法, 整数型, , 调试状态下,方法内 不能使用 输出调试文本 调试输出等命令 编译后不影响
  16. .参数 子程序指针, 整数型, ,
  17. .参数 缓存区, 整数型, 可空 ,
  18. .参数 参数1, 整数型, 可空 ,
  19. .参数 参数2, 整数型, 可空 ,
  20. .参数 参数3, 整数型, 可空 ,
  21. .参数 参数4, 整数型, 可空 ,
  22. .参数 参数5, 整数型, 可空 ,

  23. .子程序 置成员值_ID, 逻辑型, , 先调用  取成员数
  24. .参数 第几个成员, 整数型, ,
  25. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址

  26. .子程序 置成员值_名称, 逻辑型, , 先调用  取成员数 和 绑定成员
  27. .参数 参数名, 文本型, ,
  28. .参数 欲写入的值, 整数型, , 非整数型 请调用 取地址</font>


复制代码




2.png


调用代码截图


3.png


类截图


4.png


运行效果演示




ys.gif
调试结果 截图
5.png
此模块中不含任何的广告,也不带任何盈利性质。如有雷同,纯属巧合
如果你觉得不错,请点赞即可!回帖下载

说明:代码写的不太严谨,比如某些数组越界的可能性没去判断,各位需要的话,自行判断一下

EClass_易语言类操作.e (29.96 KB, 下载次数: 87)
QQ截图20190505142932.jpg

评分

参与人数 11好评 +10 精币 +28 收起 理由
含沙射影 + 1 + 2 支持开源~!感谢分享
易语言资源网 + 1 + 5 支持开源~!感谢分享
Ossian + 1 + 2 支持开源~!感谢分享
songue + 1 + 2 精彩文章希望继续努力
kyo9766 + 1 + 2 支持开源~!感谢分享
ljaihong + 1 + 2 支持开源~!感谢分享
101232 + 1 + 2 支持开源~!感谢分享
Sad.XkM + 1 + 2 支持开源~!感谢分享
大司命 + 1 + 5 支持开源~!感谢分享
汉族 + 1 + 2 支持开源~!感谢分享
冯古屋 + 2 支持开源~!感谢分享

查看全部评分


您可以选择打赏方式支持楼主

本帖被以下淘专辑推荐:

签到天数: 2 天

发表于 昨天 20:25 | 显示全部楼层
支持开源~!感谢分享
回复

使用道具 举报

签到天数: 19 天

发表于 前天 21:55 | 显示全部楼层
一定一定多一点s'q
回复

使用道具 举报

签到天数: 2 天

发表于 5 天前 | 显示全部楼层
支持开源,方便使用
回复

使用道具 举报

签到天数: 26 天

发表于 5 天前 | 显示全部楼层
支持开源~!感谢分享
回复

使用道具 举报

签到天数: 24 天

发表于 7 天前 | 显示全部楼层
無需多言,直接點讚!
回复

使用道具 举报

签到天数: 1 天

发表于 7 天前 | 显示全部楼层
支持开源.楼主666
回复

使用道具 举报

签到天数: 17 天

结帖率:0% (0/1)
发表于 2019-5-19 20:53:02 | 显示全部楼层
感谢分享!
回复

使用道具 举报

签到天数: 6 天

发表于 2019-5-19 20:18:45 | 显示全部楼层
支持开源.楼主666
回复

使用道具 举报

签到天数: 14 天

结帖率:67% (2/3)
发表于 2019-5-18 13:02:40 | 显示全部楼层
支持分享, 谢谢开源
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /2 下一条

发布主题 收藏帖子 返回列表 按钮

sitemap|易语言源码|易语言教程|易语言论坛|诚聘英才|易语言模块|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3422125,QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 揭阳市揭东区精易科技有限公司 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表