精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 论坛浏览速度太慢? 教你赚取精币 - 每日签到

找工作/接单 百度招聘- 论坛招聘- 论坛接单- 猪八戒接单- 威客中国-

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

搜索
订阅<精易模块>源码若快打码 快速★准确★稳定★便宜
强制加群|高质量|联系QQ:7777762
██【免费网络验证】无需服务器███打码兔秒杀一切验证码██
全国800万秒换IP动态VPN仅35元/月
若快打码 快速★准确★稳定★便宜
强制加群|高质量|联系QQ:7777762
██【易卡发卡平台】无需服务器█
█打码兔答题 速度快 极稳定█
大量收空间转发量相册等QQ7212210
Thewolf语音验证码接收平台可API
强制加群|高质量|联系QQ:7777762
█火眼答题-超速-极稳-高质量█云速打码全天50%分成★稳定★快速
大量收空间转发量相册等QQ7212210每天10万男性量需要联系Q22288847
█陌陌动态男粉日出10wQQ:949369
最高价收各种流量qq:18903072
长期出王者量qq:52365783
0.4无限收网吧强制进Q群量qq807015
█████打码平台/最低1元/万题
 ☆英数打码☆
免费淘客内部券API接口,技术支持
【26元】给你加3000微信好友█ 
极速稳定识别平台 高并发 低至2元
质量转盘游戏号q6417954
斗鱼<最便宜人气>招代理910222910
免费淘客内部券API接口,技术支持
验证码识别定制联系QQ3244540580
★收陌陌社交粉游戏粉Q491474952★大量收空间转发量相册量Q29012668
斗鱼<高等级人气>招代理910222910
【枫叶打码 九宫 天龙 QQ码特价】
无限收网吧强制好友 联系99644
40W网吧好友加群逆向量Q950092
大量收空间转发量相册量Q29012668
斗鱼人气热门推荐招代理910222910
█拨号vps服务器5元/天免费测试█
无限收网吧强制好友 联系99644
承接投票评选活动。QQ:80098213
大量收空间转发量相册量Q29012668
斗鱼经济公司接口招代理910222910
███ 微信公众号收粉.日结!
无限收网吧强制好友 联系99644
██ 实力高价收购各种流量!██
大量收网吧域名跳转量QQ29012668
斗鱼tv<全屏弹幕>招代理910222910
███ 微信公众号收粉.日结!
多大量都吃的下 联系Q:99644 
██ 实力高价收购各种流量!██
大量收运营商域名跳转量Q29012668
出售活令牌QQ单价1.0元
███ 微信公众号收粉.日结!
全网最高价收 联系 99644
★滴滴答题★8元万码★分成任加★
日出2万微信粉:包养=低价格高质量
诚招团队开发【淘宝复制软件】急~
cps平台寻渠道 需要联系3225787607
淘客软件招推广100%分成Q3861151
各种直播粉丝关注合作 Q:709093018█斗鱼/熊猫人气招代理Q5919620█
诚招大神开发【淘宝复制软件】急~
24小时出LOL精准粉 联系q:975542
无限高价收各种量 联系Q481476614
最高价收量共赢合作QQ:931334887
一直播花椒人气粉丝诚招代理
╰→诚信收APP精准男粉Q1090302552
无限收各种强制进Q群量q290208720
█长期稳定收质量男粉Q80003865█
无限收网吧强制好友联系Q76498 我要租此广告位   
查看: 114|回复: 6
收起左侧

[已解决] 超级列表框数字相加

 关闭 [复制链接]

签到天数:24 天

结帖率:100% (6/6)
发表于 2017-3-21 11:46:38 | 显示全部楼层 |阅读模式
50精币
就是把金额那些累计加起来 显示在标签里
大神写个例子呗 QQ截图20170321102912.jpg 123.rar (136.8 KB, 下载次数: 4)

最佳答案

查看完整内容

.版本 2 .支持库 iext .支持库 spec .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 索引, 整数型 .局部变量 n, 整数型 .局部变量 数, 整数型 .计次循环首 (30, n) 超级列表框1.插入表项 (索引, , , , , ) 超级列表框1.置标题 (索引, 2, 到文本 (n)) .计次循环尾 () .计次循环首 (超级列表框1.取表项数 (), n) 数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2)) .计次循 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 17 天

结帖率:100% (18/18)
发表于 2017-3-21 11:46:39 | 显示全部楼层
.版本 2
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 索引, 整数型
.局部变量 n, 整数型
.局部变量 数, 整数型

.计次循环首 (30, n)
    超级列表框1.插入表项 (索引, , , , , )
    超级列表框1.置标题 (索引, 2, 到文本 (n))
.计次循环尾 ()
.计次循环首 (超级列表框1.取表项数 (), n)
    数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2))
.计次循环尾 ()
调试输出 (数)



您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 17 天

结帖率:100% (18/18)
发表于 2017-3-21 11:54:59 | 显示全部楼层
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 数, 整数型
.局部变量 n, 整数型

.计次循环首 (超级列表框1.取表项数 (), n)
    数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2))
.计次循环尾 ()
标签1.标题 = 到文本 (数)
没注意到你放了源码..

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:56:17 | 显示全部楼层
  
变量循环首 (0, 超级列表框1.取硐钍 (), 1, n)
标签1.标题 = 到文本 (到数值 (标签1.标题)到数值 (超级列表框1.取晏 (n, 2)))
变量循环尾 ()


i支持库列表   支持库注释   
iext扩展界面支持库一


您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:56:42 | 显示全部楼层
  1. .版本 2
  2. .支持库 iext

  3. .变量循环首 (0, 超级列表框1.取表项数 (), 1, n)
  4.     标签1.标题 = 到文本 (到数值 (标签1.标题) + 到数值 (超级列表框1.取标题 (n, 2)))
  5. .变量循环尾 ()
复制代码

补充内容 (2017-3-21 11:57):
循环计算 前 先  标签1.标题=""  清空一下 防止和上次内容重复计算

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:58:13 | 显示全部楼层
  1. .版本 2
  2. .支持库 iext

  3. .子程序 _按钮1_被单击
  4. .局部变量 n, 整数型

  5. 标签1.标题 = “”
  6. .变量循环首 (0, 超级列表框1.取表项数 (), 1, n)
  7.     标签1.标题 = 到文本 (到数值 (标签1.标题) + 到数值 (超级列表框1.取标题 (n, 2)))
  8. .变量循环尾 ()
复制代码

补充内容 (2017-3-21 11:58):
这样就完美了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 23 天

结帖率:100% (19/19)
发表于 2017-3-21 11:59:46 | 显示全部楼层
新建 易程序 (3).zip (167.55 KB, 下载次数: 3)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

关闭

精易论坛 - 有你更精彩上一条 /1 下一条

快速回复 收藏帖子 返回列表

sitemap|易语言教程|易语言源码|易语言论坛|诚聘英才|易语言模块|Archiver|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3400082,企业QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表