精易论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

用微信号发送消息登录论坛

新人指南 邀请好友注册 - 论坛浏览速度太慢? 教你赚取精币 - 每日签到

找工作/接单 百度招聘- 论坛招聘- 论坛接单- 猪八戒接单- 威客中国-

论坛版规 总版规 - 建议/投诉 - 应聘版主 - 精华帖总集 积分说明 - 禁言标准 - 有奖举报

搜索
订阅<精易模块>源码若快打码 快速★准确★稳定★便宜
█出网吧加群量|联系QQ949369
██【免费网络验证】无需服务器███打码兔秒杀一切验证码██
全国PPTP秒换IP 动态VPN仅35元/月
若快打码 快速★准确★稳定★便宜
█出网吧加群量|联系QQ949369
██【易卡发卡平台】无需服务器█
█打码兔答题 速度快 极稳定█
★滴滴答题★8元万码★分成任加★【26元】给你加3000微信好友█ 
██棋牌游戏公司:招贤纳士██
█火眼答题-超速-极稳-高质量█云速打码全天50%分成★稳定★快速
谁要第三方接口联系我Q939788885
 ☆英数打码☆
██招技术主管和技术型人才██
最高价收各种流量qq:18903072
极速识别 滑块/汉字/字母 低至2元
谁要第三方接口联系我Q939788885
最高价收空间转发Q3360924172
██美工·前端·客户端·服务端██收全网直播app播放地址解析
免费淘客内部券API接口,技术支持
网吧好友量0.1加群量0.3Q950092
大量收空间转发量相册量Q1998532【枫叶打码 九宫 天龙 QQ码特价】收全网直播app播放地址解析免费淘客内部券API接口,技术支持
收各种运营商量
大量收空间转发量相册量Q1998532
██出售令牌号大量0.8██
收全网直播app播放地址解析▲高价收引流软件 q:245014016▲
收各种棋牌引流渠道大量收空间转发量相册量Q1998532
斗鱼最便宜人气招代理QQ910222910
收全网直播app播放地址解析收QQ空间转发量相册量
收各种棋牌引流渠道
大量收空间转发量相册量Q1998532
斗鱼高等级人气招代理QQ910222910
收全网直播app播放地址解析收QQ空间转发量相册量
收各种棋牌引流渠道
大量收空间转发量相册量Q1998532
斗鱼人气热门推荐招代理910222910
活人加群 需要的加Q3576000484
收QQ空间转发量相册量
收安卓预装或静默安装量
出网咖好友群 可中介QQ1620549634
斗鱼经济公司接口招代理910222910
免费上QQ令牌技术上令牌不要钱
收QQ空间转发量相册量
高价收Q空间转发量QQ709078880█
最高价收空间相册量转发量Q877770
斗鱼全屏弹幕招代理QQ910222910
收网吧转发空间QQ:1513888885
收QQ空间转发量相册量
无限高价收各种量 联系Q481476614最高价收空间相册量转发量Q877770
出售令牌号 0.9
收网吧转发空间QQ:1513888885
代拉男性活人进群可担保Q11809030
收可上传相册Q号:1721982666
最高价收空间相册量转发量Q877770
█高价大量收质量男粉Q80003865█
收空间相册量网吧量Q:1685588898█无限量收各种量Q8956858█
收可上传相册Q号:1721982666
最高价收空间相册量转发量Q877770█斗鱼/熊猫人气招代理Q5919620█收空间相册量网吧量Q:1685588898█无限量收各种量Q8956858█
收可上传相册Q号:1721982666
最高价收空间相册量转发量Q877770
出售引流软件 联系q12998049
收空间相册量网吧量Q:1685588898
█无限量收各种量Q8956858█
收可上传相册Q号:1721982666
全网最强微博助手加微信免费送
★收各类辅助激活安装量收益高★
收空间相册量网吧量Q:1685588898█无限量收各种量Q8956858█
收可上传相册Q号:1721982666
寻高质量高转化流,质量好的联系
★高价收各类PC端流量引流渠道★
收空间相册量网吧量Q:1685588898█无限量收各种量Q8956858█
91hka.com就要好卡诚邀商户秒结算
寻高质量高转化流,质量好的联系
★长期收游戏辅助量,收益高高高★
███百兆E3机器出租9/天███
█拨号vps服务器5元/天免费测试█
微信软件全功能寻求合作QQ5883569
寻高质量高转化流,质量好的联系
▲▲高价收斗鱼人气软件▲合作▲ 
长期出售高质量男性粉引流进QQ群高价收相册转发人气号Q2997909741
出游戏男粉日产上万QQ:1013326110寻高质量高转化流,质量好的联系
稳定收质量男粉Q号:9587982
长期出售高质量男性粉引流进QQ群高价收相册转发人气号Q2997909741
█████打码平台/最低1元/万题
收各种渠道引流量--可测试的来
大量收王者LOL量 联系QQ448098222
大量收好友量丶Q群量丶微信粉丝量
大量收微信指定群5元一个
我要租此广告位    
查看: 119|回复: 6
收起左侧

[已解决] 超级列表框数字相加

 关闭 [复制链接]

签到天数:23 天

结帖率:100% (6/6)
发表于 2017-3-21 11:46:38 | 显示全部楼层 |阅读模式
50精币
就是把金额那些累计加起来 显示在标签里
大神写个例子呗 QQ截图20170321102912.jpg 123.rar (136.8 KB, 下载次数: 4)

最佳答案

查看完整内容

.版本 2 .支持库 iext .支持库 spec .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 索引, 整数型 .局部变量 n, 整数型 .局部变量 数, 整数型 .计次循环首 (30, n) 超级列表框1.插入表项 (索引, , , , , ) 超级列表框1.置标题 (索引, 2, 到文本 (n)) .计次循环尾 () .计次循环首 (超级列表框1.取表项数 (), n) 数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2)) .计次循 ...

回答提醒:如果本帖被关闭无法回复,您有更好的答案帮助楼主解决,请发表至 源码区 可获得加分喔。
友情提醒:本版被采纳的主题可在 申请荣誉值 帖子申请荣誉值,获得 1点 荣誉值,荣誉值可兑换终身vip用户组哦。
快捷通道:申请荣誉值无答案申请取消悬赏投诉有答案未采纳为最佳

签到天数: 9 天

结帖率:95% (19/20)
发表于 2017-3-21 11:46:39 | 显示全部楼层
.版本 2
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 索引, 整数型
.局部变量 n, 整数型
.局部变量 数, 整数型

.计次循环首 (30, n)
    超级列表框1.插入表项 (索引, , , , , )
    超级列表框1.置标题 (索引, 2, 到文本 (n))
.计次循环尾 ()
.计次循环首 (超级列表框1.取表项数 (), n)
    数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2))
.计次循环尾 ()
调试输出 (数)



您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 9 天

结帖率:95% (19/20)
发表于 2017-3-21 11:54:59 | 显示全部楼层
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 数, 整数型
.局部变量 n, 整数型

.计次循环首 (超级列表框1.取表项数 (), n)
    数 = 数 + 到整数 (超级列表框1.取标题 (n - 1, 2))
.计次循环尾 ()
标签1.标题 = 到文本 (数)
没注意到你放了源码..

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:56:17 | 显示全部楼层
  
变量循环首 (0, 超级列表框1.取硐钍 (), 1, n)
标签1.标题 = 到文本 (到数值 (标签1.标题)到数值 (超级列表框1.取晏 (n, 2)))
变量循环尾 ()


i支持库列表   支持库注释   
iext扩展界面支持库一


您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:56:42 | 显示全部楼层
  1. .版本 2
  2. .支持库 iext

  3. .变量循环首 (0, 超级列表框1.取表项数 (), 1, n)
  4.     标签1.标题 = 到文本 (到数值 (标签1.标题) + 到数值 (超级列表框1.取标题 (n, 2)))
  5. .变量循环尾 ()
复制代码

补充内容 (2017-3-21 11:57):
循环计算 前 先  标签1.标题=""  清空一下 防止和上次内容重复计算

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 20 天

结帖率:98% (87/89)
发表于 2017-3-21 11:58:13 | 显示全部楼层
  1. .版本 2
  2. .支持库 iext

  3. .子程序 _按钮1_被单击
  4. .局部变量 n, 整数型

  5. 标签1.标题 = “”
  6. .变量循环首 (0, 超级列表框1.取表项数 (), 1, n)
  7.     标签1.标题 = 到文本 (到数值 (标签1.标题) + 到数值 (超级列表框1.取标题 (n, 2)))
  8. .变量循环尾 ()
复制代码

补充内容 (2017-3-21 11:58):
这样就完美了

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

签到天数: 23 天

结帖率:100% (20/20)
发表于 2017-3-21 11:59:46 | 显示全部楼层
新建 易程序 (3).zip (167.55 KB, 下载次数: 5)

您可以选择打赏方式支持他

打赏
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则 致发广告者

快速回复 收藏帖子 返回列表

sitemap|易语言教程|易语言源码|易语言论坛|诚聘英才|易语言模块|Archiver|手机版|联系我们|精易论坛
拒绝任何人以任何形式在本论坛发表与中华人民共和国法律相抵触的言论,本站内容均为会员发表,并不代表精易立场!
揭阳精易科技有限公司申明:我公司所有的培训课程版权归精易所有,任何人以任何方式翻录、盗版、破解本站培训课程,我们必将通过法律途径解决!
公司简介:揭阳市揭东区精易科技有限公司致力于易语言教学培训/易语言学习交流社区的建设与软件开发,多年来为中小企业编写过许许多多各式软件,并把多年积累的开发经验逐步录制成视频课程供学员学习,让学员全面系统化学习易语言编程,少走弯路,减少对相关技术的研究与摸索时间,从而加快了学习进度!
防范网络诈骗,远离网络犯罪 违法和不良信息举报电话0663-3400082,企业QQ: 800073686,邮箱:800073686@b.qq.com
Powered by Discuz! X3.2 ( 粤ICP备12094385号-1) 粤公网安备 44522102000125

快速回复 返回顶部 返回列表